Starting the program

The Steel Joint module can be started in one of the following ways:

  • Click Start button of Windows status bar and select All programs -> FEM-Design…

    1585727855492-430.png

     

  • Click Windows desktop -> FEM-Design 19 icon to start up the FEM-Design Command Center. Click on Steel Joint-icon.

    1585727906819-413.png

When starting the Steel Joint module a Code, configuration dialog pops out. Here the user has to select a code for the calculation. The code selection influences the values of safety factors, as well as the range of available modelling materials.

1585728096467-123.png

Introduction

The Steel Joint module covers 51 joints that are classified into 7 types:

  • Column splice
  • Beam splice
  • Column base
  • Beam to beam
  • Beam to column
  • Knee
  • Bracing

Each type includes several solutions, where different bar cross-section or different components are used, (end plate, splice plate, weld, bolt…). Solutions may include additional options that can be chosen for different number of joined bars or different bar topology (e.g. Y, X, K bracing joints).

The following table shows all the possible joints.

TypeSolutionOptions
Column splice1585730203534-718.pngCS11585729952680-461.png--
CS21585729267159-295.png--
CS31585729135282-377.png--
CS41585729570574-697.png--
CS51585729660667-737.png--
CS61585729705953-304.png--
Beam splice1585728313969-146.pngBS11585730132811-524.png--
BS21585730040571-862.png--
BS31585730053736-772.png--
BS41585730067001-365.png--
BS51585730080683-734.png--
BS61585730094047-971.png--
BS71585730103465-940.png--
Beam to beam1585730220425-521.pngBB11585730988022-177.png--
BB21585730941873-337.png--
BB31585730951285-527.png--
BB41585730960783-130.png--
BB51585730969698-734.png--
Column base1585730230177-780.pngCB11585730910397-230.png--
CB21585730168683-371.png--
Beam to column1585729519621-267.pngBC11585731048460-764.png--
BC21585731182929-873.png--
BC31585731192923-715.png--
BC41585731202930-969.png--
BC51585731258497-285.png1585731086632-479.pngA
1585731062051-372.pngB
BC61585731217784-987.png--
BC71585731224833-326.png--
BC81585731235651-566.png--
Knee1585729480225-201.pngKN11585730817948-940.png--
KN21585730579005-458.png--
KN31585730589175-430.png--
KN41585730600701-645.png--
KN51585730679525-133.png1585730780123-181.pngA
1585730747845-573.pngB
KN61585730691331-367.png1585730778306-449.pngA
1585730746475-343.pngB
KN71585730699227-537.png--
KN81585730710150-388.png--
Bracing1585729359917-347.pngBJ11585730500634-777.png1585730409780-110.pngY
1585730418255-799.pngX
1585730514640-865.pngK
BJ21585730280524-460.png1585730409780-110.pngY
1585730450749-532.pngX
1585730517203-787.pngK
BJ31585730359428-644.png1585730409780-110.pngY
1585730452759-668.pngX
1585730519577-408.pngK
BJ41585730370733-129.png--
BJ51585730381786-506.png--
BJ61585730394642-875.png--

Steel joint

User interface

The user interface of the standalone module contains the following parts:

  • Navigation panel
  • 3D model of the joint
  • Calculation window
  • Collection
  • Enter Documentation module
light.png

Toolbars, Menu bar and Status bar are the standard FEM-Design components that are located in all modules’ interface (see FEM-Design User Manual, Basic concept -> User interface chapter).

 

1585731632554-593.png

Navigation panel

Navigation panel is located on the left side. All user input takes place on this panel.

3D model of the joint

The 3D model of the joint is located on the right side. It is updated in real time. When any joint’s parameter is modified, the 3D model will be updated immediately.

Calculation window

Calculation window by default is placed in Navigation panel, in the Design panel. The user can however, change its position. This window displays calculations, errors and warnings.

Collection

The collection of the designed joints is located at the up-left corner. In this part of the interface the designed joints can be selected for modification.

Entering Documentation module

The button to enter the Documentation module is located on the top-right corner. For more information see Chapter 2.7.

Joint

Designing of a joint in the standalone module is performed in 3 main steps.

  • Selecting a joint
  • Setting data
  • Designing the joint

First, the user has to choose a joint type (1), then a solution (2), and an option (3), if available. User can step forward to the Data panel by clicking on the Next button (4).

1585731740929-972.png

Data

Basic data

In the up-right of the Data panel the following data of bars connected to a joint can be set:

  • Cross-section(s)
  • Material(s)
  • Geometry (in some solutions)
  • Buckling data (in case of column splices and column bases, more details come later)

1585731755104-804.png

light.pngThe program will automatically set the geometry of the joint components if the Setup components automatically when cross-section changed option is enabled. Otherwise, the components will not be modified after the cross-section has changed.

1585731770983-882.png

Cross section

The section library displays only those sections that are relevant for selected joint type. The library can be exported to a file, or imported from a file.

1585731809709-116.png

light.pngIn the cross-section library only the same type of sections can be imported.

If a new section needs to be created, or the user wants to modify or delete the existing sections, it can be done in the Edit section library dialog, or by launching the Section Editor from the Tools menu (or the Toolbar).

1585731856602-139.png    1585731860973-436.png

light.pngFor more information about section editing, see FEM-Design User Manual, Structure Definition -> Properties -> Cross-section chapter.

Material

The material library contains some standard steel grades. The library can be exported to a file, or imported from a file.

1585731871905-757.png

warning.pngIn the material library there is a new partial factor called Gamma M5, which refers to the resistance of hollow and pipe sections (see Eurocode 1993-1-8, 2.2).

The user can create a new material by pressing the New button.

1585731896310-511.png

Geometry

In case of some joints it is possible to define the inclination of bars.

1585731905861-290.png

Buckling data

In some joints buckling data are present. They are considered in automatic calculation of 2nd order effects, if necessary.

1585731911721-263.png

Load combinations

Load combinations can be defined at the bottom of the Data panel.

1585731919568-292.png

light.pngA selected load combination can be deleted by pressing Delete.

The 2nd order effect is considered in column splice and column base joints. If 2nd order calculation is marked by X in the Load combinations table, it is supposed that the internal forces come from 2nd order calculation.

Otherwise, internal forces are supposed to come from 1st order calculations and 2nd order effect is calculated automatically, based on the buckling data defined by the user in the Basic data table.

1585731948864-100.png

The user can step forward to the Design panel by clicking on the Next button.

Design

Modify, add and remove components

In the Design panel, components of the joint (e.g. end plate, splice plate, bolts, weld, etc.) can be modified. Additionally, some components such as stiffeners, haunches, etc. can be added or removed by setting Yes/No option in Apply.

A selected component is always highlighted in orange color in the 3D model.

1585732044106-937.png

Bolts

By selecting Bolts the user can define the bolt’s size, quality and other parameters.

The Bolt library provides a possibility to create, modify, and delete the bolts, as well as the import or export from / to a file.

Bolt size

1585732303129-501.png

Bolt position in general case

In general cases (like splice plates, fin plates, etc.) the number of the bolt rows, columns, distance between the columns (c) , distance between the rows (e) and the distance of the first row from the plate’s edge (e0) can be set by the user. The bolt columns are automatically positioned symmetrically in the plate.

1585732112071-958.png

light.pngThe bolts arrangement figure is automatically refreshed when changes are applied.

If in some cases, the bolts arrangement drawing and the dimensions are too small or too big, it is because the figure is not scaled properly. The user has the opportunity to change the scale of the drawing in order to see the figure clearly.

1585732167915-822.png

Bolt position in end plate for moment-resistant joints

In case of end plates for moment-resistant joints the user has more possibilities to define the bolts position.

There may be either 2 or 4 bolts in a row and the distance between the inner bolts (c1) and the outer bolts (c2) have to be set. Then for each row the user can define the:

  • Number of the bolts
  • Distance of the row relative to one of the following positons:
    • Top flange
    • Bottom flange
    • Top haunch (if available)
    • Bottom haunch (if available)
    • Bottom plate edge
    • Top plate edge
    • Previous bolt row

1585732405499-228.png     1585732409809-605.png 

Change solution

Change solution button is located in the bottom-right of the Design panel. A joint solution can be changed only if there is/are another solution(s) available (if the button is active). When the solution is changed, internal forces will remain the same.

1585732440890-532.png

1585732445372-436.png

1585732450713-847.png

Calculation window

Content

Utilizations and a failure mode of the joint are displayed in the Calculation dialog. Each calculation has a reference to the specific standard.

The calculation results can be displayed either for the maximum, or for selected load combination.

1585732554210-974.png

Moving the calculation window

The Calculation window is located at the bottom left corner as default, but the user can relocate it by docking the window to the blue arrows shown below.

1585732562850-542.png

warning.png

When the Calculation window is docked on the bottom-left (default solution) it is not visible in the interface in Joint and Data panels – only in Design panel.

If the user wants to see the window in all interfaces, then it should be relocated to one of the remaining four docking positions.

Collection

The purpose of Collection is to collect and document the joints that belong to one model.

When a joint is designed, it can be added to the collection by clicking on Finish button and assigning a name to it.

1585732596655-480.png

After saving the designed joint, a new joint can be started. Designed joint can be reloaded from the list for modification.

1585732602991-608.png

Any joint in Collection can be displayed in a separate dialog along with a 3D model of it. In this dialog the user can rename, copy or delete the joints.

1585732623758-888.png

light.png

The 3D preview area behaves like the model space in other modules, therefore:

  • right clicking in the model space will pop up the view commands,
  • dragging the view by holding the middle mouse button will animate pan the view,
  • using the wheel on the mouse will zoom in and out the model view,
  • using CTRL + middle mouse button will animate rotate the model view.

1585732662259-427.png

Documentation

General

FEM-Design automatically generates documentation for each joint added to the Collection. The documentation is located in Documentation module.

The documentation contains the input data of the joint (Member data, Load combinations, data of all components) and detailed calculations, so called detailed result.

1585732697991-214.png

Printing

Setup a printer

The printing process requires a printer(s) associated with the section(s) of the current documentation. If a section does not have a defined printer (Undefined), you can add one by:

  • selecting the section name in the document list (1),
  • pressing Properties button in the Control panel (2),
  • pressing Printer setup button (3),
  • Selecting a printer from the dropdown list (4).

1585732836076-721.png

warning.pngIf you assign a PDF printer all sections, you can save your documentation as a PDF file.

Print range

The completed document, or only some parts of it, can be printed out with Control Panel’s Print tool or File -> Print document.

The user can set the Page rage as:

  • All -> The whole document (all pages) will be printed out.
  • Selection -> The objects selected in the Control panel (multi-selection also works) and their pages will be printed out.
  • Pages -> Only selected pages will be printed. Enter page number and/or page ranges by separating with commas and by using “-“ (an example: 1,10,15-20,25, etc.).

1585732876161-203.png

Export to .docx format

It is possible to export the documentation into the Office OpenXML (.docx) file. In the Documentation module press the Save as .docx button at the bottom right corner of the Control panel.

1585732903901-653.png

Save as Office open XML (docx) document dialog will appear. Here the user can decide the followings:

  • here to save the result file, 
  • which MS Office Word template file to use (optional),
  • whether to mark the Documentation Sections in comments or not (only in Documentation module).

1585732911245-602.png

warning.pngThe own template must be based on the original template file called Template for FEM-Design document templates.dotx located in your local user folder at your PC in Documents\FEM-Design document templates folderas this file contains the style required for the correct export.
warning.pngMS Office Word 2007 or newer is required for opening files with .docx distribution.

It is highly recommended to mark the documentation sections in the exported file, since the page rendering in MS Word and in FEM-Design are different. Furthermore, the exported document has A4 format pages. Therefore, if there are pages in the FEM-DEsign Documentation with different size, it is easier to find them and change their size in the result .docx file with section marks.

Using own Word templates is useful when the FEM-Design Documentation contains Title block, since it is not possible to export it to .docx. As an alternative, the user can create a Word template with custom headers and footers, and use it for the export.

warning.pngSince MS Word has more sophisticated solutions for creating the table of contents, FEM-Design does not export it to the .docx document. However, the chapters are exported therefore, the table of contents can be created in MS Word easily.
light.png

More information and useful hint can be found in the Save as .docx FAQ document accessible from the Help menu.

Advanced documentation tools

Documentation module is a powerful tool that allows you to create multi-page documentation with titles, figures, texts, tables, images, headers, footers, table of content etc.

In order to find out more about all the possibilities that the documentation module can offer, please read the Documentation chapter.

Created by Fredrik Lagerström on 2020/04/01 09:52
Copyright 2019 StruSoft AB
FEM-Design Wiki