FEM-Design Section Editor gives the possibility to define, edit and store profiles for the bar elements (beam, column and truss element).

The functions of the Section Editor:

  • Drawing new sections
  • Definition of new sections by parameters,
  • Definition of complex sections by mixing drawing and standard profiles,
  • Editing cross-sections,
  • Calculation of sectional data
  • Profile registration and organizing.

Section Editor can be started directly from design modules that work with bar elements from the Tools menu.

1584518862042-922.png
Figure: Section Editor as a built-in tool of design modules

Section Editor can be started as an independent FEM-Design application by clicking the 1584518890573-420.png Section Editor icon in the “FEM-Design tools” folder of:

  • Start > All Programs > FEM-Design…
  • Windows Taskbar > FEM-Design System Tray 1584518904696-586.png (if installed)
  • Short-cut 1584518922660-397.png on Desktop (if installed).

Section Editor module has only one tabmenu called 1584518933702-615.png that contains all the section definition tools, but the FEM-Design drawing, editing, displaying etc. commands are also available on the Section Editor user-interface.

1584518875195-352.png
Figure: Section Editor user-interface

Sections are two-dimensional region elements defined in the Y-Z plane of the Global (and UCS) coordinate-system. Section Editor uses the Y-Z system for defining and calculating profiles, because the sections are perpendicular to the x’ axis (parallel with the y’-z’ plane) of the local coordinate system of bar elements.

Cross-Section Definition

New cross-section can be defined by drawing section regions with arbitrary geometry, or by giving parameter values of a parametric section available in the built-in Section library, or by combining the two methods to build complex sections.

Drawing a Section

To draw a section use the 1584518965487-114.png Draw section tool and apply 1584518974769-373.png Define for the required region definition (geometry) mode 1584519034341-461.png Rectangular, 1584519042981-757.png Circular or 1584519055394-896.png Polygonal.

1584519016081-732.png
Figure: Section defined as polygon

With 1584519066253-361.png Pick lines tool, section can be generated by one-clicking drawing lines and arcs that define closed region. Drawing elements can be defined previously with the Draw menu commands or they can be imported from DWG/DXF files. With 1584519092226-932.png Pick existing region tool, section can be generated by one clicking drawing region defined by the Region command of the Draw menu.

1584519104432-389.png
Figure: Section created by selecting closed contour

With the 1584519354941-795.png Hole tool, openings and cuttings can be inserted to section regions with any shape defined
by the previously listed region definition modes.

1584519344478-786.png
Figure: Section edited by Hole

1582804930808-349.pngYou can read about the definition steps and functions of different region and hole geometries at the similar tools (“blue color-linked”) of Structure definition.

Section region shapes, corner points and side lines can be modified with the Modify menu tools.

Parametric Section

Although, quick definition of parametric profiles available in the settings dialogs (Cross-sections) of Column, Beam and Truss member, parametric sections can be inserted for editing and using them to create complex sections.
Use 1584519916753-325.png Insert section into drawing command to browse from parametric sections as well as standard and user-defined profiles, and to insert one or more of the required section with chosen geometry and sizes into the drawing area.

1582804849244-917.pngAlthough, you may choose for example a timber profile for editing and register as another fabrication type (for example steel, concrete etc.), we suggest you to choose profile type that will suit for later design. But, always you decide the available design type of the section defined by Section Editor when registering it with its Fabrication technology into Section library.

Definition steps

  1. Choose a parametric section shape in Section library or select a predefined (standard or registered user-defined) profile from New >/Size… option.
    1584519993257-429.png
    Figure: Dialog for defining parametric sections or for choosing predefined sections
  2. In case of parametric profiles, set the required geometric parameters. Each shape has a preview with the meaning of the parameters.
  3. Set the insertion point at Insertion point tab, where the placement can be defined. Default setting for placement is the center of gravity, but it can be changed by clicking on the specific points (green points) or set by y’ and z’ coordinates.
  4. Click OK to start inserting the defined or selected profile into the drawing area.
    1584520004880-235.png
    Figure: Definition of insertion point position
  5. Place the section with its insertion point on the drawing area. Click 1584520019980-386.png or 1584520040773-740.png to insert the section in the origin of the global Y-Z system.
  6. Further rotation can be set with the direction of the section’s z axis. Accurate angle can be typed in the Command line or click 1584520028169-489.png or 1584520037747-686.png to use the direction set in the Reference point… dialog.

Complex Section

1582804849244-917.png

Only homogenic complex profiles can be defined in the Section Editor, because one material can be assigned to it later in the design modules when defining beams, columns and bars.

At complex sections, intersecting or overlapping among section regions are not allowed. If there is any problem, the program stops the sectional data calculation with an error message.

As read in the previous chapter, quick definition of complex profile can be done by the repetition of section insertion with different positions and directions.

1584520076081-903.png
Figure: Complex profile built by parametric profiles

Of course, combining the section drawing and insertion modes various complex cross-sections can be defined.

1584520083243-307.png
Figure: Mixture of definition modes

Cross-Sectional Data

Before calculating the data of the defined section, it is recommended to place the section’s centre of gravity to the global system origin. With the Query command of Tool menu, you can easily find the center of gravity point of the defined section region and insert a drawing point.

1584520133669-940.png
Figure: Section moved into Origin with its center of gravity

1582804930808-349.pngQuery finds the center of gravity point of complex sections, if you merge the connected region parts with the Union tool of the Modify region command (Modify menu).

1584520144672-595.png
Figure: One complex region after merging region parts

The following settings (Settings menu) effect on sectional data calculation:

1584520153039-247.png
Figure: Calculation settings

  • Display result
    Set data types you want to display after calculation in the Sectional data window. The data list contains all available data on which multiply-selection such as 1584520208456-539.png and 1584520217909-402.png. (See the meanings of the sectional data at Sections.) All data can be selected by the Select all button.
  • Calculation options
    The Link the touching regions automatically at the next calculation option handles the connected regions as one complex region in calculations. The option influences the value of the following parameters: perimeter (P), area/perimeter (A/P), shearing center (Ys, Zs), shearing factors (Rho y, Rho z, Rho yz, Rho 1, Rho 2), torsion moment of inertia (It), torsion section modulus (Wt), warping parameter (Igamma) and Wagner parameters (z1, z2, z gamma).

To calculate the sectional data set at Monitored data click 1584520248447-124.png Calculate on the 1584520255688-772.png tabmenu. The results are automatically displayed in the Sectional data window.

1584520238741-330.png
Figure: Calculated sectional data

If you make modifications on the section geometry, you have to rerun the sectional data calculation with 1584520268414-405.png Calculate.

As a modeling feature, a calculated cross-sectional data can be manually modified/overwritten manually with arbitrary given value. With this possibility the user can create virtual cross-section with  known data. Double clicking on a data, custom value can be set for it in the Modify sectional data dialog. Modified data is signed with “:” instead of “=” in the Sectional data window. The original value can be reset for the current data with the dialog’s Calculate option, or you can reset all data with the Overwrite the user modified sectional data at the next calculation option (Settings > Calculation options).

1584520279354-953.png
Figure: Customizable sectional data

Documentation of Cross-Section

With the 1584520307001-248.png Insert report command, the table of the calculated sectional data can be placed on the drawing area based on the Display result setting.

1584520313525-348.png
Figure: Sectional data inserted to drawing area

If you make modifications on the section geometry, you have to rerun the sectional data calculation with 1584520334041-858.png Calculate and the content of the table refreshes automatically.

The table is stored on the Sectional data object layer. The color of the table can be modified together with the layer’s color. More display changes such as the modification of the text and border style can be done with the Properties > Change properties tool (Edit menu).

The defined section is lying on the Cross-section object layer, so the default blue color of section regions can be modified together with the layer’s color.

Insert section into library – Section Library

To add a new section having valid calculations to the Section library, click Register and set the required settings such as the name of the storing folder (Library name) and the Type and Size IDs. Also set the fabrication technology effect on the later available design calculations. To store the section press OK.

1582804849244-917.png

Before registering the current section click Calculate.

1584520384369-999.png
Figure: New section registered to Section library

Fabrication technologyDesign
Rolled steelSteel bar design
Cold-formed steelSteel bar design
Weld steelSteel bar design
ConcreteRC bar design
TimberTimber bar design
Generic- (only for analysis)

Table: Fabrication technology and the assigned design type

The program automatically detects the shape type of the sections and shows it as a symbol. It is important for the later design calculations.

The content of the Section library can be edited (renaming, deleting etc.) with the Edit library command.

1584520437880-240.png
Figure: Library and content editing

A registered section can be added to beam and column elements by choosing it in the Section tabpage of the element settings dialog (Default settings).

1584520447638-276.png
Figure: User-defined section used for bar elements (beams)

Created by Fredrik Lagerström on 2020/02/26 13:02
Copyright 2020 StruSoft AB
FEM-Design Wiki