Show last authors
1 {{box cssClass="floatinginfobox" title="**Contents**"}}
2 {{toc/}}
3 {{/box}}
4
5 There are numerous ways to get draft and initial model geometry for later design in FEM-Design.
6
7 With the so-called //Wizard// tool, typical frame and roof structures can be modeled quickly by giving the parameters of the required geometry, support and load, and the program automatically generates the real 3D model.
8
9 Models can be shared between the 2D and the 3D modeling of //FEM-Design modules//. For example, a slab of a multi-storey building (modeled in //3D Structure// module) can be design separately from the other slabs in the //Plate// module.
10
11 FEM-Design supports the major CAD drawing exchange formats (//DWG/DXF//), so imported drawings can be used as referenced draft for building up the structural models.
12
13 FEM-Design// //is able to import 3D models from other structural and architectural programs in two ways:
14
15 * FEM-Design supports the import of the most popular 3D model exchange data format called //IFC// (//Industry Foundation Classes//). The model-based data import gives the possibility to use the models designed by other disciplines (such as architectural) as an initial model or to show them as a reference.
16
17 * StruSoft develops //direct 3D model exchange links// with ArchiCAD (architectural discipline) and the major structural applications: Tekla Structures and Revit Structure. Add-ons build in these applications export native FEM-Design elements generated from 3D models.
18
19 = Parametric model =
20
21 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579531644986-884.png||alt="1579531644986-884.png"]]
22
23 The parametric model is an editor module, where the User can create parametrized model as templates. The templates later can be imported into the Structure module with customized settings.
24
25 This module can be found in the command center.
26
27
28 (% style="text-align: justify;" %)
29 == Available structural and analytical elements ==
30
31 (% style="text-align: justify;" %)
32 In the first version of the parametric model module the user can use point and straight line objects, like point and line foundations, bars, point and line supports, and fictitious bars.
33
34 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579510155605-474.png||alt="1579510155605-474.png"]]
35
36
37
38 (% style="text-align: justify;" %)
39 == Parameter tab ==
40
41 The parameter tab is where the tools placed to parametrize the model element’s number and placement.
42
43 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579510557613-170.png||alt="1579510557613-170.png"]]
44
45
46 ----
47
48 (% style="text-align: justify;" %)
49 === Base rays and base planes ===
50
51 These objects can be used as the frame of the parametric model. Structural and analytical elements can be attached them.
52
53 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579510608959-746.png||alt="1579510608959-746.png"]]
54
55 (% class="box infomessage" %)
56 (((
57 For 3D parametric models it’s advised to use only base planes, and for 2D models base rays should be preferred.
58 )))
59
60 The following example, which is a simple roof structure with columns, shows a practical way to use base planes and base rays. The base planes defines the plane where the supports, the columns will be placed, the bottom and the top level and the first and last plane of the roof structure. The base rays will defines the beams x’ direction (and for locking, see on //Lock// chapter).
61
62 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574943990673-127.png||alt="1574943990673-127.png"]]
63
64 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574944002714-536.png||alt="1574944002714-536.png"]]
65
66 (% style="text-align: justify;" %)
67 === Grids ===
68
69 Grids are used to create iterative patterns, like a series of columns or an array of point foundations.
70
71 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579513601384-345.png||alt="1579513601384-345.png"]]
72
73 With this function the User can create one, two or three dimensional grids:
74
75 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574940863862-226.png||alt="1574940863862-226.png"]]
76
77 Structural and analytical elements can be attached to the grid. The attachable elements should be fit in one cell of the grid:
78
79 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574940935542-552.png||alt="1574940935542-552.png"]]
80
81 The user can draw anywhere in the cells, it will be attached to that grid.
82
83 The grids can be warped in every possible way by the corner points.
84
85 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579529349165-597.png||alt="1579529349165-597.png"]]
86
87 (% class="box warningmessage" %)
88 (((
89 If the grid's cell is triangular shape the structural element cannot be attached to the triangular edges.
90 )))
91
92 The User can set the number of cells in one direction by any given numbers or parameters:
93
94 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574941410291-517.png||alt="1574941410291-517.png"]]
95
96 The User can set where he/she wants to multiply structural objects on the grid:
97
98 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579513915071-931.png||alt="1579513915071-931.png"]]
99
100 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574941433608-815.png||alt="1574941433608-815.png"]]
101
102
103 Using the //Local y’ axis //option to follow the objects local y’ axis in the grid after the structural element assigned to grid.
104
105
106 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574941495905-741.png||alt="1574941495905-741.png"]]
107
108
109
110 === Locks ===
111
112 Locks are used to bound nodes of structural elements, analytical elements, base lines and grids to the cross points of base elements. The locked objects are marked with the lock symbol in the model space.
113
114 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579511119714-389.png||alt="1579511119714-389.png"]]
115
116
117 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574941521869-304.png||alt="1574941521869-304.png"]]
118
119
120 Cross points can be a intersections of two base line, an intersection of a base line and base plane and a cross point of three base plane. The following example shows how to define the middle beam position with lock object, simply The base ray and base plane intersection will be the position of the middle beam.
121
122 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574944046657-328.png?width=1087&height=524||alt="1574944046657-328.png"]]
123
124
125
126 (% class="box warningmessage" %)
127 (((
128 If the base objects are moved, the locked objects are moving with them
129 )))
130
131 === Constraints ===
132
133 Constrains are used to set distances between parallel base objects.
134
135 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579511191987-573.png||alt="1579511191987-573.png"]]
136
137 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579529925479-162.png||alt="1579529925479-162.png"]]
138
139 The following example shows how to use the parameters on a practical example.
140
141 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579529619643-329.png?width=1076&height=540||alt="1579529619643-329.png"]]
142
143 **Parameters**
144
145 Parameters are used to control the parametric model. It can be created new parameters directly in the parameter dialogs or indirectly from parametric objects’ dialogs (grid and constraint).
146
147 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579511235231-447.png||alt="1579511235231-447.png"]]
148
149 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574941625349-220.png||alt="1574941625349-220.png"]]
150
151 If one of the parameters (which are assigned to the parametric model) changed the modifications will automatically apply to the paramteric model.
152
153 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1574944080959-896.png?width=1253&height=569||alt="1574944080959-896.png"]]
154
155 === Import parametric models to structure module ===
156
157 The parametric model can be imported to 3D modules by
158
159 * //Tools / Apply parametric model//
160 * //Edit / Paste file//
161 * //Open (file with *.prm extension)//
162
163 After selecting the .prm file the parameter dialog will appear where the previously defined parameters can be set and with that parameters the model will be applied.
164
165 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/New%20features/New%20in%20FEM-Design%2019/Parametric%20model/WebHome/1579531475755-847.png||alt="1579531475755-847.png"]]
166
167
168 = {{id name="Model Exchange between FEM-Design Modules"/}}Model Exchange between FEM-Design Modules =
169
170 Different FEM-Design modules are able to share models between each other. The next table shows the possible connections between modules.
171
172
173 (% class="table-hover" style="width:668px" %)
174 |(% colspan="2" rowspan="3" style="width:221px" %) |(% colspan="4" style="width:465px" %)**Source Module (.file extension)**
175 |(% colspan="2" style="width:215px" %)**2D models**|(% colspan="2" style="width:249px" %)**3D models**
176 |(% style="width:112px" %)[[image:1584357370056-161.png]]** (.pla)**|(% style="width:111px" %)[[image:1584357377924-340.png]]** (.wal)**|(% style="width:145px" %)[[image:1584357385444-518.png]]** (.frm)**|(% style="width:113px" %)[[image:1584357393635-818.png]]** (.str)**
177 |(% rowspan="4" style="width:155px" %)**Destination Module**|(% style="width:66px" %)[[image:1584357367888-964.png]]|(% style="text-align:center; width:112px" %)[[image:1584371583648-693.png]]|(% style="text-align:center; width:111px" %) |(% style="text-align:center; width:145px" %) |(% style="text-align:center; width:113px" %)[[image:1584371581078-617.png]] (1)
178 |(% style="width:66px" %)[[image:1584357376594-436.png]]|(% style="text-align:center; width:112px" %) |(% style="text-align:center; width:111px" %)[[image:1584371582450-666.png]]|(% style="text-align:center; width:145px" %) |(% style="text-align:center; width:113px" %)[[image:1584371579772-694.png]] (2)
179 |(% style="width:66px" %)[[image:1584357384225-967.png]]|(% style="text-align:center; width:112px" %) |(% style="text-align:center; width:111px" %) |(% style="text-align:center; width:145px" %)[[image:1584371588616-182.png]]|(% style="text-align:center; width:113px" %)[[image:1584371578374-153.png]] (4)
180 |(% style="width:66px" %)[[image:1584357392274-905.png]]|(% style="text-align:center; width:112px" %)[[image:1584371584829-179.png]] (3.1)|(% style="text-align:center; width:111px" %)[[image:1584371586021-896.png]] (3.2)|(% style="text-align:center; width:145px" %)[[image:1584371587865-126.png]] (5)|(% style="text-align:center; width:113px" %)[[image:1584371589510-892.png]]
181
182 (% style="text-align: center;" %)
183 Table: Model connections between FEM-Design modules. Numbers shown in paranthesis are linked to the method below.
184
185 The main featured connections from the above possibilities:
186
187 1. **Slab-system imported from 3D Structure to Plate module**
188 Slabs or slab-system of a building (created by //3D Structure// or //PreDesign//) //storey// together with connected walls, columns, beams and loads can be imported into //Plate// module.(((
189 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)Only the loads directly placed on the slab elements can be imported to //Plate//. The loads arrive from other stories or connected elements have to be added manually to the slab regions as //Point/Line/Surface loads//.
190
191 **Steps of import:**
192
193 1. Click //Open// (//File// menu) in the [[image:1584366009667-559.png]] .//Plate// module. Select the //.str// (//3D Structure//) or .prd (//PreDesign//) which contents you would like to import to //Plate//.
194 1. Select the //Storey//, which slabs (plates) you would like to load as a new project.
195
196 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)The import requires //storey-system// from the file selected by //Open//.
197
198 1. Allow or forbid the import of columns and walls connected above/below the slabs of the selected storey. Beams and loads connected to related slabs will be automatically imported.
199 1. Set the end conditions (fixed or hinged) of the walls (=wall supports) which you would like to import.
200 1. Click //OK// to start the import.
201 \\[[image:1584366093124-273.png]]
202 Figure: Import of slabs with connected elements into a Plate project
203
204 )))
205 1. **Wall-system imported from 3D Structure to Wall module**
206 Wall regions situate on a vertical plane defined by an //axis// of a building (created by //3D Structure//) can be imported into //Wall// module together with connected supports and loads.(((
207 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)Only the loads directly placed on the wall elements can be imported to //Wall//. The loads arrive from other connected elements have to be added manually to the wall regions as //Point/Line loads//.
208
209 **Steps of import:**
210
211 1. Click //Open// (//File// menu) in the [[image:1584366172759-973.png]] //Wall// module. Select the //.str// (//3D Structure//) which contents you would like to import to //Wall//.
212 1. Select the //Axis//, which wall regions you would like to load as a new project.
213
214 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)The import requires //axis-system// from the file selected by //Open//.
215
216 1. Click //OK// to start the import.
217 \\[[image:1584366723307-598.png]]
218 Figure: Import of walls with connected elements into a Wall project
219
220 )))
221 1. **Single plate/wall import to 3D Structure (3.1 and 3.2)**
222 Slabs/Walls with their supports and loads created and designed in the [[image:1584366014784-384.png]] //Plate// /[[image:1584366169807-343.png]] //Wall// module can be imported into the [[image:1584366862555-698.png]] //3D Structure// module. Multi-storey building can be defined by copying the opened elements, and run global stability analysis and design for the final model.
223 \\**Steps of import:**
224 11. Click //Open// (//File// menu) in the [[image:1584366865760-254.png]] //3D Structure// module. Select the //.pla// (//Plate//) or //.wal// (//Wall//) which contents you would like to import to //Plate//.
225 11. In case of curved walls, set their conversion to planar wall regions. Curved wall element is not available in the 3D structure modules. The value of the approximation can be set in the //tmax// field. If the “originally curved” walls are connected to curved plate edges, the program also modifies the curved plate edges to polyline.
226 11. Click //OK// to start the import.
227 \\Optional steps:
228
229 11. Copy (//Modify > Copy//) plate regions with their wall/column supports and loads, if required.
230 11. Only one //Plate/Wall// file can be imported (with //Open//) in a 3D project. But, you can open different files in separate 3D projects, and later you can merge their contents into one with the //Copy// and //Paste// commands and set their real position with the //Move// command (//Edit// menu).
231 11. In //Plate// module, the //Wall// and //Column** **//elements are supports. So, do not forget to add supports to the bottom end of the columns and walls of the lowest storey.
232 \\[[image:1584367140415-653.png]]
233 Figure: Import of a slab (system) into a 3D structure project
234
235 1. **Frame part exported from 3D Structure to 3D Frame (4)**
236 Frame parts (beams, columns and truss members) of a multi-storey building (created in [[image:1584366878828-782.png]] //3D Structure//) can be imported into the [[image:1584368292060-344.png]]** ** //3D Frame// module by filtering out the shell, plate, wall elements and their related surface supports and loads. The import process is very simple: just apply //Open// (//File// menu) for the //.str// (//3D Structure//) files in //3D Frame//.
237 [[image:1584368298909-167.png]]
238 Figure: Import of frame parts into the 3D Frame module
239
240 1. **Frame import to 3D Structure (5)**
241 Initial analysis and design can be done for only the load-bearing frame parts in the [[image:1584368374213-697.png]]** ** //3D Frame// module, then the bar elements can be imported into the [[image:1584366883675-567.png]] //3D Structure// modules to complete them with planar element such as plates, walls and their supports and loads. The import process is very simple: just apply //Open// (//File// menu) for the //.frm// (//3D Frame//) files in //PreDesign// or //3D Structure//.
242
243 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)Opening PreDesign model in 3D Structure and 3D Frame is not allowed since version 12.0, as PreDesigh has totally different database and not possible to keep compatibility with other 3D modules.
244
245 = {{id name="CAD Drawing Import and Export"/}}CAD Drawing Import/Export =
246
247 A DWG or DXF file generally contains drawing objects (points, lines, dimensions, texts etc.), so it can be used as a reference draft displaying a floor plan, a section or an elevation. Each //FEM-Design module// is able to import (and also export) DWG and DXF.
248
249 All elements, so both structural model and drawing elements, can be converted and exported to DWG/DXF format. The objects are automatically converted to lines with their 3D position and placed onto separate layers by object types. Also, the symbols and info labels are broken to text and line parts.
250
251 == Import ==
252
253 The steps of opening a DWG/DXF file:
254
255 1. Open the DWG/DXF file with //File > Open//.
256 1. Set the import settings in the upcoming dialog:
257 [[image:1584368878063-792.png]]
258 Figure: DWG import settings
259
260 * //Unit//: Set the same drawing length unit with the unit-system saved in the file by the exporting application. Most of the DWG-compatible applications use “mm” while defining and exporting drawings.
261 * //Scale//: Set the drawing scale of the opened file by typing the required value. Scale affects the display of texts, line types and hatches.
262 * //Ignore points//: Check this box to filter out drawing points, so not to allow their import.
263 * //Set to 2D//: Check this box, if you would like to merge all drawing elements (independently their level position) in the XY plane of the //Global co-ordinate system//. It is recommended only, if the points of the imported drawing place in the same or near the same (small geometry inaccuracy in Z direction) plane.
264 * //Ignore empty layers//: Check this box not to import empty layers that do not contain drawing elements. Unchecked box merges all layers stored in the DWG/DXF file.(((
265 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)The imported layers will be converted to //Drawing layers//.
266 )))
267 * //Merge points//: Checking this box corrects the inaccuracies of the imported drawing in the given merging distance and deletes the point duplications.
268
269 (% start="3" %)
270 1. Hide the unnecessary drawing layers to make clear the points and lines you would like to use for later model definition.
271 [[image:1584369080688-151.png]]
272 Figure: Active imported drawing layers(((
273 |(% style="width:87px" %)[[image:light.png||alt="1582804930808-349.png"]]|(% style="width:1363px" %)With// Modify > Change appearance// you can query the host drawing layer of a selected element.
274 )))
275 1. Create the structural model based on the referenced (opened) drawing.(((
276 |(% style="width:85px" %)[[image:light.png||alt="1582804930808-349.png"]]|(% style="width:1365px" %)(((
277 Apply the proper //Object Snap// //Tools** **//to find the required main points, endpoints, intersections, lines etc. for the input (reference points and lines) of the //model elements//.
278
279 Set the size of the elements according to the drawing elements after inquiring/measuring positions, directions and sizes with //Tools > Query//, if it is needed.
280
281 Pay attention to pick proper/correct lines when defining reference lines and insertion points for the structural objects. For example, think on the wall position while connecting it to a plate edge. Not always following the real state (defined by the DWG drawing) is the optimized way to model elements.
282 \\[[image:1584369283049-412.png]]
283 Figure: Reference line (and finite element mesh) definition based on the drawing
284
285 Rotate the position of the drawing, if it is needed. For example set a section/elevation drawing to the //Global// //XZ// or //YZ// plane in 3D modules.
286
287 [[image:1584369330158-990.png]]
288
289 Figure: Rotation of a drawing (definition of an elevation)
290
291 In most cases the drawing elements of the merged DWG/DXF file are placed far from the origin of the //global co-ordinate system//, so click //View > Zoom margin// to show the entire drawing after opening it.
292 )))
293 )))
294
295 |[[image:light.png||alt="1582804930808-349.png"]]|(((
296 Only one DWG/DXF file can be opened at a time. But, you can merge more than one drawing (e.g. floor plans of different stories) into a project as the following hint:
297
298 1. Open the first drawing as a new FEM-Design project.
299 1. Open the second/other drawing as a separate FEM-Design project. (More than one copies of a FEM-Design module can run in the same time.
300 1. Apply //Edit > Copy //for the required elements of the second/other drawing to send them to Clipboard.
301 1. Use //Edit > Paste //to merge the drawing elements (from the Clipboard) into the first project. Set the real position of the drawing insertion (point), so for example, place the 2^^nd^^ floor elements in the correct 2^^nd^^ level position.
302 )))
303
304 == Export ==
305
306 There are two different ways to export a file to DWG/DXF-format.
307
308 * File > Save as...
309 * File export to DWG/DXF
310
311 === Save as... ===
312
313 The steps of saving a DWG/DXF file:
314
315 1. Click //File > Save as//, choose the proper DWG/DXF file type and enter a valid file name.
316 [[image:1586159629363-352.png]]
317
318 1. Set the export settings in the upcoming dialog:
319 \\[[image:1586159964938-986.png]]
320 Figure: DWG export settings
321
322 1*. //Unit//: Set the drawing length unit of the exported elements to the type required by the other application which wants to open the DWG/DXF file.
323 1*. Only (% style="color: rgb(255, 255, 255); background-color: rgb(41, 128, 185)" %)selected lines(%%) will be saved
324 1*. //Show visible layers only//: This feature will only show current visible layers in the current FEM-Design window
325 1*. //Do not show empty layers//: Filters empty (unnecessary) layers to not be seen and therefor not possible to export.
326 1*. AutoCAD version: Select the version of AutoCAD to be able to read the file. Note that older versions might not be able to read newer formats.
327
328 |[[image:light.png]]|//Do not show empty layers// makes the view more clean to find the layers that you want to have selected or deselected.
329
330 === File export to DWG/DXF ===
331
332 Similar to the Save as...-function, this feature works the same but instead of saving all objects it is possible to select the objects you want to export.
333
334 The steps of exporting a DWG/DXF file:
335
336 1. Click //File > Export to DWG/DXF//
337 1. Select the objects in the 3D window that you want to export
338 1. After the objects are selected a window pops up informing the user to save the file, choose the proper DWG/DXF file type and enter a valid file name.
339 1. [[image:1586159629363-352.png]]
340
341 1. Set the export settings in the upcoming dialog:
342 \\[[image:1586159964938-986.png]]
343 Figure: DWG export settings
344
345 1*. //Unit//: Set the drawing length unit of the exported elements to the type required by the other application which wants to open the DWG/DXF file.
346 1*. Only (% style="color: rgb(255, 255, 255); background-color: rgb(41, 128, 185)" %)selected lines(%%) will be saved
347 1*. //Show visible layers only//: This feature will only show current visible layers in the current FEM-Design window
348 1*. //Do not show empty layers//: Filters empty (unnecessary) layers to not be seen and therefor not possible to export.
349 1*. AutoCAD version: Select the version of AutoCAD to be able to read the file. Note that older versions might not be able to read newer formats.
350
351 |[[image:light.png]]|//Do not show empty layers// makes the view more clean to find the layers that you want to have selected or deselected.
352
353 == General information ==
354
355 All elements (beams, columns… supports, loads, drawing elements, labels, etc.) will be generated to lines and texts, and they will be placed onto separate drawing layers by their types. All DWG/DXF-compatible applications are able to filter elements by layers during or after the import process.
356
357 [[image:1584369646970-755.png]]
358
359 Figure: Exported DWG in 2D and 3D views
360
361 = {{id name="StruSoft XML-format (StruXML)"/}}StruSoft XML-format (StruXML) =
362
363 More information about the StruXML [[here>>doc:FEM-Design API.StruXML.WebHome]].
364
365 = {{id name="IFC Import"/}}IFC Import =
366
367 FEM-Design gives the possibility to import 3D models saved in IFC files from other architectural and structural programs. Some of the most important features of the FEM-Design’s IFC import:
368
369 * Compatible import formats: IFC2x version 2 and 3
370 * Material conversion table and style
371 * Object-filtering
372 * Connections of misplaced objects (point-point and line-line connection)
373
374 An IFC model contains elements according to the mapping rule of model elements to IFC element types. For example, a column is represented as //IfcColumn// in the IFC scheme by default. Not only the geometry, but numerous properties like material, profiles etc. are assigned to one element.
375
376 Opening an IFC file generates native FEM-Design elements based on the model structure or solid body model (“reference model”) depending on the chosen import method:
377
378 * **Architectural View**
379 The static system is converted from the architectural/structural model elements (IFC architectural representation), so //FEM-Design// creates native structural objects such as //Plates//, //Walls//, //Beams// and //Columns//.
380 \\[[image:1584370311380-371.png]]
381 Figure: Generation of real FEM-Design objects
382
383 * **Reference Geometry View**
384 A solid body model is generated from the IFC model as a reference. Elements are not supported by the current FEM-Design can be also display because of the solid representation. For example, solids generated from slabs and walls can be shown as reference in the [[image:1584370358797-786.png]] //3D Frame// module, although only bar elements can be defined in it.
385 After the import, FEM-Design can find and select points, edges and surfaces of the solid body model elements, so the user can define //Plates//, //Walls//, //Beams//, //Columns //and //Truss// //members// manually according to the referenced model. For example, to define a wall object in FEM-Design 3D modules, just pick on the requested vertical solid surface.
386 \\[[image:1584370391349-177.png]]
387 Figure: Generation of 3D solid bodies (drawing)
388
389 * **Structural Analysis View**
390 Some structural application (e.g. Tekla Structures) is able to create analysis model and export it via IFC. Opening an analysis type IFC model, which contains region and line representation of structural elements generates native FEM-Design elements very fast.
391 [[image:1584370472654-420.png]]
392 Figure: Generation of real FEM-Design objects from an imported analysis model
393
394 Of course, the result of element import depends on the FEM-Design module where the process is done:
395
396 |Module|**Architectural View**|**Reference Geometry View**|**Structural Analysis View**
397 |(((
398 [[image:1584370516393-223.png]] Plate
399
400
401 )))|(((
402 One storey only:
403
404 - Plates and Beams
405
406 - Walls and Columns as supports
407 )))|(((
408 Entire model and all building elements as Solid objects
409
410
411 )))|(((
412 -
413
414
415
416 )))
417 |(((
418 [[image:1584370527181-812.png]] 3D Frame
419
420
421 )))|(((
422 Beams and Columns only
423
424
425 )))|Entire model and all building elements as Solid objects|(((
426 Beams and Columns only
427
428
429 )))
430 |(((
431 [[image:1584370536691-662.png]] 3D Structure
432 )))|Plates, Walls, Beams and Columns|Entire model and all building elements as Solid objects|Plates, Walls, Beams and Columns
433
434 Table: Imported IFC elements by “views” and FEM-Design modules
435
436 **The steps of opening an IFC file:**
437
438 1. Load the IFC file with //File> Open//.
439 1. Choose the required import method: //Architectural View//, //Reference Geometry View// or //Structural Analysis View//. The first two methods are always available, but the last one depends on the received IFC model type (“Analysis-type”).
440 [[image:1584370622687-155.png]]
441 Figure: Selection of import mode (view)
442 1. A tree lists the IFC model content by buildings and their storeys. In the //Architectural// and //Reference Geometry// views, objects can be selected for the import.
443 In //Architectural View// mode, “Irregular” label represents the element types/geometries, which cannot be converted to FEM-Design structural elements. However these elements can be displayed in the //Reference Geometry View//.(((
444 |(% style="width:95px" %)[[image:light.png||alt="1582804930808-349.png"]]|(% style="width:1355px" %)(((
445 [[image:1584370769717-918.png]] //Plate// module only imports plates situate on the same storey together with supports under them. Most of the architectural software places the “support elements” (like walls, columns etc.) on one storey below the plates’ host storey, so the requested elements can be selected from separate storeys. In case of [[image:1584370780909-521.png]] //3D Structure// models, the entire model can be imported independently from the storey system.
446
447 [[image:1584370818022-275.png]]
448
449 Figure: Differences between modules used for the model import
450 )))
451 )))
452 1. Set the main properties of the selected elements (only in //Architectural// and //Structural Analysis views//).
453 [[image:1584370884448-322.png]]
454 Figure: Main properties of elements
455 1*. //General properties//: it displays the ID name of the elements and the IFC global unique identifier (GUID). Description may contain the profile name of the elements depending on the exporter application.
456 1*. //Material mapping//: it displays the material of the selected element (IFC material) and the default FEM-Design material (available in the current standard) assigned to the imported IFC material. Of course, you can modify and set the required material that will model the imported one. Material can be set with //Select material //by elements or based on the material //Mapping table. //Of course, the material can be modified later with the element’s [[image:1584370917664-545.png]] //Properties// tool.
457 The conversion can be done on different model levels, so for the entire structure, by storeys (e.g. 1st floor), by object type (e.g. all slabs), and for the type (e.g. slabs) of the selected objects.
458 1**. **Select material**
459 A dialog appears with the built-in (available in the current standard) and user-defined concrete, steel and timber materials of FEM-Design. New concrete, steel and general materials can be created in the dialog too.
460 1**. **Mapping table**
461 You can associate standard materials (as the applied code) to one or more materials of the imported model (= “FC Material”) in dialogue format. It works for the complete model, so there is no difference that you select an object or a storey or a building. There are two independent conversion maps, one for the architectural and one for the structural model.
462 Select one (or more) material in the “IFC Material” column, then press //Assign material// and finally choose proper FEM-Design material available in the current code. Here, new materials can also be created (//New//). Clicking //OK// returns to the material conversion table that shows the selected conversion: the selected material appears in the “FEM-Design Material” column. Material mapping table can be saved and exported for others with the //Export// option, or previously saved conversion rules can be loaded with //Import//.
463 1*. //Layer filter//: the core of the composite layered materials can be set here.
464 1*. //Statical system//: in [[image:1584370983007-301.png]] //Plate// module, the end connections (fixed or hinged) of selected columns and walls (supports) can be set as a default value. Of course, the end connections can be modified later with the element’s [[image:1584370994384-992.png]] //Properties// tool.
465 1. Clicking //OK// loads the //IFC// model. The loading process may take a long time depending on the complexity and the size of the imported model.
466
467 If you open an IFC model in //Architectural view// mode with the 3D modules, the program generates rigid //connection objects// (//Point-point //and/or //Line-line connection//) between the misplaced elements, which solid surfaces are touching each other, but the generated calculation planes are not. The method depends on the types of the “connected” objects:
468
469 * If a bar element connects to an object, the program applies //Point-point connection//.
470 * If only planar elements connect to each other, //Line-line connections// are assigned to them.
471
472 [[image:1584371089864-819.png]]
473
474 Figure: Line-line connection generated between the plate and the touching wall elements
475
476 |(% style="width:95px" %)[[image:light.png||alt="1582804930808-349.png"]]|(% style="width:1355px" %)(((
477 You can modify the connection stiffness with the [[image:1584371123829-926.png]] //Properties// tool of the //Point-point// and //Line-line connection// commands.
478 )))
479
480 = {{id name="Direct Data Links"/}}Direct Data Links =
481
482 StruSoft develops direct links with the architectural software ArchiCAD and the structural applications Tekla Structures and Revit Structure. So, thanks to external tools, ArchiCAD can exports the entire architectural or a simplified structural model or its part, and the two structural management/editor applications can export the analysis model generated from the structural model.
483
484 Direct link means that add-ons embedded in the previous applications generates automatically FEM-Design [[(% class="wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink" %)//Plate//>>path:#_Plate]](%%), [[(% class="wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink" %)//Wall//>>path:#_Wall]](%%), [[(% class="wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink" %)//Column//>>path:#_Column]](%%) and [[(% class="wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink wikiinternallink" %)//Beam//>>path:#_Beam]](%%) elements from their native 3D elements, so further conversion is not needed inside FEM-Design while opening the model files.
485
486 |(% style="width:99px" %)[[image:warning.png||alt="1582804849244-917.png"]]|(% style="width:1351px" %)(((
487 The external StruSoft applications together with their user manuals are available on the **//Download//** (//Downloads// menu) by the versions of ArchiCAD, Tekla Structures and Revit Structure.
488
489 The ArchiCAD Add-On exports //.fdx// files compatible with the FEM-Design [[image:1584371315555-506.png]] //3D Structure// or [[image:1584371327895-766.png]] //Plate//.
490
491 The Revit Structure Add-In exports //.r2f //files compatible with the FEM-Design [[image:1584371316808-510.png]] //3D Structure//.
492
493 Tekla Structures sends analysis model (//Analysis > Analysis & Design Models//) directly to FEM-Design [[image:1584371318393-902.png]] //3D Structure//, so both FEM-Design and Tekla Structures licenses can be installed on the same computer.
494 )))
495
496 The next table summarizes the FEM-Design elements matched to the elements of the related applications by the external tools in the special exchange file formats.
497
498 |FEM-Design|**ArchiCAD**|**Revit Structure**|**Tekla Structures**
499 |[[image:1584371374612-186.png]] //Beam//|Beam|(((
500 - Beam
501
502 - Truss
503
504 - Brace
505
506 - Beam System
507 )))|(((
508 - Concrete Beam
509
510 - Concrete Polybeam
511
512 - Steel Beam
513
514 - Steel Polybeam
515
516 - Steel Curved Beam
517 )))
518 |[[image:1584371381373-474.png]] //Column//|Column|(((
519 Structural Column
520
521 (straight only)
522 )))|(((
523 - Concrete Column
524
525 - Steel Column
526 )))
527 |[[image:1584371391881-762.png]] //Plate//|(((
528 - Slab
529
530 - Roof
531 )))|(((
532 - Structural Floor
533
534 - Isolated Foundation
535
536 - Wall Foundation
537
538 - Foundation Slab
539 )))|(((
540 - Concrete Slab
541
542 - Steel Contour Plate
543 )))
544 |[[image:1584371398958-787.png]] //Wall//|(((
545 Wall
546
547 (Straight, Curved, Trapezoid)
548 )))|(((
549 Structural Wall
550
551 (straight only)
552 )))|Concrete Panel
553
554 Table: Elements by applications can be imported as FEM-Design elements
555
556 //Material and profile mapping// is recommended at all direct link connection:
557
558 * In case of Revit Structure, the Add-In gives the possibility to map the Revit Structure profiles and materials with the FEM-Design ones.
559 * In case of Tekla Structures, the material and profile mappings can be done in editable (e.g. with Notepad) text files. The factory default templates can be found in the FEM-Design’s “FORMATS” library: “TeklaFEM-DesignMaterialMapping.cnv” and “TeklaFEM-DesignProfileMapping.cnv”.
560 * In case of ArchiCAD, opening the .//fdx// file in the [[image:1584371411850-848.png]] //3D Structure// or [[image:1584371419878-781.png]] //Plate //module, a setting dialog comes up with the following settings:
561 [[image:1584371445181-522.png]]
562 **Storey **([[image:1584371421965-279.png]] //Plate //module)
563 \\In ArchiCAD, users work by storeys. The Plate module’s “Selected item” lists all available storeys. Choose the required one, and the program will import the plates and its connected objects like beams and column/wall supports. In case of [[image:1584371411850-848.png]] //3D Structure//, storeys can be not selected, the module opens the entire model.
564 \\**Composites**
565 \\“Composites/Fills” lists the materials (ArchiCAD Cut Fills) together with the multi-layered composite structures defined in ArchiCAD. For composites, the core part (that thickness will be considered in FEM-Design) can be set in this dialog tab.
566 \\**Defaults**
567 ** Here you can set the “Material” mapping by element types.
568 ** Minimum size/thickness value gives the limit of the columns/walls can be imported. For example, giving 0.1m min. thickness for walls means that the partition walls with smaller thickness (e.g. 9cm) will be not loaded while import.
569 ** Fixed and hinged end “Connections” for columns and walls (Plate module only) can be set with the radio buttons.
570 ** Unchecked “Arrange beam to reference line” option will be place beams in their original position as defined in ArchiCAD; but the calculation line will be their (middle) axis. The checked state derives same position of the beam’s calculation line with its reference line in ArchiCAD.
571 ** “Create support from ArchiCAD's reference line” has the same function with the previous beam setting, but it effects on walls.
572 ** “Accuracy of arc wall” generates straight wall segments from a curved ArchiCAD wall in the 3D Structure module (because curved wall can be defined in 3D modules). The maximum deviation (a) from the arc can be set in meter unit.
Copyright 2019 StruSoft AB
FEM-Design Wiki