Although FEM-Design is an analysis and design application, CAD drawing can be also done with its built-in drawing tools. Editing tools also available to edit, modify and multiply both structural and drawing elements. Drawings can be the draft of the later design model, but you may also export them in the popular DWG and DXF formats.

Drawing tools are grouped in the Draw menu, but they are directly available from the list appears when clicking 1585290408581-252.png key together with 1585290414508-165.png .

Editing tools are grouped in the Edit menu, but they are directly available from the list appears when clicking 1585290417893-999.png.

1585290423788-971.png

Figure: Drawing and editing tools

Draw Menu Commands

The following rules are valid for the drawing commands and elements:

  • Drawing elements are placed and stored in Drawing layers.
  • The color of the current drawing layer is the default drawing color. Under “Current color” button of Status bar, you can customize the drawing color independently from the host layer’s color.
  • The style of the drawing lines and edges can be set with “Current style”.
  • Drawing and text styles together with display settings of drawing elements are available at Settings.
  • Although, you may draw in 3D, in most cases, it is recommended to set the user coordinate-system in the drawing plane.
  • To define drawing points, type coordinate and angle values in the Command line and/or Co-ordinate box or use the Object snap tools to pick requested special points.
  • Command line guides you with the steps of drawing element definition.

The next table summarizes the available drawing tools, their functions and definition steps.

CommandIconDescriptionDefinition modes
Point1585290595317-322.pngDefines a point based on the current drawing settings.-
Line1585290609808-849.pngDefines a line or connected lines (open, closed and/or polyline) based on the current drawing settings.Definition of start- and endpoints
Rectangle1585290619220-485.pngDefines a rectangle (closed contour) based on the current drawing settings.Definition of two opposite corners
Arc1585290626378-142.pngDefines a circular arc based on the current drawing settings.

1585290993264-763.png Arc by center, radius and angle

1585290998390-430.png  Arc by 3 points

1585291004253-445.png Arc by start, end point and tangent

Circle1585290633485-750.pngDefines a circle arc based on the current drawing settings.

1585290977697-667.png Circle by center and radius

1585290982900-776.png Circle by diameter

1585290987841-137.png  Circle by 3 points

Region1585290639091-136.pngDefines a drawing region with arbitrary shape. Also holes can be added to the region.

1585290860926-188.png Rectangular

1585290937927-871.png Circular

1585290944971-893.png Polygonal

1585290959748-288.png Pick lines (close contour)

Solid1585290645030-762.pngDefines prismatic, centric, sphere, regular and general 3D solid surface. Generic solid can be generated with the help of arbitrary shapes and directrix. Solids can be also cutted in their heights.

1585290898688-244.png Prismatic

  • 1585290905053-595.png Rectangular base (brick/cube)
  • 1585290910581-489.png  Circular base (cylinder)
  • 1585290916745-673.png Polygonal base (prism)
  • 1585290922422-314.png Pick lines (arbitrary base)
  • 1585290927869-371.png Pick existing region (arbitrary base)

1585290853145-680.png Centric

  • 1585290860926-188.png Rectangular base (pyramid)
  • 1585290866824-361.png Circular base (cone)
  • 1585290874728-123.png  Polygonal base
  • 1585290881606-224.png  Pick lines (arbitrary base)
  • 1585290889569-970.png Pick existing region (arbitrary base)

1585290829936-738.png Sphere

  • 1585290836630-621.png Sphere
  • 1585290842733-295.png Segment of sphere

1585290822948-874.png Regular

  • 1585290785088-768.png Tetrahedron
  • 1585290794592-695.png Cube
  • 1585290801462-296.png Octahedron
  • 1585290808612-680.png Dodecahedron
  • 1585290815434-413.png Icosahedron

1585290778618-102.png  General (arbitrary shape with directrix)

Text1585290652225-930.pngDefines arbitrary text in custom style and any direction.-
Field1585290657189-461.pngPlaces autotext in custom style and any direction.-
Dimension1585290662481-946.pngDefines length, angle and level dimensions in custom style.

1585290720880-851.png Linear (Length)

1585290726009-211.png Arc

1585290731335-766.png Diameter

1585290736662-270.png Radius

1585290742427-878.png Angle

1585290752076-196.png Level dimension

Title information table1585290670527-973.png

Places a table that displays title

Information of the current project. The content of the table can be set by Settings > Title. The width of the information table is defined by the text size and style (Settings> Text). Table is placed in the Title information object layer. Layer color defines the table color too.

-

Table: Draw menu tools

The following chapters give more details for some drawing items.

Solids

This chapter shows some example for available solid geometries and introduces how general solids can be defined with the help of shape contour and directrix.

warning.png

There are no real curved surfaces in 3D modeling, so the program approximates the curved surfaces with polygonal planes. The value of approximation can be set by the Refracting angle option (Primary/Secondary). The next figure shows the meaning of refracting angle values for a double-curved surface (defined by 1585291089499-274.png General).

1585291096595-121.png

Figure: Curved surface approximation

1585291120185-283.png

Figure: Some examples for prismatic solids with definition steps

1585291134954-885.png

Figure: Full or truncated pyramid (Centric solid)

1585291145161-368.png

Figure: Some examples for centric solids with definition steps

1585291154492-440.png

Figure: Spheres defined in different coordinate-systems

1585291165458-749.png

Figure: Half and truncated spheres

1585291239874-927.png

Figure: Octa-, dodeca- and icosahedron

With General tool, general 3D solids can be defined with a directrix and a generation line (builds up the surface of the solid). Both of them can be a closed contour line or an arbitrary line (it can be also closed), but one by one. The only rule is that they must touch each other. Five tools can be used for defining the contour geometry and other five ones for defining the line geometry. The function of the contour line or the arbitrary line can be set with the Directrix is contour line (and the generation line is the arbitrary line) or the Directrix is line (and the generation line is the contour line) tools. The final shape of the solid depends on the Perpendicular and Constant options that define how (in what angle) the generation line will be transformed around the directrix:

  • Perpendicular: the solid sections having the same shape with the generation line will be perpendicular to the directrix in its all points.
  • Constant: the solid sections (inner surfaces) will be parallel with the generation line along the directrix.

1585291251823-606.png

Figure: Different combinations of directrix and generation line

1585291272706-840.png

Figure: Both directrix and generation line are closed contours

Text and Field

Custom (1585291290263-259.png Text command) and automatic (1585291297598-932.png Field command) texts can be placed on the drawing area in arbitrary position. They can also be edited any time.

1585291303258-681.png

Figure: Text and Field commands with their settings

At Text, the custom text can be defined in the Text field. At Field, the content of autotext can be set at Type. Some autotext types (such as Project title, Description, Designer’s name, Signature and Comments) are defined by the user at Settings > Title, and the other ones automatically set by the current project settings (such as File name, File date, Code name etc.). Field is especially useful in Documentation, as you can see it from the range of autotext types.

The following text properties can be set for both text and field items:

  • Font
    Choose the required font type from available MS Windows offered types.
  • Script
    Script solves the character problems at different languages. An example for the Times New Roman font: character “ő” appears as “õ” in Western, but as correct “ő” in Central European script.
  • Size
    It is the height of the font in millimeters.
  • Width
    It is the width of the font. Its value that is lower than 1 defines narrower letters. Its value that is bigger than 1 results thicker letters.
  • Slant
    You can set the slant of the letters in degrees that closes angle with the vertical direction. The angle is measured clockwise. The standard italic font has about 10-15 degree slant.
  • Alignment
    In the Alignment figure you can set the position of the text insertion point. The hatched rectangle is the border of the text and the insertion point is in the intersection of the two black lines. Moving the black lines with the mouse offers nine possible positions for the insertion point.

To place the text/field on the drawing area, give the coordinates of the insertion point, and then define its direction. The 1585291331266-354.png  mouse button sets the direction parallel (“horizontal”) with the X direction of UCS.

1585291338324-902.png

Figure: Text position

Special characters can be defined in Text field by typing “%” before letters and numbers. These are the followings:

  • %g = ° (degree symbol)
  • %d = ∅ (diameter symbol)
  • %p = ± (plus/minus symbol)
  • %% = %
  • %2 = 2 (square sign)
  • %3 = 3 (cube sign)

Dimension

With 1585291420394-617.png  Dimension, length, angle and level dimensions can be defined in custom style. The style of dimensions can be set by 1585291435990-705.png  Default settings.

1585291440392-746.png

Figure: Dimension settings

  • Dimension line extension
    Dimension line can be extended with a value.
  • Level
    The size of the 1585291456212-438.png  Level dimension symbol can be set with Size value.
  • Color and Pen width
    You can choose a color (black by default) for all dimension items, and set a pen width for the lines.
  • Layer
    Drawing layer (“DIM” by default) can be chosen for the new dimension items. Of course, you can define and use different layers by position (external/internal), by direction (horizontal/vertical), by type (length/level dimension) for example.
  • Extension line
    Sizes, positions and display settings can be set for extension lines.
  • Arrowheads
    The style, the size and the pen width of the arrowheads can be set here.
  • Text display properties
    The text style, the decimal numbers and the measurement unit type (independently from the project unit settings) of the numeric values can be set here. Additional text can be inserted before and after the measured values with Prefix and Suffix. Also special characters can be used as dimension text.
  • Horizontal / Vertical alignment
    The alignment of text to dimension lines can be set by direction.

Dimension types

From the Dimension tool palette chose the required type of the new dimension.

1585291476638-387.png

Figure: Dimension types

Different directions can be set for 1585291486765-508.png  Linear type dimensions:

  • Predefined direction
    The direction of dimension lines can be set parallel with one of the axis directions of the UCS or the global system.
    1585291500995-635.png
    Figure: Dimensions parallel with global axes
  • Parallel with line
    The direction of dimension lines can be set parallel with a line defined by two points.
    1585291531417-215.png
    Figure: Dimensions parallel with a given line
  • Perpendicular to plane
    The direction of dimension lines can be set perpendicular to a given plane (e.g. the plane of a wall).
    1585291555181-322.png
    Figure: Dimensions perpendicular to a given plane

    1585291568229-550.png
    Figure: Dimensions of arcs and circles

    1585291578991-419.png
    Figure: Dimensions of angles

    1585291584361-757.png
    Figure: Level dimension

Modification in dimension

  • Modify line dimension
    With this tool you can add new (reference) points to a selected predefined linear dimension line. First select the required dimension line, and then place the new point.

    1585291694736-216.png
    Figure: New points added to dimension line
     
  • Add dimension to base line
    New dimension lines can be added to a baseline of an existing linear dimension line. This means, that the starting point of the new lines is at the selected baseline of the dimension line. First select the dimension line, then choose the side or baseline, and finally add the new points. The new lines will inherit all properties from the selected one. The location of the selected dimension line determines that the new lines will be above it or below it.

    1585291715193-394.png
    Figure: New dimension line assigned to a base line of an existing one
     
  • Dimension line position
    The position of a predefined dimension lines can be modified easily. Just select the required dimension line, and then define its new position.
    1585291739593-800.png
    Figure: Modification in dimension line positions
  • Text content
    The real measured values can be substitute with any custom text. Not only numbers but letters can be added as text content. Do not forget to hide unit system, if you want to display only the new text. First select the text value, and then type the required text in the Text content dialog. Clicking the Original button restores the measured dimension value and overwrites the custom, the user-modified text.
    1585291758144-902.png

Edit and Modify Menu Commands

The Edit menu contains tools for editing and modifying drawing elements, structural elements, loads, reinforcement objects, result data, etc. The following table summarizes the editing tools, their function and examples.

Edit CommandIconFunctionExample
Repeat command Reruns the last used command. 
Undo1585291790155-542.png

Undoes the last operation such as the editing operations summarized in this list.

The maximum numbers of undoable operations can be set at Settings > Environment > General > System > Undo steps.

Calculation operations and previous commands cannot be undone.

Undo command does not close the current action window only resets it.

 
Redo1585291805135-426.png

Executes the previously undone command.

Redo command does not close the current action window only resets it.

 
Cut1585291814249-146.pngErases selected elements of the project and places it onto the Clipboard in order to Paste them later to the drawing area. An insertion point is required for the later insertion (paste). 
Copy1585291819143-427.pngPlaces selected items on the Clipboard. It does not delete the original objects. An insertion point is required for the later insertion (paste). 
Paste1585291824424-943.png

Inserts the FEM-Design-type drawing contents of the Clipboard into the current project’s drawing area. The elements are placed with the coordinates of the insertion point defined by Cut and Copy.

Paste together with Cut and Copy is working between more than one opened projects too.

 
Erase1585291842209-858.png

Deletes selected objects from the current project and so from the drawing area.

Some special objects can be deleted with their own eraser tool:

  • Holes of planar regional elements (plates, walls etc.) can be deleted with the Remove hole tool of Modify region command.
  • Finite elements of a mesh can be deleted with the Delete tool of the Finite elements tabmenu.
 
Copy bitmap It exports the selected part of the drawing area to the Clipboard as an image, and it can be inserted to other programs such as photo editors, MS Word, MS Excel, etc. 
Paste file 

Inserts the whole geometrical content (drawing and structural elements, loads, finite element mesh) of a FEM-Design file into the current project. The insertion point of the copied content is the global system origin of the pasted file.

The loaded file must be compatible with the current FEM-Design module.

-
External reference It imports DWG/DXF drawings as an image in the background 
Modify commandsIconFunction               Example
Move1585292000721-325.pngMoves objects or their copies with a given distance (displacement vector) in the drawing area. 
Copy1585292005422-131.pngMakes more than one copies of selected objects. Each copies can be moved with different distances. The base point of each copies are the same point of the selected elements. 
Mirror1585292025458-111.png

Mirrors selected objects or make a mirrored copy of them.

Elements or their copies can be mirrored to a given line or plane.

1585292139639-542.png
Rotate1585292034451-438.png

Rotates selected objects or make a rotated copy of them.

Elements or their copies can be rotated around a given point or line with an accurate angle or a defined new position.

1585292145691-878.png
 Array > Rectangular1585292164316-665.pngMultiplies selected objects as row (UCS y direction) and column (UCS x direction) distribution. The number of copies and the distance between the copies by direction are required.1585292152802-543.png
 Array > Polar1585292169404-659.png

Multiplies selected objects by rotating them around a centre point.

Required data: direction of rotation (Clockwise/Counter-clockwise), the origin of the rotation, the rotation angle and the number of copies.

1585292158949-812.png
Offset1585292380316-581.pngMakes a copy of line-type objects (line, arc, region contour, beam, column etc.) that will be placed parallel with the original object with a given distance and on the defined side.1585292180945-821.png
Stretch1585292387514-942.pngStretches line-type elements or the selected corners of closed polygons and region-type elements.1585292185165-128.png
Curve1585292337739-175.png

Curve a line-type element or an edge of region-type elements.

Clicking 1585292342894-932.png  on a curved line straigntens that.

1585292190398-520.png
Elbow1585292327151-528.pngBreaks a selected line or region edge, or in other word, it adds new point to lines and edges in new position.1585292196038-909.png
Scale1585292320984-821.pngScales objects, blocks, even the entire structure. A base point (will be the only point that will remain in its original place after scaling) and the scale factor are required for scaling1585292200657-298.png
Split1585292314677-235.pngAutomatically splits selected line-type elements in their common intersections.1585292206076-549.png
Trim1585292309563-356.pngCuts line-type objects along an edge defined by another object. The cutting edge may have a real or virtual intersetion with the selected line wanted to be trimmed.1585292213340-633.png
Extend1585292304897-650.pngExtends line-type objects to an edge defined by another object. The boundary edge may have a real or virtual intersetion with the selected line wanted to be extended.1585292219407-958.png
Break1585292299617-483.png

Cuts a section from line-type object and breaks it into two independent object.

Break can be used to cut a line into two parts by double clicking in the same line point (zero section length).

1585292225303-815.png
Chamfer1585292291693-237.png
  1. Cuts the corner of a closed polygon and region.
  2. Connects two line-type objects with a skew line defined by the chamfer distances.
1585292230732-224.png
Fillet1585292286465-348.png
  1. Rounds the corner of a closed polygon and region.
  2. Connects two line-type objects with an arc defined by the fillet radius.
1585292237006-724.png
Modify region1585292280632-538.png
  1. Removes hole from region-type object.
  2. Splits region by cutting edge defined manually or by the intersection of another region.
  3. Reduces/increases region area with parallel offset of region edges.
  4. Swaps faces of wall/plate regions (mirrors local system).
  5. Does logical operations (union, substarct, intercection and excluded “OR”) between regions.
1585292241636-424.png
Modify solid1585292274374-957.png
  1. Removes hole from drawing solid.
  2. Splits solid by cutting region/plane defined manually or by the intersection of another solid.
  3. Does logical operations (union, substarct, intercection and excluded “OR”) between solids.
1585292246110-231.png
Change direction1585292268251-152.png

Modifies the direction of the following object types:

  • column and beam section position,
  • support,
  • load,
  • parametric reinforcement,
  • applied reinforcement bar.
1585292251976-342.png
Change appearance1585292262240-685.png
  1. Changes display properties of drawing and structural objects such as color, line type, pen width, text style etc.
  2. Matches properties of an object with others.
 

Table: Edit menu tools

Quick modifications

By clicking right mouse button the quick menu appears. After clicking on an arbitrary element all the commands of quick menu are visible but those that are not available for the chosen element(s) are disabled.

 

Click LB (default)

Click + hold LB

CTRL + Hold LB

Line’s end point

Node on surface edge

StretchStretchDrag a copy

Along point

along line

CurveMoveDrag a copy

Any point inside Surface

MoveMoveDrag a copy
Any point on screen, where there is nothingBox selection

 

 
  • At  1585292520841-937.png   user can select another command in the Modify menu which is also available by 1585292526715-143.png .
  • 1585292522483-364.png  on line’s end point or node on surface edge starts ‘Stretch’ command or the last used command selected by the user for this case

    1585292552997-209.png
     
  • 1585292575048-645.png   on any point along the line starts ‘Curve’ command or the last command

    1585292600671-529.png
     
  • 1585292623135-945.png  on any point inside on surface starts ‘Move’ command

    1585292649993-800.png

     
  • 1585292671434-788.png and holding at line’s end point or surface edge’s end node starts ‘Stretch’ command

    1585292693118-763.png

     
  • 1585292724835-286.png  and holding at any point along line or any point inside surface starts ‘Move’ command

    1585292775760-282.png
     
  • 1585292790411-700.png  +holding 1585292739116-670.png at any point in a structural or drawing element starts to drag a copy of the object.

    1585292809142-188.png

     
  • 1585292748915-798.png  none of the objects starts ‘Box selection’

    1585292857274-973.png

     
  • 1585292881318-925.png  none of the objects hit pops up ‘Modify’ commands.

    1585292899853-293.png

Guide lines and Tracker

The Guide lines and Tracker appears when any commands started and assist the user in modeling and modifying elements in a much more effective way. Guide lines are displayed temporarily during modification or drawing to assist user to find desired point in a fast and easy way. There are two kinds of Guide lines Straight and Circular. The Color and Angle step can be set in the Settings/Environment/Guide line and Tracker. All features of Guide lines can be turned OFF/ON in its Setting dialog. There are three colors of Guide lines in FEM-Desig. Dark green line will be drawn if the Guide line is parallel with the X axis of UCS, orange line will be drawn if it is parallel with the Y axis of UCS and light green (as default color) line will be drawn for any other guide line.

1585292996411-368.png

1585293046191-264.png

 StandClick RB

Along line or arc

Parallel guide lineParallel guide line

Line’s middle or end point

Perpendicular guide linePerpendicular guide line

Guide line

-Remove that guide line

Guide lines can be defined on the following ways:

  • It appears automatically after 1 second, if mouse stands over a line

 This function can be turned off in its Settings by unchecking „Pop up guide line automatically if the mouse stays over a line for more than 1 second”

  • 1585293067239-919.png  on a line (straight, arc, circle or any object having these kind of geometry)

 Virtual intersections can be found easily with Guide lines

1585293082877-206.png

  • 1585293101463-177.png  and drag mouse to define arbitrary guide line. If 1585293107235-261.png  is pressed, the line is created with finite length (from start point to end point), otherwise it will have infinite length.

    Middle point of a rectangle can be found easily with Guide lines

    1585293225609-507.png

Guide lines are drawn in 3D, but Master Line (thick line) from which angle is measured, can only be placed in UCS or in a plane parallel to UCS.

  • Perpendicular guide line appears if mouse cursor stands over the end or middle point of a line, otherwise Parallel guide line appears.

    1585293345390-994.png
  • 1585293368295-790.png  over guide line will remove that guide line.

    1585293387114-984.png
  • By 1585293408529-921.png  over snap-free places, guide line settings will pop up.
  • Snapping on a Guide line + 1585293413575-460.png  will stick the pointer to that guide line.

    1585293432306-737.png

The Tracker tooltip shows Angle, Distance, dx, dy and dz from the last pointIt pop up next to the cursor while drawing and the tracker will be the same color as the Guide line.8

1585293457329-133.png

Modify region

Modify region command includes editing functions of drawing regions and region-type structural objects (plate, wall, surface load, surface support, surface reinforcement etc.).

  • Remove hole
  • Split region
    It divides regions into several pieces by cutting edge that can be defined manually as custom polyline or by selecting predefined lines or by selecting a region intersects the original one.

    1585293499089-573.png
    Figure: Splitting region
     
  • Perpendicular region offset
    It increases or decreases region area parallel with region edges. Offset can be done for all region edges, for all external contour, or for the hole edges.
    1585293520218-125.png
    Figure: Perpendicular region offset
     
  • Direction region offset
    It increases or decreases region area along a defined direction. Offset can be done for all region edges, for all external contour, or for the hole edges.

    1585293550314-579.png
    Figure: Direction region offset
     
  • Swap top and bottom faces
    It exchanges the upper and lower surface of plates and the front and back sides of walls. It also mirrors objects with variable thicknesses.

    1585293570791-882.png
    Figure: Swap plate region surface (variable thickness)
     
  • Logical operation: Union
    It adds user-defined area to a selected region or unifies two predefined regions. The result region always inherits the properties of the goal region selected first.

    1585293599583-234.png
    Figure: Custom drawn part added to a (plate) region
    1585293614671-197.png
    Figure: Unifying two regions into one
     
  • Logical operation: Substract
    It cuts out a part of a region, which will be determined by another region intersects the original one. The result region always inherits the properties of the goal region selected first.

    1585293650594-880.png
    Figure: Substract of two intersected regions
     
  • Logical operation: Intersection
    It creates a new region from the intersection of two regions. The result region always inherits the properties of the goal region selected first.

    1585293675788-152.png
    Figure: Intersection of two regions
     
  • Logical operation: Excluded “OR” (XOR)
    It performs an algebral XOR operation on an existing region and a shape drawn to intersect it or two regions having common part. The common part will be deleted. The result region always inherits the properties of the goal region selected first.

    1585293696664-772.png

    Figure: Deleted intersection part of two regions

Modify solid

Solid operations command includes editing functions of drawing solids.

  • Remove hole
  • Split solid
    It divides solids into several pieces by cutting plane that can be defined manually as custom plane or by selecting existing regions or by selecting a solid intersects the original one.

    1585293737073-826.png
    Figure: Splitting solid with predefined region and custom defined plane
     
  • Logical operation: Union
    It unifies one solid with another one(s). The result solid always inherits the properties of the goal solid selected first.

    1585293755727-784.png
    Figure: Unifying three solids into one
     
  • Logical operation: Substract
    It cuts out a part of a solid, which will be determined by another solid intersects the original one. The result solid always inherits the properties of the goal solid selected first.

    1585293772895-740.png

    Figure: Substract of solids
     
  • Logical operation: Intersection
    It creates a new solid from the common part of two solids. The result solid always inherits the properties of the goal solid selected first.

    1585293795736-960.png
    Figure: Intersection of two solids
     
  • Logical operation: Excluded “OR” (XOR)
    It performs an algebral XOR operation on two selected solids. The common part will be deleted. The result solid always inherits the properties of the goal solid selected first.

    1585293818034-815.png

    Figure: Deleted intersection part of two solids

Change appearance

The Change appearance command changes several properties of objects according to user modifications.

  • Change properties
    The display properties of objects can be modified in one settings dialog:
    • layer of drawing objects,
    • line type of lines, edges and axes,
    • text style of texts, tables, dimensions etc.
    • color of selected objects (different color can be set from the color of the layer assigned to the object),
    • pen width of objects.

1585293851696-304.png

Figure: Appearance modification

Created by Fredrik Lagerström on 2020/03/27 07:21
Copyright 2019 StruSoft AB
FEM-Design Wiki