Show last authors
1 {{box cssClass="floatinginfobox" title="**Contents**"}}
2 {{toc/}}
3 {{/box}}
4
5 This chapter summarizes the documentation possibilities of FEM-Design projects, models and results. It introduces the printing and (% class="wikiinternallink" %)//listing//(%%) (summary tables) functions and the automatic documentation based on templates ((% class="wikiinternallink" %)//Documentation module//(%%)).
6
7 = {{id name="Printing"/}}Printing =
8
9 [[image:1585649495990-104.png]] The full content or a selection part of the screen (//Drawing area//) can be printed out with the //Plot// command (//File// menu). Just click with [[image:1585649911949-467.png]] to send the entire screen to print preview, or define a selection box with [[image:1585649919868-880.png]] to set it content as the plotting input.
10
11 [[image:1585649936971-517.png]]
12
13 Figure: Plotting screen (entire or selected part)
14
15 The printing settings are the following:
16
17 * **Settings dialog style**
18 With //Dialog// and //Preview// buttons you can switch between the dialog box and the full screen mode of the plotting settings.
19 * **Printer setup**
20 The goal printer can be chosen from the available (installed or network) printers and plotters. PDF creator (not included by default) can be also set here to save the screen content as PDF. The printer or PDF settings are available at //Properties//.
21 * **Page setup**
22 The size of the paper and the margins together with the paper orientation can be set here in a separate dialog. Title label can be added to the print area. Check the box “//Info label//” to add title label to the bottom right corner of the print area. Set the page number and set the text size and the width of the label at //Setup//. The label contains custom text set by //Settings > Title// and autotext such as the file name and date modified.
23 \\[[image:1585649964029-739.png]]
24 Figure: Title label as header(((
25 |[[image:light.png]]|If you would like to print out only the content of the //Title//, place it on the drawing area with //Draw > Title information table//, add it to the print area selection and inactivate the //Info label// option at //Page setup//.
26
27 [[image:1585650010022-370.png]]
28 Figure: Title label as drawing element
29 )))
30 * **Color print**
31 Switch between grayscale and color (seen on screen) printing.
32 * **Pen simulation**
33 Different pen width values can be assigned to colors at //Setup//.
34 * **Print border**
35 Rectangle border fit to paper margins (//Page setup//) can be shown and set for printing out.
36 * **Print only selected area**
37 If this check box is active, only the selected area (in case of selection) will be printed otherwise the its environment (the whole content of the drawing area).
38 \\[[image:1585650168070-231.png]]
39 Figure: Printing selection
40 * **Scale**
41 Set the printing scale manually or select one from the list. Dashed border marks objects (selection size) to print and helps in setting the scale. //Fit scale to margins //option sets the biggest scale of the selected print area according to the paper size, margins and the origin (see later). //Fit text size to scale// option sets the scale of the texts according to the drawing scale (//1:?//) or keeps the original size of the text in case of its inactive status.
42 \\[[image:1585650187996-541.png]]
43 Figure: Printing text size
44 * **Origin**
45 The position of the selected printing area can be set with its distance from the origin. //Horizontal// defines the distance of the bottom-left corner of the printing area from the left margin and //Vertical// sets the distance of the bottom-left of the printing area from the bottom margin. //Center// buttons fit the printing area to the middle of the page area bordered by the margins. The printing area can be dragged by the mouse also on the symbolic white page.
46 [[image:1585650212143-558.png]]
47 Figure: Printing area position
48 * **Simple preview**
49 It is generally a problem to plot big models; setting the final position of drawings on the paper takes time. By activating //Simple preview//, the program shows only the frame of the selected printing area to reduce the generation time of the drawing when setting its position (//Origin//) and //Scale//.
50 \\[[image:1585650236735-876.png]]
51 Figure: Simple preview of the printing area
52 * **Save as default**
53 It saves the paper and color printing settings as the default plotting settings for later use and next projects.
54 Click //Print// to start printing. A small dialog appears, in which you may cancel/stop printing.
55
56 = {{id name="Quantity Estimation"/}}Quantity Estimation =
57
58 [[image:1585650262281-378.png]] Just one click on //Quantity estimation// (//Tools// menu), and a fast process collects all structural elements of the current project and lists their materials, identifiers, main geometric parameters (e.g. profiles/thickness), quantities, reinforcement diameter etc.
59
60 [[image:1585650451183-886.png]]
61
62 Figure: Quantity estimation
63
64 |(% style="width:123px" %)[[image:warning.png]]|(% style="width:1367px" %)Reinforcement quantities are displayed after (% class="wikiinternallink" %)//RC design//(%%) only.
65
66 Categorization by priorities and summary by certain properties are also available in the quantity estimation tables (//Options//).
67
68 (% style="text-align:center" %)
69 [[image:1585650634964-591.png]]
70
71 (% style="text-align: center;" %)
72 Figure: Categorization and summary features
73
74 The currently displayed table can be attached to [[image:1585650649867-163.png]] (% class="wikiinternallink" %)//Documentation//(%%) by clicking //Add to documentation//.
75
76 The results of quantity estimation can be printed out directly as tables with the //List// option. (Other summary tables such as structural, load, finite element input and analysis/design result outputs of the current project can be also listed here. You may also use the [[image:1585650657735-600.png]] (% class="wikiinternallink" %)//List//(%%) command of the //Tools// menu any time.)
77
78
79 (% style="text-align:center" %)
80 [[image:1585650670009-118.png]]
81
82 (% style="text-align: center;" %)
83 Figure: Listing quantity estimation results
84
85 = {{id name="Listing"/}}Listing =
86
87 All tables of input and output data can be collected and printed out.
88
89 After launching the List**// //**[[image:1585650762535-571.png]] command, the User can select the **required objects** – using Filter and/or common graphical selection methods - before the List tables dialog appears. The whole database can be listed by pressing [[image:1585650775592-253.png]] button. Selection can be carried out in the List tables dialog as well using the drop-down menu in the top right corner. The User can choose the followings:
90
91 * All (all objects of the model),
92 * Current selection (objects selected before List tables appeared; this option is not available when all objects were selected (by pressing Enter) after launching the List command),
93 * Visible objects (objects visible in the Application window),
94 * User defined filter (objects belonging to pre-defined filters).
95
96 Listed data depend on the selected objects. By ticking ‘Hide irrelevant tables’ check box those tables which are irrelevant by the current selection disappear (otherwise they are shown in grey).
97
98 (% style="text-align:center" %)
99 [[image:1585650791090-491.png]]
100
101 (% style="text-align: center;" %)
102 Figure: List tables dialog
103
104 Further options are available in //List tables// dialog:
105
106 (% style="text-align:center" %)
107 [[image:1585650807888-808.png]]
108
109 * **//Format table…//**: The table settings can be set for all export modes at Format Table...:
110 \\[[image:1585650819453-986.png]]
111 Figure: Customizable table settings
112 \\The following properties can be set:
113 ** a common text style (font type and size) for table titles, text and values;
114 ** the unit of the values by element type (//Length//, //Force//, //Displacement// etc.);
115 ** the column width that can be defined by the Width option or by stretching the right side of the selected column with mouse;
116 ** decimal number of numeric data; and
117 ** scientific form of numeric data.
118 * At **//Options//** (depending on the data type), the calculation points (nodes) can be set where you would like to ask and list (result) values.
119 * //Settings>// stores the current list settings as the default settings for later use and next projects or previously saved defaults can be loaded.
120 * With //Add to batch// option the selected data can be added to //Batch list// (see later).
121
122 In ‘Send to…’ drop-down menu the destination of the listed tables can be set. These are the followings:
123
124 (% style="text-align:center" %)
125 [[image:1585651169501-733.png]]
126
127 (% style="text-align: center;" %)
128 Figure: Listing procedure and modes
129
130 * **Clipboard**
131 Clicking //List data// sends the table of the selected item to the //Microsoft Office Clipboard//, which allows you to copy the table and text items from FEM-Design and paste them into another document such as Microsoft Excel, Word etc.
132 * **Printer**(((
133 |(((
134 [[image:1585651239840-813.png]]
135
136
137 [[image:1585651248680-563.png]]
138 )))|//List data// sends the selected data table directly to the printer according to //Page// and //Printer setup//. //Page setup// offers the same possibilities mentioned at (% class="wikiinternallink wikiinternallink" %)//Printing//(%%).
139 )))
140 * **Documentation** (listed tables appear in the documentation),
141 * **Excel file** (listed tables can be exported to an Excel file)
142
143 (% style="text-align:center" %)
144 [[image:1585651330219-428.png]]
145
146 In List to Excel dialog besides the File path also a Template path can be set if the User has a pre-defined Excel-template (with .xltx, .xlt, or .xltm extension). The created Excel file can be opened immediately by ticking ‘Open file in Excel’ checkbox.
147
148 * Listing without a template file: creates an Excel file in which all the tables are located on separate spreadsheets.
149 * Listing with a template file: the User can create a template in which the locations of the required tables in the spreadsheet are marked with ‘$$’ followed by the exact title of the table. Using a template allows the User to gain exactly the required data.
150
151 Template file:
152
153 [[image:1585651368606-116.png]]
154
155
156 Template-based exported file:
157
158 [[image:1585651378495-685.png]]
159
160 |[[image:light.png]]|After listing to Excel without any template and examining the number of columns belonging to a table, it is easier to create a template.
161
162 |(% style="width:125px" %)[[image:light.png]]|(% style="width:1365px" %)2 batch files + 2 templates are delivered with the program (FDSteelFrame, FDRCStruct).
163
164 To avoid the time-consuming procedure of selecting the tables for listing one by one **Batch **is implemented for the tables which can be saved and reloaded, even in different models. This way all the required tables can be listed by a few click. Tables can be added to the **Batch** by selecting the tables in the “Data” window and clicking on //Add to batch// button.
165
166 (% style="text-align:center" %)
167 [[image:1585651455415-666.png]]
168
169 The following options can be done with the batch:
170
171 * Delete tables (selected data will be deleted),
172 * Save batch (the batch can be saved to a batch script file with .bsc extension),
173 * Load batch (the saved batches can be loaded and used in other models; those tables which are not relevant in other models are displayed in grey),
174 * List batch (all tables in batch window will be listed in accordance with the settings of ‘List objects…’ and ‘Send to…’ drop-down menus.
175
176 The batch window and options can be hidden by clicking on //<Hide batch// button.
177
178 |(% style="width:125px" %)[[image:light.png]]|(% style="width:1365px" %)In batch window more data can be selected by holding [[image:1585651555723-388.png]] pressed or with the help of [[image:1585651568991-812.png]] and [[image:1585651550696-119.png]] buttons.
179
180 |(% style="width:125px" %)[[image:light.png]]|(% style="width:1365px" %)In a listed batch the order of the tables is the same as in the batch window. The order of the tables in batch window can be rearranged with [[image:1585651564003-467.png]] pressed and using [[image:1585651558099-650.png]] .
181
182 |(% style="width:125px" %)[[image:light.png]]|(% style="width:1365px" %)A saved batch file with load cases (or load combinations, stability analysis etc.) can be used in other models when the names of the load cases (or load combinations, stability analysis etc.) are the same due to that the identification is based on the name. If all load cases (or load combinations, stability analysis etc.) are selected in the batch window and the batch file is loaded in another model, all the load cases (or load combinations, stability analysis etc.) of the other model will be taken into account.
183
184 = {{id name="Documentation Module"/}}Documentation Module =
185
186 Although the (% class="wikiinternallink" %)//Plot//(%%) and (% class="wikiinternallink" %)//List//(%%) commands give quick report data possibilities, you can create multi-page documentation with the //Documentation// module. Titles, figures, texts, tables, images, headers, footers, table of content etc. can be placed in custom style into the complete documentation. //Documentation// module can be run in all FEM-Design modules (depending on your license).
187
188 Click [[image:1585647783555-453.png]] to enter //Documentation// mode.
189
190 [[image:1585647788341-158.png]]
191
192 Figure: Starting Document module
193
194 The next chapters introduce the possibilities and the proposed steps for defining complete set of design documentation.
195
196 == Main Commands ==
197
198 The commands and their functions:
199
200 [[image:1585647802656-346.png]]
201
202 Figure: Documentation tools
203
204 * **Section**
205 [[image:1585647823589-970.png]] //Section// defines documentation parts having different properties (=“sections”) such as page size, orientation, margin sizes and associated printer.(((
206 |[[image:1585647854136-601.png]]|Define a section for the cover page with a color image as //A4// page size and with a color associated printer, and another section for the other pages as //A3// size and with grey-scale printer for texts and figures with black lines.
207 )))
208 * (((
209 **Title block**
210 This is a command for creating and registering new labels, headers, footers and frames, and for inserting stored title templates into the document from the built-in or user-defined title block library. You can apply drawing and auto text tools to design your private label, title and frame style and then register it with [[image:1585647883538-453.png]] //Title block //command for current and future use.
211 )))
212 * (((
213 **Table of contents**
214 It inserts a table of contents into the current document. It contains the list of chapters (see the next command) and their page numbers. If you define a new chapter or make modifications, the program refreshes this list.
215 )))
216 * (((
217 **Chapter**
218 Titles of main and sub-chapters can be inserted into the document with item numbers and names.
219 )))
220 * (((
221 **Page break**
222 Defining a page break generates a new page with the same properties of the current section.
223 )))
224 * (((
225 **Graphical window**
226 The command lets you to insert (working) windows in which you can display different figures (geometry, loads, mesh, analysis and design results, etc.) into the current document.
227
228
229 |(% style="width:94px" %)[[image:warning.png]]|(% style="width:1356px" %)(((
230 A window object defined by [[image:1585648012204-635.png]] //Graphical window// is not a static figure with constant and fixed content. It is a working window, where you can use the layer systems, display settings and view commands (zoom and rotate operations, plane, side and space views, shade and wireframe display modes, etc.) to set the required appearance of the model, the loads, the supports, the results, etc.
231 )))
232 )))
233 * **Table**
234 It inserts tables of input and output data (e.g. list of load cases and load combinations). The function and the table settings are similar with the possibilities of the (% class="wikiinternallink" %)//List//(%%)**// //**command.
235 * **Draw box**
236 The tool inserts a working window into the document where you can create your own drawing with the commands of the //Draw// and //Edit// menus. Drawing layer-system is also available in a [[image:1585648001767-932.png]] //Draw box//.
237 * **Text box**
238 It is a simple word processor for creating texts, notes into the document. The size of the text box, the font styles and text alignment can be set manually.
239 * **Image**
240 Image files (e.g. jpg, bmp etc.) can be inserted to the document with this command.
241
242 == Control Panel ==
243
244 The control panel enables you to easy move between different parts of the current document, to set the properties of the inserted objects, and to print and create templates for further documentation.
245
246 |(% style="width:211px" %)(((
247 [[image:1585647590864-425.png]]
248 )))|(% style="width:1279px" %)(((
249 === **Documentation map** ===
250
251 The list contains the defined title boxes, sections, graphic boxes, images, drawings and texts (hereafter called “objects”). You can activate the selected list object by double clicking on its name.
252
253 In order to speed up work in Documentation, Sections can be hidden/shown by clicking the checkbox next to the section’s name.
254
255 The hidden sections are not locked thus, they can be cut, copied, pasted, moved, dropped or modified. If an active section is moved into a hidden one, both sections will be hidden and vice versa.
256
257 |[[image:light.png]]|It is possible to select more sections to hide at one go. Uncheck an active checkbox, all the selected sections will turn off. Check an inactive one, they will all be shown.
258
259 === **Navigation** ===
260
261 You can navigate between pages by [[image:1585647700116-967.png]] //Page up//, [[image:1585647704404-197.png]]// // //Page down//, [[image:1585647709602-810.png]]// // //Home //and [[image:1585647714147-882.png]]// // //End// buttons. Clicking [[image:1585647718455-915.png]]// // //Go to// switches to the object selected in the list (the same as double clicking the selected object in the //List//).
262
263 Titles added to documentation elements provide easy navigation through defined //text boxes// and figures (//Graphical window//, //Image// and //Draw box//).
264
265 === **Items** ===
266
267 With //Cut//, //Copy// and //Paste// tools you can modify the position of selected list items (multi-selection also works by using the mouse together with [[image:1585647732401-782.png]] and/or [[image:1585647739002-211.png]] keys). You can move a selected list object into a new position by holding down the [[image:1585647744542-711.png]] key and moving the mouse into the required row of the list. To erase one or more selected objects click on //Delete//. With //Properties// the settings (sizes, styles, contents, etc.) of the selected object can be modified. The variability of objects depends on the type of object (drawing, text, image, section, etc.).
268
269 === **Document** ===
270
271 With //Reset//, you can delete all contents of the current documentation and “open” a new, empty document with the default settings. At //Templates// you can save the current document structure and settings under a name as a template. You can also load a predefined one to create fast documentation of your current project (see later //Templates//). The //Print// command lets you print out the whole document or a part of it. With //Save as .docx //button the whole documentation can be exported to an Office OpenXML (.docx) file.
272 )))
273
274 == Steps to Create Your Own Documentation ==
275
276 This chapter shows the proposed steps of document creation via an easy example (in [[image:1585646405469-141.png]]** **//Plate// module).
277
278 |(% style="width:100px" %)[[image:light.png]]|(% style="width:1390px" %)For a faster documentation process, we recommend that you start documentation after finishing model generation and calculations and not before them.
279
280 1. **Document title**
281 Set the main properties of the document by selecting //Untitled// in the list and click on //Properties// at //Items//. Give a name for your document (in //Title//) and set the font settings by chapter orders (levels). Under //Utilities// you can save the settings as default or as a named style, so you can then load styles for future projects.
282 \\[[image:1585646456070-328.png]]
283 \\Figure: Document title
284 1. **Cover page (**Text box and Image - Section 1.**)**
285 Set the properties of //Section 1.// by activating it in the list and by clicking on //Properties//.
286 \\[[image:1585646640006-329.png]]
287 Figure: Cover page
288 1*. Set the paper size and orientation (e.g. //A4// and portrait).
289 1*. Choose a printer for the current section. You can set different printers, plotters and PDF creators per sections. It is very typical that the text parts are wanted to print as A4 and the figures etc. as A3, etc.
290 1*. Set the margin, from which the texts, figures, images, etc. will start. For example, the main title will start 60mm from the top of the page.
291 \\Write the title of the document on the first page with [[image:1585647176914-585.png]] //Text box//. The text will start from the upper margin.
292 \\[[image:1585647160629-613.png]]
293 Figure: Cover page with title
294 Also a subtitle can be created by re-running [[image:1585647192072-997.png]] //Text box//.(((
295 |(% style="width:90px" %)[[image:light.png]]|(% style="width:1320px" %)Empty rows and new lines can be defined with the Ctrl //+ //Enter// //key-combination.
296
297 Place an image file (e.g. a picture about the model) with the [[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image002.png||alt="icon_image.png"]] //Image// command. To open an image file, browse for it at //>// option of //File name//. Set the position of the picture from the side margins at //Alignment//. At //Size// you can define arbitrary size or special size (//Page width/// //Full page//) by choosing from the list under //>// symbol. Apply //Preserve ratio// to avoid figures from distortion during size definition.
298 \\[[image:1585647248270-464.png]]
299 Figure: Cover image
300
301 |(% style="width:90px" %)[[image:light.png]]|(% style="width:1320px" %)The settings for an inserted object (text box, image, etc.) may be modified by selecting it in the list and by pressing on the //Properties// option. It works the same as with the initial dialog of the object.
302 )))
303 1. **Table of contents (**Section 2.**)**
304 Create a new section (leave your selection on the last item (here the image)) with [[image:1585646303521-374.png]] //Section// and set the value of the top margin, which the table of content will start from (e.g. 30mm). Click on [[image:1585646312849-895.png]] //Table of contents// command and an empty “table” appears on the //Section 2// page. The table will be refilled automatically when defining //chapters//.
305 \\[[image:1585646324160-495.png]]
306 Figure: Inserted (empty) table of contents
307 1. **Header and footer (**Title block - Section 3.**)**
308 Create a new section (leave your selection on the last item (here “Table of contents”)) with [[image:1585646184659-655.png]] //Section// and set top and bottom margin values that define the available area for further text, figures and tables (30mm in this example). Use the commands from the //Draw// menu to prepare the appearance (frames and texts) of headers and footers. Apply e.g. //Line// and //Field// commands (//Auto-text//).
309 \\[[image:1585646193206-289.png]]
310 Figure: Header/footer defined by Line and Field commands(((
311 |(% style="width:100px" %)[[image:light.png]]|(% style="width:1390px" %)Where you see “?” symbol at an auto-text, the content can be defined at //Settings //>// Title//.
312
313 After finishing drawing, use the //Register// tool of [[image:1585646241182-810.png]] //Title block// to save your “header and footer” as built-in label parts. Type an identifier (“header&footer” in this example) for the title in //Name// field, select the lines and texts by window selection and give an insertion point (bottom left corner of the page in this example).
314 \\[[image:1585646252879-609.png]]
315 Figure: Header/footer defined by Line and Field commands
316 After registration, delete the drawings and text from the document by //Erase //(//Edit// menu)!
317 \\Insert the defined and registered title block into the document with the //Insert// tool of [[image:1585646279485-314.png]] //Title block//. Choose the saved “header&footer” from the //Name// list, and then place the insertion point of the selected title block on the bottom left corner of the page. As result, the “header&footer” will be repeated on every page in the current section (//Section 3.//).
318 \\[[image:1585646274430-578.png]]
319 Figure: Insertion of title block (header & footer)
320 )))
321 1. **Chapters (**Section 3.**)**
322 Place your first chapter with the [[image:1585646134324-776.png]] //Chapter// command. Give a name in //Title// field for the current chapter (“Geometry” in this example).
323 \\[[image:1585646140322-565.png]]
324 Figure: Insertion of chapter
325 For further chapters the program offers alternative numbering systems for the next main chapter (“2”) or subchapter (“1.1”). It depends on which button is active: [[image:1585646144746-862.png]]// // //Increase// //indent// or [[image:1585646149039-886.png]] //Decrease indent//.
326 1. **Figures (**Graphical window - Section 3.**)**
327 In a chapter you may insert text (see //Text box//), images (see //Image//) and figures of the model geometry, loads, results, etc. In this example, first place a figure about the model geometry (plates and supports). Click [[image:1585645910238-417.png]] //Graphical window//, choose //Structure//-type and set the display parameters of the image in the appeared dialogue box. You may give a name to the figure for displaying it (//Display title//, “Plane view”). A “1m scale bar” can be displayed inside the figure with //Display scale//. The size of the window can be set with a width and a height value or by choosing predefined sizes under //>// (//Page width/Full page//). The required figure position can be defined by activating one of the buttons for //Alignment// (“centre” in this example). The position of the title is the same as the activated //Alignment// of the window. Clicking //OK// inserts the new figure into the document.
328 \\[[image:1585645923063-332.png]]
329 Figure: Insertion of figure
330 \\Other graphical windows can be defined by repeating the previous step. For example, place a side view of the structure, etc.
331 \\Clicking the window area activates it as a working window, so you can modify the view and position of the window content. Black thick frame shows what graphical window is the active.(((
332 |(% style="width:52px" %)[[image:1585645981377-902.png]]|(% style="width:1398px" %)(((
333 For example, clicking the //Structure//-type graphical window, the display settings (//Settings// menu), the view commands (//View// menu) and the //layer system// (//Current layer//) may be used; but at an //Analysis// (result)-type graphical window, you can browse from results (//New result// and// Select result//), displaying numeric values (//Numeric value//).
334 )))
335
336 [[image:1585645940999-586.png]]
337 \\Figure: Available tools depend on the graphical window type
338
339
340 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)Each graphical window has its own layer system, main and display settings. //FEM-Design// also gives the possibility to define different units for displaying geometry and various results.
341
342 Click the white paper (outside from the active graphical window) to return back documentation.
343 \\Repeat the previous steps to define more //chapters// (2. Supports, 3. Loads, 3.1 Load cases, 3.2 Load combinations, etc.), and to place new figures (such as loads with a //Loads-type graphical window//).
344
345 |(% style="width:100px" %)[[image:light.png]]|(% style="width:1390px" %)There is no facility to set distances between texts, chapter title rows and figures, but with [[image:1585646078285-970.png]] //Text box// command you can insert empty lines between objects into the document.
346
347 Another way to insert figures is, that the current model view can be placed onto the last page of documentation with the [[image:1585646091090-662.png]] //Add view to document //command (//Tool// menu). Of course, the settings of the new graphical window can be modified later with the //Properties// tool of //Documentation//.
348 \\[[image:1585646099252-919.png]]
349 Figure: Quick export of current view as a figure into documentation
350 )))
351 1. **Tables (**Section 3.**)**
352 Input and output data as tables can be added to the document with the [[image:1585645872500-874.png]] //Table// command. The functions and tools of //Table// are same as described at **//List//**. Choose data to print out as a table from the available //Tables//, //Data// and //Result// lists. In this example, place a summarization table of load combinations (under chapter 3.2: Load combinations). First select //Load combinations// in //Data// list (//Tables/ Loads//), second set the table settings at //Table// and //Options//, and finally click on //List data//. As a result the selected table appears after the current documentation object.
353 [[image:1585645879525-860.png]]
354 Figure: Insert table to documentation
355 1. **Result figures (**Graphical window - Section 3.**)**
356 To document result figures, use [[image:1585645852539-906.png]]// // //Graphical window //and select //Analysis-//, //RC design-// , //Steel design-// or //Timber design// (depending on the available calculation type and what result you would like to display). After insertion, click inside the graphical window and choose result types with //New result// and/or// Select result//.
357
358 == Templates and Automatic Documentation ==
359
360 The documentation structure (cover, chapters, text and window positions) defined in //Documentation// module can be saved under a file name (//.DSC//) as a template for further projects. Click //Control Panel’s// //Templates //>// Save as //tool.
361
362 The program automatically generates your complete documentation, if you apply a previously defined or built-in template. Use //Templates //>// Apply// when entering to //Documentation// mode after modeling and calculate a new project, and the program automatically generates complete documentation by refreshing based on the applied template (it updates the title label, table of content, page numbers, figures and tables etc. of the template).
363
364 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)A picture inserted by //Image// is deleted in a new template!
365
366 If you load a template into a document having no calculated results, the //Analysis//, //RC design// or //Steel design//-type graphical windows contain only the structure, but they will be refreshed any time you have calculations.
367
368 The //Templates// can be appended into the Documentation by //Templates >/Append…// command. Items of the appended templates will be inserted after the last existing document item.
369
370 [[image:1585645781935-779.png]]
371
372 If an applied template generates documentation with //tables// having no valid values, the empty tables can be hidden. Select the title of the document (first row) in the //Control panel//, then click //Properties// and inactivate the “//Display empty tables//” option in the dialogue that pops up.
373
374 [[image:1585645664997-349.png]]
375
376 Figure: Empty tables hidden by Properties
377
378 The documentation can be exported to Office OpenXML (docx). For further information check the following link: [[http:~~/~~/download.strusoft.com/FEM-Design/inst150x/savetodocxfaq.pdf>>url:http://download.strusoft.com/FEM-Design/inst150x/savetodocxfaq.pdf]]
379
380 == Printing ==
381
382 The completed document or only some parts of it can be printed out with //Control Panel’s** **Print// tool or //File > Print document//.
383
384 (% style="text-align:center" %)
385 [[image:1585645626133-106.png]]
386
387 (% style="text-align: center;" %)
388 Figure: Printing setup
389
390 Set the //Page range// as:
391
392 * **All**
393 The whole document (all pages from start to end) will be printed out.
394 * **Selection**
395 The objects selected in the //Control panel// (multi-selection also works) and their pages will be printed out.
396 * **Pages**
397 This provides the possibility for printing by defined page. Enter page number and/or page ranges by separating with commas and by using “-“ (an example: 1,10,15-20,25, etc.).
398
399 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)The printing process requires associated printer(s) by the sections of the current documentation. If a section has not got a defined printer (//Undefined//), you can add one by selecting the section name in the document list and by using the //Properties// tool (//Change// option).
400
401 (% style="text-align:center" %)
402 [[image:1585645575047-943.png]]
403
404 (% style="text-align: center;" %)
405 Figure: Printer assigned to Section
406
407 |(% style="width:100px" %)[[image:light.png]]|(% style="width:1390px" %)If you assign a PDF creator program to all sections, you can save your documentation as a //PDF// file.
408
409 = {{id name="Export to .docx format"/}}Export to .docx format =
410
411 It  is possible to export the Documentation** **and any Detailed result to Office OpenXML (.docx) file.
412
413 In the Documentation module this feature can be accessed by the “//Save as .docx//” button at the bottom right corner of the Control panel.
414
415 [[image:1585645523602-569.png]]
416
417
418 To export data from the Detailed result window use the //File > Export to > Export to Office OpenXML (.docx) document// command or directly the //File > Export to Office OpenXML (.docx) document// command where it is available.
419
420 In both cases the “Save as Office open XML (docx) document” dialog appears, where User can decide the followings:
421
422 * where to save the result file
423 * which MS Office Word template file to use for the convention (optional)
424 * whether to mark the Documentation Sections in comments or not (only in Documentation module)
425
426 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)The used template files must be based on the original template file //My Documents\FEM-Design document templates\template for fem-design document templates.dotx, //as this file contains the style required for the exportation.
427
428 [[image:1585645480928-876.png]]
429
430
431 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)MS Office Word 2007 or newer is required for opening files with .docx distribution
432
433 It is highly recommended to mark the documentation sections in the exported file, since the page rendering in MS Word and in FEM-Design are different. Furthermore, the exported document has A4 format pages. Therefore, if there are pages in the FD Documentation with different size, it is easier to find them and change their size in the result .docx file with section marks.
434
435 Using own Word templates is useful when the FD Documentation contains Title block, since it is not possible to export it to .docx. As an alternative, User can create a Word template with custom headers and footers, and use it for the exportation.
436
437 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)Since MS Word has more sophisticated solutions for creating the table of contents, FEM-Design does not export it to the .docx document. However, chapters are exported, therefore table of contents can be created in MS Word easily.
438
439 **~ **An example of the exported Detailed result can be seen in the following figure:
440
441 [[image:1585645428189-156.png]]
442
443 **~ **
444
445 |(% style="width:100px" %)[[image:light.png]]|(% style="width:1390px" %)More information and useful hint can be found in the Docx FAQ.
446
447 = {{id name="Export to Mathcad and to XHTML"/}}Export to Mathcad and to XHTML =
448
449 User can export Detailed results to .xmcd (Mathcad 15) and to .html (XHTML with MathML). This opportunities can be accessed in the Detailed Result window’s //File > Export to// menu. The .html exportation is available for the detailed results of all Designs, while the .xmcd is for Steel and Timber design.
450
451 [[image:1585645349972-497.png]]
452
453 **~ **
454
455 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)The exported .html file can be displayed properly only in web browsers supporting MathML. Currently: Firefox 38 or higher, Safari 8 and 9, iOS Safari 8.4 or higher.
456
457 The result of the XHTML exportation is a .html file and also a folder, which contains elements of the html page.
458
459 [[image:1585645316289-692.png]]
460
461 The result of the exportation to Mathcad is a single .xmcd file, which is fully editable in Matchcad 15.
462
463 [[image:1585645304835-614.png]]
464
465
466 |(% style="width:116px" %)[[image:warning.png]]|(% style="width:1374px" %)Mathcad 15 M20 version is required to open the .xmcd file.
Copyright 2020 StruSoft AB
FEM-Design Wiki