This chapter summarizes the documentation possibilities of FEM-Design projects, models and results. It introduces the printing and listing (summary tables) functions and the automatic documentation based on templates (Documentation module).

Printing

1585649495990-104.png      The full content or a selection part of the screen (Drawing area) can be printed out with the Plot command (File menu). Just click with 1585649911949-467.png  to send the entire screen to print preview, or define a selection box with 1585649919868-880.png to set it content as the plotting input.

1585649936971-517.png

Figure: Plotting screen (entire or selected part)

The printing settings are the following:

  • Settings dialog style
    With Dialog and Preview buttons you can switch between the dialog box and the full screen mode of the plotting settings.
  • Printer setup
    The goal printer can be chosen from the available (installed or network) printers and plotters. PDF creator (not included by default) can be also set here to save the screen content as PDF. The printer or PDF settings are available at Properties.
  • Page setup
    The size of the paper and the margins together with the paper orientation can be set here in a separate dialog. Title label can be added to the print area. Check the box “Info label” to add title label to the bottom right corner of the print area. Set the page number and set the text size and the width of the label at Setup. The label contains custom text set by Settings > Title and autotext such as the file name and date modified.

    1585649964029-739.png
    Figure: Title label as header
    light.pngIf you would like to print out only the content of the Title, place it on the drawing area with Draw > Title information table, add it to the print area selection and inactivate the Info label option at Page setup.

    1585650010022-370.png
    Figure: Title label as drawing element

  • Color print
    Switch between grayscale and color (seen on screen) printing.
  • Pen simulation
    Different pen width values can be assigned to colors at Setup.
  • Print border
    Rectangle border fit to paper margins (Page setup) can be shown and set for printing out.
  • Print only selected area
    If this check box is active, only the selected area (in case of selection) will be printed otherwise the its environment (the whole content of the drawing area).

    1585650168070-231.png
    Figure: Printing selection
  • Scale
    Set the printing scale manually or select one from the list. Dashed border marks objects (selection size) to print and helps in setting the scale. Fit scale to margins option sets the biggest scale of the selected print area according to the paper size, margins and the origin (see later). Fit text size to scale option sets the scale of the texts according to the drawing scale (1:?) or keeps the original size of the text in case of its inactive status.

    1585650187996-541.png
    Figure: Printing text size
  • Origin
    The position of the selected printing area can be set with its distance from the origin. Horizontal defines the distance of the bottom-left corner of the printing area from the left margin and Vertical sets the distance of the bottom-left of the printing area from the bottom margin. Center buttons fit the printing area to the middle of the page area bordered by the margins. The printing area can be dragged by the mouse also on the symbolic white page.
    1585650212143-558.png
    Figure: Printing area position
  • Simple preview
    It is generally a problem to plot big models; setting the final position of drawings on the paper takes time. By activating Simple preview, the program shows only the frame of the selected printing area to reduce the generation time of the drawing when setting its position (Origin) and Scale.

    1585650236735-876.png
    Figure: Simple preview of the printing area
  • Save as default
    It saves the paper and color printing settings as the default plotting settings for later use and next projects.
    Click Print to start printing. A small dialog appears, in which you may cancel/stop printing.

Quantity Estimation

1585650262281-378.png Just one click on Quantity estimation (Tools menu), and a fast process collects all structural elements of the current project and lists their materials, identifiers, main geometric parameters (e.g. profiles/thickness), quantities, reinforcement diameter etc.

1585650451183-886.png

Figure: Quantity estimation

warning.pngReinforcement quantities are displayed after RC design only.

Categorization by priorities and summary by certain properties are also available in the quantity estimation tables (Options).

1585650634964-591.png

Figure: Categorization and summary features

The currently displayed table can be attached to 1585650649867-163.png Documentation by clicking Add to documentation.

The results of quantity estimation can be printed out directly as tables with the List option. (Other summary tables such as structural, load, finite element input and analysis/design result outputs of the current project can be also listed here. You may also use the 1585650657735-600.png  List command of the Tools menu any time.)

1585650670009-118.png

Figure: Listing quantity estimation results

Listing

All tables of input and output data can be collected and printed out.

After launching the List 1585650762535-571.png command, the User can select the required objects – using Filter and/or common graphical selection methods - before the List tables dialog appears. The whole database can be listed by pressing 1585650775592-253.png button. Selection can be carried out in the List tables dialog as well using the drop-down menu in the top right corner. The User can choose the followings:

  • All (all objects of the model),
  • Current selection (objects selected before List tables appeared; this option is not available when all objects were selected (by pressing Enter) after launching the List command),
  • Visible objects (objects visible in the Application window),
  • User defined filter (objects belonging to pre-defined filters).

Listed data depend on the selected objects. By ticking ‘Hide irrelevant tables’ check box those tables which are irrelevant by the current selection disappear (otherwise they are shown in grey).

1585650791090-491.png

Figure: List tables dialog

Further options are available in List tables dialog:

1585650807888-808.png

  • Format table…: The table settings can be set for all export modes at Format Table...:

    1585650819453-986.png
    Figure: Customizable table settings

    The following properties can be set:
    • a common text style (font type and size) for table titles, text and values;
    • the unit of the values by element type (Length, Force, Displacement etc.);
    • the column width that can be defined by the Width option or by stretching the right side of the selected column with mouse;
    • decimal number of numeric data; and
    • scientific form of numeric data.
  • At Options (depending on the data type), the calculation points (nodes) can be set where you would like to ask and list (result) values.
  • Settings> stores the current list settings as the default settings for later use and next projects or previously saved defaults can be loaded.
  • With Add to batch option the selected data can be added to Batch list (see later).

In ‘Send to…’ drop-down menu the destination of the listed tables can be set. These are the followings:

1585651169501-733.png

Figure: Listing procedure and modes

  • Clipboard
    Clicking List data sends the table of the selected item to the Microsoft Office Clipboard, which allows you to copy the table and text items from FEM-Design and paste them into another document such as Microsoft Excel, Word etc.
  • Printer

    1585651239840-813.png
     

    1585651248680-563.png

    List data sends the selected data table directly to the printer according to Page and Printer setup. Page setup offers the same possibilities mentioned at Printing.
  • Documentation (listed tables appear in the documentation),
  • Excel file (listed tables can be exported to an Excel file)

1585651330219-428.png

In List to Excel dialog besides the File path also a Template path can be set if the User has a pre-defined Excel-template (with .xltx, .xlt, or .xltm extension). The created Excel file can be opened immediately by ticking ‘Open file in Excel’ checkbox.

  • Listing without a template file: creates an Excel file in which all the tables are located on separate spreadsheets.
  • Listing with a template file: the User can create a template in which the locations of the required tables in the spreadsheet are marked with ‘$$’ followed by the exact title of the table. Using a template allows the User to gain exactly the required data.

Template file:

1585651368606-116.png

Template-based exported file:

1585651378495-685.png

light.pngAfter listing to Excel without any template and examining the number of columns belonging to a table, it is easier to create a template.
light.png2 batch files + 2 templates are delivered with the program (FDSteelFrame, FDRCStruct).

To avoid the time-consuming procedure of selecting the tables for listing one by one Batch is implemented for the tables which can be saved and reloaded, even in different models. This way all the required tables can be listed by a few click. Tables can be added to the Batch by selecting the tables in the “Data” window and clicking on Add to batch button.

1585651455415-666.png

The following options can be done with the batch:

  • Delete tables (selected data will be deleted),
  • Save batch (the batch can be saved to a batch script file with .bsc extension),
  • Load batch (the saved batches can be loaded and used in other models; those tables which are not relevant in other models are displayed in grey),
  • List batch (all tables in batch window will be listed in accordance with the settings of ‘List objects…’ and ‘Send to…’ drop-down menus.

The batch window and options can be hidden by clicking on <Hide batch button.

light.pngIn batch window more data can be selected by holding 1585651555723-388.png  pressed or with the help of 1585651568991-812.png  and 1585651550696-119.png buttons.
light.pngIn a listed batch the order of the tables is the same as in the batch window. The order of the tables in batch window can be rearranged with 1585651564003-467.png  pressed and using 1585651558099-650.png .
light.pngA saved batch file with load cases (or load combinations, stability analysis etc.) can be used in other models when the names of the load cases (or load combinations, stability analysis etc.) are the same due to that the identification is based on the name. If all load cases (or load combinations, stability analysis etc.) are selected in the batch window and the batch file is loaded in another model, all the load cases (or load combinations, stability analysis etc.) of the other model will be taken into account.

Documentation Module

Although the Plot and List commands give quick report data possibilities, you can create multi-page documentation with the Documentation module. Titles, figures, texts, tables, images, headers, footers, table of content etc. can be placed in custom style into the complete documentation. Documentation module can be run in all FEM-Design modules (depending on your license).

Click 1585647783555-453.png  to enter Documentation mode.

1585647788341-158.png

Figure: Starting Document module

The next chapters introduce the possibilities and the proposed steps for defining complete set of design documentation.

Main Commands

The commands and their functions:

1585647802656-346.png

Figure: Documentation tools

  • Section
    1585647823589-970.png Section defines documentation parts having different properties (=“sections”) such as page size, orientation, margin sizes and associated printer.
    1585647854136-601.pngDefine a section for the cover page with a color image as A4 page size and with a color associated printer, and another section for the other pages as A3 size and with grey-scale printer for texts and figures with black lines.
  • Title block
    This is a command for creating and registering new labels, headers, footers and frames, and for inserting stored title templates into the document from the built-in or user-defined title block library. You can apply drawing and auto text tools to design your private label, title and frame style and then register it with 1585647883538-453.png  Title block command for current and future use.

  • Table of contents
    It inserts a table of contents into the current document. It contains the list of chapters (see the next command) and their page numbers. If you define a new chapter or make modifications, the program refreshes this list.

  • Chapter
    Titles of main and sub-chapters can be inserted into the document with item numbers and names.

  • Page break
    Defining a page break generates a new page with the same properties of the current section.

  • Graphical window
    The command lets you to insert (working) windows in which you can display different figures (geometry, loads, mesh, analysis and design results, etc.) into the current document.
     

    warning.png

    A window object defined by 1585648012204-635.png  Graphical window is not a static figure with constant and fixed content. It is a working window, where you can use the layer systems, display settings and view commands (zoom and rotate operations, plane, side and space views, shade and wireframe display modes, etc.) to set the required appearance of the model, the loads, the supports, the results, etc.

  • Table
    It inserts tables of input and output data (e.g. list of load cases and load combinations). The function and the table settings are similar with the possibilities of the List command.
  • Draw box
    The tool inserts a working window into the document where you can create your own drawing with the commands of the Draw and Edit menus. Drawing layer-system is also available in a 1585648001767-932.png  Draw box.
  • Text box
    It is a simple word processor for creating texts, notes into the document. The size of the text box, the font styles and text alignment can be set manually.
  • Image
    Image files (e.g. jpg, bmp etc.) can be inserted to the document with this command.

Control Panel

The control panel enables you to easy move between different parts of the current document, to set the properties of the inserted objects, and to print and create templates for further documentation.

1585647590864-425.png

Documentation map

The list contains the defined title boxes, sections, graphic boxes, images, drawings and texts (hereafter called “objects”). You can activate the selected list object by double clicking on its name.

In order to speed up work in Documentation, Sections can be hidden/shown by clicking the checkbox next to the section’s name.

The hidden sections are not locked thus, they can be cut, copied, pasted, moved, dropped or modified. If an active section is moved into a hidden one, both sections will be hidden and vice versa.

light.pngIt is possible to select more sections to hide at one go. Uncheck an active checkbox, all the selected sections will turn off. Check an inactive one, they will all be shown.

Navigation

You can navigate between pages by 1585647700116-967.png  Page up, 1585647704404-197.png  Page down, 1585647709602-810.png  Home and 1585647714147-882.png  End buttons. Clicking 1585647718455-915.png  Go to switches to the object selected in the list (the same as double clicking the selected object in the List).

Titles added to documentation elements provide easy navigation through defined text boxes and figures (Graphical window, Image and Draw box).

Items

With Cut, Copy and Paste tools you can modify the position of selected list items (multi-selection also works by using the mouse together with 1585647732401-782.png  and/or 1585647739002-211.png  keys). You can move a selected list object into a new position by holding down the 1585647744542-711.png  key and moving the mouse into the required row of the list. To erase one or more selected objects click on Delete. With Properties the settings (sizes, styles, contents, etc.) of the selected object can be modified. The variability of objects depends on the type of object (drawing, text, image, section, etc.).

Document

With Reset, you can delete all contents of the current documentation and “open” a new, empty document with the default settings. At Templates you can save the current document structure and settings under a name as a template. You can also load a predefined one to create fast documentation of your current project (see later Templates). The Print command lets you print out the whole document or a part of it. With Save as .docx button the whole documentation can be exported to an Office OpenXML (.docx) file.

Steps to Create Your Own Documentation

This chapter shows the proposed steps of document creation via an easy example (in 1585646405469-141.png Plate module).

light.pngFor a faster documentation process, we recommend that you start documentation after finishing model generation and calculations and not before them.
  1. Document title
    Set the main properties of the document by selecting Untitled in the list and click on Properties at Items. Give a name for your document (in Title) and set the font settings by chapter orders (levels). Under Utilities you can save the settings as default or as a named style, so you can then load styles for future projects.

    1585646456070-328.png

    Figure: Document title
  2. Cover page (Text box and Image - Section 1.)
    Set the properties of Section 1. by activating it in the list and by clicking on Properties.

    1585646640006-329.png
    Figure: Cover page
    • Set the paper size and orientation (e.g. A4 and portrait).
    • Choose a printer for the current section. You can set different printers, plotters and PDF creators per sections. It is very typical that the text parts are wanted to print as A4 and the figures etc. as A3, etc.
    • Set the margin, from which the texts, figures, images, etc. will start. For example, the main title will start 60mm from the top of the page.

      Write the title of the document on the first page with 1585647176914-585.png  Text box. The text will start from the upper margin.

      1585647160629-613.png
      Figure: Cover page with title
      Also a subtitle can be created by re-running 1585647192072-997.png  Text box.
      light.pngEmpty rows and new lines can be defined with the Ctrl Enter key-combination.

      Place an image file (e.g. a picture about the model) with the icon_image.png  Image command. To open an image file, browse for it at > option of File name. Set the position of the picture from the side margins at Alignment. At Size you can define arbitrary size or special size (Page width/ Full page) by choosing from the list under > symbol. Apply Preserve ratio to avoid figures from distortion during size definition.

      1585647248270-464.png
      Figure: Cover image

      light.pngThe settings for an inserted object (text box, image, etc.) may be modified by selecting it in the list and by pressing on the Properties option. It works the same as with the initial dialog of the object.
  3. Table of contents (Section 2.)
    Create a new section (leave your selection on the last item (here the image)) with 1585646303521-374.png  Section and set the value of the top margin, which the table of content will start from (e.g. 30mm). Click on 1585646312849-895.png  Table of contents command and an empty “table” appears on the Section 2 page. The table will be refilled automatically when defining chapters.

    1585646324160-495.png
    Figure: Inserted (empty) table of contents
  4. Header and footer (Title block - Section 3.)
    Create a new section (leave your selection on the last item (here “Table of contents”)) with 1585646184659-655.png  Section and set top and bottom margin values that define the available area for further text, figures and tables (30mm in this example). Use the commands from the Draw menu to prepare the appearance (frames and texts) of headers and footers. Apply e.g. Line and Field commands (Auto-text).

    1585646193206-289.png
    Figure: Header/footer defined by Line and Field commands
    light.pngWhere you see “?” symbol at an auto-text, the content can be defined at Settings > Title.

    After finishing drawing, use the Register tool of 1585646241182-810.png  Title block to save your “header and footer” as built-in label parts. Type an identifier (“header&footer” in this example) for the title in Name field, select the lines and texts by window selection and give an insertion point (bottom left corner of the page in this example).

    1585646252879-609.png
    Figure: Header/footer defined by Line and Field commands
    After registration, delete the drawings and text from the document by Erase (Edit menu)!

    Insert the defined and registered title block into the document with the Insert tool of 1585646279485-314.png  Title block. Choose the saved “header&footer” from the Name list, and then place the insertion point of the selected title block on the bottom left corner of the page. As result, the “header&footer” will be repeated on every page in the current section (Section 3.).

    1585646274430-578.png
    Figure: Insertion of title block (header & footer)

  5. Chapters (Section 3.)
    Place your first chapter with the 1585646134324-776.png  Chapter command. Give a name in Title field for the current chapter (“Geometry” in this example).

    1585646140322-565.png
    Figure: Insertion of chapter
    For further chapters the program offers alternative numbering systems for the next main chapter (“2”) or subchapter (“1.1”). It depends on which button is active: 1585646144746-862.png  Increase indent or 1585646149039-886.png  Decrease indent.
  6. Figures (Graphical window - Section 3.)
    In a chapter you may insert text (see Text box), images (see Image) and figures of the model geometry, loads, results, etc. In this example, first place a figure about the model geometry (plates and supports). Click 1585645910238-417.png  Graphical window, choose Structure-type and set the display parameters of the image in the appeared dialogue box. You may give a name to the figure for displaying it (Display title, “Plane view”). A “1m scale bar” can be displayed inside the figure with Display scale. The size of the window can be set with a width and a height value or by choosing predefined sizes under > (Page width/Full page). The required figure position can be defined by activating one of the buttons for Alignment (“centre” in this example). The position of the title is the same as the activated Alignment of the window. Clicking OK inserts the new figure into the document.

    1585645923063-332.png
    Figure: Insertion of figure

    Other graphical windows can be defined by repeating the previous step. For example, place a side view of the structure, etc.

    Clicking the window area activates it as a working window, so you can modify the view and position of the window content. Black thick frame shows what graphical window is the active.
    1585645981377-902.png

    For example, clicking the Structure-type graphical window, the display settings (Settings menu), the view commands (View menu) and the layer system (Current layer) may be used; but at an Analysis (result)-type graphical window, you can browse from results (New result and Select result), displaying numeric values (Numeric value).

    1585645940999-586.png

    Figure: Available tools depend on the graphical window type
     

    warning.pngEach graphical window has its own layer system, main and display settings. FEM-Design also gives the possibility to define different units for displaying geometry and various results.

    Click the white paper (outside from the active graphical window) to return back documentation.

    Repeat the previous steps to define more chapters (2. Supports, 3. Loads, 3.1 Load cases, 3.2 Load combinations, etc.), and to place new figures (such as loads with a Loads-type graphical window).

    light.pngThere is no facility to set distances between texts, chapter title rows and figures, but with 1585646078285-970.png  Text box command you can insert empty lines between objects into the document.

    Another way to insert figures is, that the current model view can be placed onto the last page of documentation with the 1585646091090-662.png  Add view to document command (Tool menu). Of course, the settings of the new graphical window can be modified later with the Properties tool of Documentation.

    1585646099252-919.png
    Figure: Quick export of current view as a figure into documentation

  7. Tables (Section 3.)
    Input and output data as tables can be added to the document with the 1585645872500-874.png  Table command. The functions and tools of Table are same as described at List. Choose data to print out as a table from the available Tables, Data and Result lists. In this example, place a summarization table of load combinations (under chapter 3.2: Load combinations). First select Load combinations in Data list (Tables/ Loads), second set the table settings at Table and Options, and finally click on List data. As a result the selected table appears after the current documentation object.
    1585645879525-860.png
    Figure: Insert table to documentation
  8. Result figures (Graphical window - Section 3.)
    To document result figures, use 1585645852539-906.png  Graphical window and select Analysis-, RC design- , Steel design- or Timber design (depending on the available calculation type and what result you would like to display). After insertion, click inside the graphical window and choose result types with New result and/or Select result.

Templates and Automatic Documentation

The documentation structure (cover, chapters, text and window positions) defined in Documentation module can be saved under a file name (.DSC) as a template for further projects. Click Control Panel’s Templates > Save as tool.

The program automatically generates your complete documentation, if you apply a previously defined or built-in template. Use Templates > Apply when entering to Documentation mode after modeling and calculate a new project, and the program automatically generates complete documentation by refreshing based on the applied template (it updates the title label, table of content, page numbers, figures and tables etc. of the template).

warning.pngA picture inserted by Image is deleted in a new template!

If you load a template into a document having no calculated results, the Analysis, RC design or Steel design-type graphical windows contain only the structure, but they will be refreshed any time you have calculations.

The Templates can be appended into the Documentation by Templates >/Append… command. Items of the appended templates will be inserted after the last existing document item.

1585645781935-779.png

If an applied template generates documentation with tables having no valid values, the empty tables can be hidden. Select the title of the document (first row) in the Control panel, then click Properties and inactivate the “Display empty tables” option in the dialogue that pops up.

1585645664997-349.png

Figure: Empty tables hidden by Properties

The documentation can be exported to Office OpenXML (docx). For further information check the following link: http://download.strusoft.com/FEM-Design/inst150x/savetodocxfaq.pdf

Printing

The completed document or only some parts of it can be printed out with Control Panel’s Print tool or File > Print document.

1585645626133-106.png

Figure: Printing setup

Set the Page range as:

  • All
    The whole document (all pages from start to end) will be printed out.
  • Selection
    The objects selected in the Control panel (multi-selection also works) and their pages will be printed out.
  • Pages
    This provides the possibility for printing by defined page. Enter page number and/or page ranges by separating with commas and by using “-“ (an example: 1,10,15-20,25, etc.).
warning.pngThe printing process requires associated printer(s) by the sections of the current documentation. If a section has not got a defined printer (Undefined), you can add one by selecting the section name in the document list and by using the Properties tool (Change option).

1585645575047-943.png

Figure: Printer assigned to Section

light.pngIf you assign a PDF creator program to all sections, you can save your documentation as a PDF file.

Export to .docx format

It  is possible to export the Documentation and any Detailed result to Office OpenXML (.docx) file.

In the Documentation module this feature can be accessed by the “Save as .docx” button at the bottom right corner of the Control panel.

1585645523602-569.png

To export data from the Detailed result window use the File > Export to > Export to Office OpenXML (.docx) document command or directly the File > Export to Office OpenXML (.docx) document command where it is available.

In both cases the “Save as Office open XML (docx) document” dialog appears, where User can decide the followings:

  • where to save the result file
  • which MS Office Word template file to use for the convention (optional)
  • whether to mark the Documentation Sections in comments or not (only in Documentation module)
warning.pngThe used template files must be based on the original template file My Documents\FEM-Design document templates\template for fem-design document templates.dotx, as this file contains the style required for the exportation.

1585645480928-876.png

warning.pngMS Office Word 2007 or newer is required for opening files with .docx distribution

It is highly recommended to mark the documentation sections in the exported file, since the page rendering in MS Word and in FEM-Design are different. Furthermore, the exported document has A4 format pages. Therefore, if there are pages in the FD Documentation with different size, it is easier to find them and change their size in the result .docx file with section marks.

Using own Word templates is useful when the FD Documentation contains Title block, since it is not possible to export it to .docx. As an alternative, User can create a Word template with custom headers and footers, and use it for the exportation.

warning.pngSince MS Word has more sophisticated solutions for creating the table of contents, FEM-Design does not export it to the .docx document. However, chapters are exported, therefore table of contents can be created in MS Word easily.

 An example of the exported Detailed result can be seen in the following figure:

1585645428189-156.png

 

light.pngMore information and useful hint can be found in the Docx FAQ.

Export to Mathcad and to XHTML

User can export Detailed results to .xmcd (Mathcad 15) and to .html (XHTML with MathML). This opportunities can be accessed in the Detailed Result window’s File > Export to menu. The .html exportation is available for the detailed results of all Designs, while the .xmcd is for Steel and Timber design.

1585645349972-497.png

 

warning.pngThe exported .html file can be displayed properly only in web browsers supporting MathML. Currently: Firefox 38 or higher, Safari 8 and 9, iOS Safari 8.4 or higher.

The result of the XHTML exportation is a .html file and also a folder, which contains elements of the html page.

1585645316289-692.png

The result of the exportation to Mathcad is a single .xmcd file, which is fully editable in Matchcad 15.

1585645304835-614.png

warning.pngMathcad 15 M20 version is required to open the .xmcd file.
Created by Fredrik Lagerström on 2020/03/31 10:38
Copyright 2019 StruSoft AB
FEM-Design Wiki