A model consists of structural objects, loads and finite elements. This chapter summarizes the definition ways, the properties and the features of the structural objects.

Depending on the current FEM-Design Module (license you have), the available Object types are different. Although the structural objects are real 3 dimensional objects, they are 1D members and 2D planar elements (because of the finite element method) having sectional (thickness, profile etc.) and material properties. So, they can be defined as lines or regions. Some elements like point supports can be defined as points.

TypeIconModules where available

Definition

mode

PositionMaterialProfile

Load-

bearing

Soil1584603814981-709.png1584602208253-331.pngRegionHorizontalArbitrary-Arbitrary
Borehole1584603822261-738.png1584602210083-549.pngPoint----
Isolated foundation1584603829044-457.png1584602212179-470.pngRegular shape/SolidHorizontalConcreteArbitraryArbitrary
Wall foundation1584603841098-596.png1584602219423-925.pngLineHorizontalConcreteArbitraryArbitrary
Foundation slab1584603848256-757.png1584602217074-327.pngRegionHorizontalConcreteArbitraryArbitrary
Beam1584603859591-112.png

1584602561989-469.png

1584602214397-138.png  1584602626305-896.png  

Line

Horizontal

Arbitrary

ArbitraryArbitraryArbitrary
Column1584603866327-126.png

1584602559305-131.png

1584602222080-774.png  1584602621130-909.png  

Point

Point/Line

VerticalArbitraryArbitrary

(Support)

Arbitrary

Truss member

1584603873028-793.png1584602224568-738.png  1584602618708-185.png  LineArbitraryArbitraryArbitraryAxial

Intermediate section

1584603880617-711.png1584602226949-495.png  1584602617236-838.png  1584602544973-878.pngPoint-ArbitraryArbitrary-
Apex1584603889506-762.png1584602240547-944.png  1584602623687-545.pngLine

Vertical / Horizontal

TimberRectangleArbitrary
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image016.png Column corbel1584603896480-680.png1584602237211-483.png  1584602614748-860.pngPointHorizontalArbitraryArbitraryArbitrary
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image016.png Wall corbel1584603901949-632.png1584602233922-164.pngLineHorizontalArbitraryArbitraryArbitrary
 Plate1584603908879-545.png

1584602542466-682.png

1584602230254-792.png  

Region

Horizontal

Arbitrary

ArbitraryConstant / variable thickness

Vertical

Axial

Wall1584603917622-954.png

1584602591139-209.png

1584603927995-543.png 1584603950554-740.png

1584603937205-689.png

Line

Region

Line

VerticalArbitraryConstant/ variable thickness

(Support)

Planar

Arbitrary

Profiled panel

1584605667677-283.png1584604885106-242.pngLine/RegionVertical/HorizontalConcreteConstantArbitrary
Timber panel1584605673548-322.png1584604887313-772.pngLine/RegionVertical/HorizontalTimberConstantArbitrary

Point support

 

1584602573981-946.png

1584605682460-575.png 1584605763415-696.png 1584605783100-219.png

1584604896073-561.png

Point

Vertical

Arbitrary

---

Line support

 

1584605826007-726.png 1584605686131-287.png 1584605756473-657.png

1584604903979-827.png

Line

Vertical

Arbitrary

---

Surface support (group)

 

 

1584604916166-214.png

Region

Vertical

Arbitrary

---

Point-point connection

 

1584605248316-672.png

1584604936217-115.png 1584605692944-870.png 1584605747679-418.png

Line

Horizontal

Arbitrary

---

Line-line connection

 

1584605244903-256.png

1584605273661-849.png 1584605723071-700.png 1584605741598-931.png

Lines

Horizontal

Arbitrary

---

Fictitious bar

 

1584605251734-513.png

1584605270193-110.png

Line

Horizontal

Arbitrary

---
Shell model 1584605268223-162.pngRegionsArbitrarySteelConstant/ variable web heightArbitrary

Fictitious shell

 1584605266522-828.pngRegionsArbitrary---

Profiled panel

icon_3DSTRULine/RegionVertical/HorizontalConcreteConstantArbitrary
Timber panelicon_3DSTRULine/RegionVertical/HorizontalTimberConstantArbitrary

Point support

icon_PLATEMODULE

icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU

Point

Vertical

Arbitrary

---

Line support

icon_PLATEMODULE icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU  Line

Vertical

Arbitrary

---

Surface support (group)

icon_PLATEMODULE

icon_3DSTRU  

Region

Vertical

Arbitrary

---

Point-point connection

icon_PLATEMODULE

icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU

Line

Horizontal

Arbitrary

---

Line-line connection

icon_PLATEMODULE

icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU

Lines

Horizontal

Arbitrary

---

Fictitious bar

icon_PLATEMODULE

icon_FRAMEMODULE  icon_3DSTRU  

Line

Horizontal

Arbitrary

---
Shell modelicon_3DSTRURegionsArbitrarySteelConstant/ variable web heightArbitrary

Fictitious shell

icon_3DSTRU  RegionsArbitrary---

Table: Structural Objects and their main properties

The commands for defining structural objects can be started from the tabmenu_Structure  Tabmenu. Each command has a Tool palette with the customizable element properties (cross-sections, materials, stiffness values etc.) and the definition tools of the element geometry and position (direction).

Properties

Tool palette contains all customizable structural properties. The main properties can be set directly in the tool palette and all properties can be set in the dialog opens by clicking on the Default settings button. The settings dialog and fields keep the last set property values by element types (beams, columns, plates etc.)

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image034.png

Figure: Setting part of Tool palette

Cross-sections

FEM-Design offers the possibility to add any cross-section type/shape (Section) to beams, columns and truss members.

MCj04113200000%5b1%5d    To avoid design failures of concrete, steel and timber bars (section type and material do not fit), the program checks the section type - material compatibility while setting the properties. The program sends an error message when it finds incompatibility definition at closing the settings dialog. But, the so-called General material (defined by the user) can be added to each section types.

The Section tabpage of the settings dialog contains predefined cross-sections. Unique profiles and shapes can be define by their parameters (parametric shapes) in New> Size or with the icon_SECTIONEDITOR  FEM-Design Section Editor. The following table sums the available cross-section types.

TypeDescriptionSection library

Compatible

material

Standard steel profilesNot editable, built-in steel profiles depending on the applied national codefile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image037.pngSteel (or General)
Often used concrete profilesNot editable, built-in square, rectangular and circular concrete profilesfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image038.pngConcrete (or General)
Often used timber profilesNot editable, built-in square timber profilesfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image039.pngTimber (or General)
Common parametric concrete shapesPredefined concrete shapes to create required profiles by defining the shape parametersfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image040.pngConcrete (or General)
Common parametric rolled steel shapesPredefined rolled steel shapes to create required profiles by defining the shape parametersfigure_sections_steelrolledparamSteel (or General)
Common parametric cold-formed steel shapesPredefined cold-formed steel shapes to create required profiles by defining the shape parametersfigure_sections_steelcoldparamSteel (or General)
Common parametric welded steel shapesPredefined welded steel shapes to create required profiles by defining the shape parametersfigure_sections_steelweldparamSteel (or General)
Common parametric timber shapesPredefined timber shapes to create required profiles by defining the shape parametersfigure_sections_timberparamTimber (or General)

Table: Section types

Defining a new (e.g. parametric) section in the settings dialog, the program calculates automatically the parameters need for later analysis and design. Each bar element has a local coordinate-system which y and z axes define the plane of its cross-section.

ParameterMeaningExample
AAreafigure_sectionsparam
PPerimeter
A/PArea/Perimeter
Yg, ZgCenter of gravity
Ys, ZsShear center position
Iy, IzMoment of inertia
Wy, WzSection modulus
ez max, ey maxMaximum distance of extreme fiber
ez min, ey minMinimum distance of extreme fiber
iy, izRadius of inertia
Sy, SzMaximum statical moment
ItTorsion moment of inertia
WtTorsion section modulus
IgammaWarping parameter
IyzCentroidal product of inertia
z omegaWagner warping parameter
alpha1, alpha2Angle of principal direction
I1, I2Principal moment of inertia
W1 min, W2 minPrincipal minimum section modulus
W1 max, W2 maxPrincipal maximum section modulus
e2 max, e1 maxMaximum distance of extreme fiber
e2 min, e1 minMinimum distance of extreme fiber
i1, i2Radius of principal inertia
S1, S2Principal maximum statical moment
So1, So2Principal statical moment of half area
c1, c2Plastic/elastic moment capacity
Rho 1, Rho 2Principal shear factor
z2, z1Wagner parameter

Table: Sectional characteristics

A cross-section is stored in the following tree structure: group > type > size. New library items can be defined or previous ones can be edited (renamed, modified or deleted) by the following settings options.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image046.png

Figure: Section library structure

Cross-sections used in the project and defined as parametric profiles are grouped in Used sections library, but they are available only in the current project.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image047.png

Figure: “Used sections” library

MCj04113200000%5b1%5d    You can Import and Export the Section Library to share the content of the Library.

Composite sections

Composite sections can be set for beams, columns and piles.

The available composite section types:

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image048.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image049.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image050.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image051.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image052.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image053.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image054.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image055.png

Click Default settings/Section tab/Composite/New to open the settings of Composite sections.

Schematic illustration

Real section

Composite section library

Editable values

Cross-section data

MCj04113200000%5b1%5dFor the time being only above listed composite sections can be selected, there is no choice to create alternative section.

Materials

The Material tabpage of the settings dialog contains predefined materials according to the current national standard.

A model may include mixture of elements with different materials, and analysis can be done for the complete model, but design can be done for elements having proper materials.

MaterialDesign
ConcreteRC design
SteelSteel design
TimberTimber design
General- (only for analysis)
Bar steelRC design

Table: Available and design materials

Material library stores the available materials by material type groups. Materials used in the project are grouped in Used materials library, but they are available only in the current project.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image058.png

Table: Material library

Above the standard materials, user can define concrete, steel, timber and general materials. The new materials are also stored in the Material library in the proper material type group. To define a new (e.g. concrete) material, select the required material group name (e.g. Concrete), click New and set the required material properties starting with the material name first.

figure_material_new

Table: Material types

Concrete

For concrete structures, the partial safety factors γc and γS can be calculated automatically from Eurocode 2 reductions. Click Safety factor calculator next to the safety factors (Default settings > Material > Application data), check the required reduction box and press OK.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image060.jpg

Figure: Safety factor calculator

In Material settings dialog different creep coefficients can be specified for Serviceability Limit State (SLS) and Ultimate Limit State (ULS). It has some consequences in load case calculation and results:

  • All load cases are calculated twice (first with the SLS Creep coefficient, than with the ULS Creep coefficient.
  • The displayed displacements are the results of the SLS calculation.
  • The displayed internal forces, reactions are the results of the ULS calculation.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image061.jpg

Figure: Setting of creep coefficients

For reinforced concrete structure the user has the possibility to reduce the element stiffness in order to model the cracking’s effect in eigenfrequency calculation.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image062.jpg

Figure: Stiffness reduction for reinforce concrete elements

In Material settings dialog the stiffness for stability analysis can be decreased. Taking a reduction factor into account is needed in those calculations where it is specified by the standards (e.g. at the cracked section analysis).

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image063.jpg

Figure: Reduction for stability analysis

Steel

For steel structures, the γ values (M0, M1 and M2) can be set.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image064.jpg

Figure: Setting γ factors

Timber

For timber structures, the γM, Service class, the System strength factor and kcr values can be set.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image065.jpg

Figure: Timber material settings

The following table and figures summarize the calculation of Young moduli used in different analysis types for concrete, steel and timber materials.

Analysis type ConcreteSteelTimber

Load cases,

Load group,

1st order load combination

ULSEcm(1+φu)file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image066.png

Ekfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image067.png

 

Eo,mean(1+kdef)file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image068.png
SLSEcm(1+φs)file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image069.png

2nd order load combination,

Imperfection calculation

ULSEcm(1+φu)∙1γcEfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image070.pngEo,meanγMfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image071.png
SLSEcm(1+φs)∙1γcEfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image072.png
Stability analysis fstab∙Ecmfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image073.pngEo,mean(1+kdef)file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image068.png

Eigenfrequency calculation

Seismic analysis

 fdin∙Ecmfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image074.pngEo,meanfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image075.png

Table: Calculation of Young-moduli in different analysis types

The properties of the current (selected in the list) material can be edited with the Modify tool.

Customized material database can be shared between projects and users with the Export and Import tools. Click Export to save all materials of the current project in a named database file (.fdlmat). To load an exported material database to a project, just apply Import and browse for it.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image076.png

Figure: Material export/import

MCj02990090000%5b1%5d    Just one click on Quantity estimation (Tools menu), and a fast process collects all structural elements of the current project with their applied materials, material qualities, identifiers, main geometric parameters (e.g. profiles), quantities etc.

MCj04113200000%5b1%5d    Modifying the national standard for a model the program shows a dialog where you can convert the material property of the structural elements and the reinforcing steel, so the materials will automatically change after switching the code.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image078.png

Figure: Material conversion dialog

Information Pop-up

Moving the cursor over a structural object, an Information pop-up appears with its main properties. For example, the pop-up displays the ID, the material, the thickness, the alignment and orthotropic features for Plates.

figure_09_info

Figure: Information pop-up example

MCj04113200000%5b1%5d   Information pop-up appears only for elements on visible layers and if there is not running command.

MCj02990090000%5b1%5d   Pop-up is enabled by default. To unable it, uncheck the Display information pop-up at Settings > All > Environment > General >View.

“Properties” Tool

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image083.png       With the Properties tool of a tool palette, the properties of a selected object or objects can be inquired and edited in dialog format (similar to Default settings).

Figure: Modifying object properties (e.g. cross-section of a selected beam)

Modify properties by “Quick menu”

Alternative way of modifying object properties is to select any object by right click, or more objects of the same type by box, then click “Propertiesfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image084.png in the Quick menu to check/modify its/their properties. This function works for structural objects, loads or design elements.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image085.png

“Pick properties” and “Copy properties”

With these functions the properties of an object can be copied to others of the same type, or picked to use as default. Both can be found in the Tools menu and in the toolbar as well.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image086.png

1.

2.

To copy properties with the Copy properties (file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image089.png ) function, first select the source object, then one or more objects to which the properties are to be applied.

Pick properties (file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image090.png ), when used on an object (of the same type as in the active editing dialogue) will update the default settings for its type.

MCj04113200000%5b1%5dPick properties can only be used when Define is selected in an editing window, otherwise it is disabled. 

Copy and Pick properties work according to the following rules:

  • Generally, the properties defined by the property dialogue will be picked or copied.
  • They are only available in the 3D Structure and Plate modules.
  • ID will not be copied.
  • Load case of loads will not be copied.
  • Varying shell thickness and surface load value will not be copied.

Numbering

Structural elements with an ‘Identifier (. position number)’ will have an automatically or manually assigned position number.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image092.png

The position number will be 0 upon creating the object and will be automatically set to another value in the following cases:

  • before creating a list
  • using the Find tool
  • before calculation

User can manually set position numbers by Tools/Numbering… file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image093.png  tool.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image093.png

Use file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image093.png  for Manual position numbering

  1. type required position number into the Position no. textbox
  2. select option for handling position number conflicts
  3. select object(s) to set position number for

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image094.png

MCj04113200000%5b1%5d  In case more objects are selected, the first one gets the position number typed by the user and for the next ones it is increased automatically.

To set position number of component objects, like edge connections, corbels, post-tensioned cables, punching regions, the Select component (…)  auxiliary option has to be checked.

Objects with manually set position number can be highlighted by checking the last option of the tool window.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image095.png

The position number can be reset to zero by choosing Reset file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image096.png  option then selecting one or more objects.

Automatic numbering file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image097.png  sets position number automatically for all objects in the database except the ones with manually set position number.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image098.png
The option to Lock numbering can be accessed by clicking its icon file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image099.png  in the same Tool window.

When the numbering of a selected object type is locked, the position number of individual elements will remain the same. The maximum position number is saved for all IDs, so position numbers less than that will not be used in the future, even if some items are deleted.

This means all the element types with their numbering locked will retain their original ID, even after refreshing the numbering (either manually, or automatically).

Erasing object – effect on structural IDs

Without locking numbering

With numbering locked

Display Settings of Structural Elements

The display properties of the structural elements can be set at the Settings > All… > Display.

The available options depend on the current FEM-Design module.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image103.png

Figure: Settings options affect on the appearance of the structural elements

  • Drawing elements

With the Show end points of line option you can show (or hide) the insertion points of planar structural objects, their holes and bar objects (beams, columns etc.). These points are visible in all display modes, but the Wireframe mode without displaying the elements’ thickness gives the clearest appearance of them.

display_endpoints

Figure: Insertion points displayed in Wireframe mode

MCj02990090000%5b1%5d       By showing the insertion points you can also detect the unnecessary (for example accidentally) defined points, which may cause “too refined” finite element mesh in planar structural elements. The unnecessary points can be deleted with editing tools (Edit menu) which can be applied for region elements (such as plate, wall regions etc.). For example, stretch the unnecessary points outside the host region, and then cut the stretched region part(s) with the Split tool of the Modify region (Edit menu) or with the Hole tool of the structural planar object.

display_endpoints_un

Figure: Unnecessary definition points detected visually

With the Fill-up with color option the planar objects (plate, wall, drawing regions) can be displayed with their reference plane as colored surface or with their contour lines only. Applying the fill colors is useful to display holes/openings clearly. The filling color of an element is the default color of the Object layer includes the element. It can modified at the layer settings by element types (Plate, Wall etc.) or with the Color option of the Change properties tool (Edit > Properties) by elements (independently from their types).

display_fillingcolor

Figure: Planar objects displayed with their colored surface or without it in Wireframe mode

  • Structure and load labels

Information of structural elements (such as ID, position number, material properties, section names etc.) and load (such as intensity, Comment etc.) can be displayed on the screen by element types in Wireframe display mode.

display_labels

Figure: Info labels displayed on screen by element types

  • Storey

In this section the User can select how the objects can be displayed within the storey.

Every object is displayed which is in the plane of the storey or if it is crossing the range of the storey above or below according to the setting.

To display one of the defined storeys click on the  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image108.png  ikon in the Toolbar, then choose the storey you wish to be displayed:

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image109.png

The pictures below show the whole structure and how its displayed parts depend on the selected option in Settings/Display/Storey dialog.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image110.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image111.png

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image112.png file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image113.png

  • Display local system

The local co-ordinate system of the structural elements can be displayed with the Display local system option by element types. The size of the local system symbol can be set at the Size option. The color of the local system axes can be set at Local systems setting. The default colors are: green for the local x’ axis, red for the local y’ axis and blue for the local z’ axis.

display_localsys

Figure: Local co-ordinate system displayed on screen by element types

  • Special display settings of walls

With the Display wall base line option (3D Structure and Predesign modules only) the bottom end of the walls can be displayed as a hatched surface.

By inactivating the Display wall height option (Plate module only) only the reference support line (as hatched surface) can be displayed without showing the height-extension that is out from the plates’ calculation 2D plane.

display_specwall

Figure: Special display options of walls

  • Special display settings of bar elements

The Display section shape option shows the applied section of the bar elements as a colored symbol in the middle of the bar reference lines. The size (Scale), the filling (Fill) and contour (Border) colors are customizable. Although, section shape symbols are visible in most of the different display modes, their “best” display mode is the Wireframe mode without displaying the elements’ thickness.

The Display connections option shows the end connection property (see Beam, Column or Fictitious bar connection settings) of the bar elements. Only the free end motion components can be displayed as arrows, where a simple arrow shows a motion component by its direction and a double-headed arrow shows the axis direction of a rotation component. The fix (rigid) end connection components are never displayed. The color of an end motion component equals with the color of the proper axis of the host bar element’s local system (see before, Display local system). The size of the symbols can be set at the Size option.

Special display options of bar elements.png display_bars

Figure: Special display options of bar elements

  • Layer, color and pen width

All elements are placed (and grouped) on Object layers according to their type. So, for example, columns are on the “Columns” layer and the walls are on the “Walls” layer. The default color and pen width of elements’ contours/reference lines are represented by their host layers. For example, by default, walls are red, if the color of the “Walls” layer is also red.

display_layers

Figure: Layer-system of structural objects

MCj02990090000%5b1%5d   The default color of an object can be modified independently from their types with the Color option of the Change properties tool (Edit > Properties).

Color schema

This feature lets the users to navigate a model easier, by allowing them to fully customize element colors. These options can be accessed through the Tools à Colors menu command, or by clicking on their icon (file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image120.png ) in the toolbar.

Mode determines the attribute on which the color coding is based. When None is selected, the default colors for object types will be used.

For each object type, the following attributes are available:

Beam, column and trussID, Material, Cross-section
Plane plate and wallID, Material, Thickness
Profiled plate and wallID, Material, Cross-section
Timber panelID, Material
Edge connectionID, Rigidity type

The Manage button can be used to save a specified color coding system. These can be selected afterwards from the drop-down list to the left from the Manage button. Schema color is saved only for a given project.

Clicking the Apply button will apply the color code to the model. Enabling the Auto apply checkbox will apply any changes automatically.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image123.png When a custom color scheme is in use, a legend window will be displayed. With the Position button, the placement of this window can be specified; it can even be hidden. By default, the legend is displayed in the bottom left corner of the screen.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image125.png
Colors, borders, and their line types (with thickness) can be modified by clicking on the Edit palette button. In the dialog box, all parameters can be set for every value of the specified attribute (ID, Material or Thickness). It is possible to save these settings separately to be used in another color scheme.

The Settings button will allow you to save your color scheme to a file (*.cpal) or as default, or load another schema.

MCj04113200000%5b1%5dWhen a color scheme is saved, only the colors and their order will be stored, values need to be specified each time. 
MCj02990090000%5b1%5dPen (line weight) can use pixels as well as millimeters. A positive number means millimeters, while a negative one will give the line width in pixels. A line weight given in millimeters will remain the same in the documentation. When pen size is given in pixels, the line weight will remain the same on-screen, regardless of zoom level.

Geometry

The definition modes and the available shapes of structural elements’ reference line or reference plane depend on:

  • the structural type: 1D Member or Planar Object, and
  • the current FEM-Design module.

The Tool palette of a structural element contains only the available modes. The next table summarizes the geometry possibilities by structural elements.

TypeModules where available

Definition

mode

Geometry
 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image002.png  Soilicon_3DSTRUReference regionfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png  Rectangular
   
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image004.png  Boreholeicon_3DSTRUReference point- (Insertion point)
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image005.png  Isolated foundationicon_3DSTRURegular shapefile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png  Rectangular
   
  Reference solidfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image130.png  Pick existing solid
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image006.png  Wall foundationicon_3DSTRULinefile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image131.png  Straight line
   
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image007.png  Foundation  slabicon_3DSTRURegionfile:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png  Rectangular
   

 

icon_Column  Column

icon_PLATEMODULEReference point- (Insertion point)
 icon_3DSTRU  icon_FRAMEMODULE  icon_PREDESIGNMODULEReference line

 

icon_3DSTRU  icon_FRAMEMODULE  icon_PREDESIGNMODULE

Reference line
icon_3DSTRU  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image140.png   file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image141.pngReference point- (Insertion point)

 

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image142.png  Apex

 

icon_3DSTRU  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image141.pngReference beams-
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image016.png Column corbelicon_3DSTRU file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image141.pngReference point on a column- (Insertion point)
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image016.png Wall corbelicon_3DSTRUReference line

 

icon_Plate  Plate

icon_PLATEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference region

 

icon_Wall  Wall

icon_PLATEMODULEReference line
 icon_WALLMODULE  icon_PLANESTRAINReference region
 icon_3DSTRU  icon_PREDESIGNMODULEReference region
icon_3DSTRUReference region
file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image144.png  Profiled wall Reference region

icon_3DSTRU

 

Reference region

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image145.png  Use as plate:

  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png  Rectangular

  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image127.png  Circular

  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image128.png  Polygonal

  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image129.png  Pick lines

  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image130.png  Pick existing region

  Reference region
icon_PLATEMODULE  icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference point- (Insertion point)

 

icon_LineSupport  icon_LineSupportGroup  Line support

 

icon_PLATEMODULE  icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU  icon_PREDESIGNMODULE

Reference line
icon_PLATEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference region
icon_PLATEMODULE  icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference points- (Insertion points)
icon_PLATEMODULE  icon_WALLMODULE  icon_PLANESTRAIN  icon_FRAMEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference lines
icon_PLATEMODULE  icon_FRAMEMODULE  icon_3DSTRU  icon_PREDESIGNMODULEReference line

 

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image147.png  Cover

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image148.png  Wall type

icon_FRAMEMODULE icon_3DSTRUReference line

 

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image147.png  Cover

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image149.png  Slab or roof type

icon_FRAMEMODULE icon_3DSTRUReference region
icon_FRAMEMODULE icon_3DSTRUReference plane shape-

Table: Structural Objects and their geometry definition

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image131.png  Straight line

The steps of a straight line definition:

  1. Define the start point of the line by giving coordinates or mouse-clicking.
  2. Define the end point of the line by giving coordinates or mouse-clicking.

beam dialog.png wall dialog.png line support dialog.png figure_geom_straight

Figure: Some examples for defining structural objects with Straight line

Although Walls are planar objects with reference line, they are vertical and defined by their base reference line only in the icon_PLATEMODULE  FEM-Design Plate and icon_3DSTRU  3D Structure Modules. The final geometry of the reference region is set by the wall height. The next figure shows the differences of height measuring between the Plate and 3D Structure Modules. Of course, the height defines the position of reference region of curved Walls too.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image155.png

Figure: Height direction of Walls in Plate and 3D Structure Modules

MCj02990090000%5b1%5d    In 3D Structure Module, the rectangle shape of the wall can be edited by the Modify region > Split region tool and other editing tools (Edit menu). Also the Hole tool of Wall tool palette can be used to edit the reference regions.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image156.png

Figure: Some examples for additional editing of Wall region

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image132.png Arc by center, start and end points

The steps of an arc definition with its center, start and end points:

  1. Define the center point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  2. Define the start point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  3. Set the drawing direction (clockwise or counterclockwise) with figure_rightMOUSE  mouse-clicking. Define the end point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking, or set the central angle (4.) by giving its value. Circle can be defined by angle 360°.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image159.png

Figure: Some examples for defining structural objects with Arc by center, start and end points

figure_geom_arcangle

Figure: Drawing direction and angle definition

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image133.png Arc by 3 points

The steps of an arc definition with its three points:

  1. Define the start point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  2. Define the end point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  3. Define the third, peripheral point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image161.png

Figure: Some examples for defining structural objects with Arc by 3 points

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image134.png Arc by start, end point and tangent

The steps of an arc definition with its start, end point and tangent:

  1. Define the start point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  2. Define the end point of the arc by giving coordinates or figure_leftMOUSE  mouse-clicking.
  3. Set the tangent side with figure_rightMOUSE  mouse-clicking. Define the tangent direction from the start point with a third point (e.g. a point on a tangentially connected line) by giving coordinates or figure_leftMOUSE  mouse-clicking.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image162.png
Figure: Some examples for defining structural objects with Arc by 3 points

figure_geom_arctangentdir

Figure: Although same definition points are defined, the tangent side is different

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image130.png Line by selection

The step of a reference line (straight or arc) definition by selecting a previously defined line:

Select lines or region (drawing or structural object) edges define the requested shape of the reference line with one of the selection modes.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image164.png

Figure: An example for defining Wall by selecting all lines

figure_geom_selectedges

Figure: Defining Beams and Walls on Plate edges (1.) and Line supports on Wall edges (2.)

MCj04113200000%5b1%5d                    For Columns in FEM-Design 3D Modules, only vertical lines or edges can be selected.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image166.png

Figure: Column definitions by selecting vertical lines/edges

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image135.png Line by insertion point and height

As a simple definition of Columns in icon_3DSTRU  3D Structure, icon_FRAMEMODULE  3D Frame and icon_PREDESIGNMODULE  PreDesign modules define the position of the Column with its insertion point and height. The positive or negative value of the Height sets the measuring direction of the height.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image167.png

Figure: Column definition with one-click in 3D modules

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image168.png  Select axes

This definition mode is for defining Columns in the intersections of selected axes.

Select axes with one of the selection modes.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image169.png

Figure: An example for defining columns with selecting axes

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image136.png  Vertical line

This is a special tool for defining Column with two points. FEM-Design Columns can be only vertical, so the second point is not needed to be on the column axis, because its vertical distance from the start (first) point defines the height of the column. This Column definition tool is useful, when you do not know the height value of the new column, but points and lines defines the column’s vertical extension (height) can be easily found. Use Object Snap tools to find point defines indirectly the column’s end point.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image170.png

Figure: Examples for defining vertical columns with two points

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png Rectangular

The steps of a rectangular region definition:

I. Rectangle’s edges parallel with the UCS:

  1. Define the point of the first corner by giving coordinates or mouse-clicking.
  2. Define the point of the end corner by giving coordinates or mouse-clicking.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image171.png

Figure: Defining rectangular Plate and Surface support

II. Rectangle’s edges not parallel with UCS:

  1. Click  file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image172.emz  one or two times to define the rectangle’s first edge’s direction
    1. If you click file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image172.emz  one time, the direction is can be defined from the global coordinate system’s origin,
    2. If you click file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image172.emz  one times, the direction is defined in an arbitrary direction.
  2. Define the arbitrary direction of the rectangle’s one line.
  1. Define the point of the first corner by giving coordinates or mouse-clicking.
  2. Define the point of the end corner by giving coordinates or mouse-clicking.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image173.png

Figure: Defining rectangular plate

MCj02990090000%5b1%5d    The geometry of rectangular regions as well as other (later mentioned) region shapes can be edited by the Modify region > Split region tool and other editing tools (Edit menu). Also the Hole tool of planar objects’ definition command can be used to edit the reference regions.

figure_geom_rectedit

Figure: An edited rectangular Plate region

 file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image127.png Circular

The steps of a circular region definition:

  1. Define the center point by giving coordinates or mouse-clicking.
  2. Define the radius by giving its value or a point on the circle (with coordinates or mouse-clicking).

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image175.png

Figure: Defining circular Plate and Surface supports

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image128.png  Polygonal

The steps of a polygonal region definition:

  1. Define the points of the polygon vertexes by giving coordinates or figure_leftMOUSE  mouse-clicking.
  2. Close the polygon with figure_rightMOUSE  mouse-clicking or icon_Enter  key.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image177.png

Figure: Defining polygonal Plate and Surface support

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image129.png Pick lines

With this method, previously defined or imported (DWG/DXF) drawing elements can be used as sketches of structural region shapes. The step of definition:

Select a closed line defines the requested shape of the reference region with mouse-clicking.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image178.png

Figure: Defining Plate and Surface support by using close contours

In case of line junctions, more than one line has to be selected to make clear the continuity of the requested closed contour.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image179.png

Figure: Selection of more lines to define the right path for the closed shape

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image130.png Pick existing region

The step of a reference region definition by selecting a previously defined object or drawing region:

select the region(s) defines the requested shape of the reference region(s) with one of the selection modes.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image180.png

Figure: An example for placing Surface support under a Plate by selecting its region

MCj02990090000%5b1%5d    With Pick existing region, shell (Plate) elements can be easily place on the entire surface or some surface components of a Solid body (Draw > Solid).

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image181.png

Figure: Defining shell (Plate) regions by picking the surface regions of a Solid body

Hole

icon_Hole       Holes, openings and cuttings can be added to reference regions (Plate, Wall and Surface support) with the Hole tool. The following geometries can be used for holes:

The steps of a hole definition:

  1. Select the host region with mouse-clicking. Clicking a region places the UCS into the region plane, so giving hole coordinates needs only X and Y values from the UCS origin.
  2. Define the geometry of the hole with one of the following geometry modes:

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image126.png  Rectangular

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image127.png  Circular

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image128.png  Polygonal

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image129.png  Pick lines

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image183.png

Figure: Examples for holes

figure_holecut

Figure: Hole tool can be used to edit region geometries as cuttings

Holes can be easily copy inside a region or among regions with same reference plane position with the Copy command (Edit menu). It is recommended to display only the regions’ reference plane (inactive Display thickness option) to easily select the contour of the hole you would like to copy. To set the distances/new positions, the UCS has to be in the plane of the host region(s).

figure_holecopy

Figure: Copying holes in a Wall

Direction

Numerous

Tags:
Created by Fredrik Lagerström on 2020/03/19 08:07
Copyright 2022 StruSoft AB
FEM-Design Wiki