Show last authors
1 (% style="text-align: justify;" %)
2 Each FEM-Design module is able to import (and also export) DWG and DXF. All elements, so both structural model and drawing elements, can be converted and exported to DWG/DXF format. The objects are automatically converted to lines with their 3D position and placed onto separate layers by object types. Also, the symbols and info labels are broken to text and line parts.
3
4
5 (% style="text-align: justify;" %)
6 Contents
7
8 {{toc start="2"/}}
9
10
11 ----
12
13 == Basic concept ==
14
15 (% style="text-align: justify;" %)
16 All elements (beams, columns… supports, loads, drawing elements, labels, etc.) will be generated as lines and texts, and they will be placed onto separate drawing layers by their types. All DWG/DXF-compatible applications are able to filter elements by layers during or after the import process. The imported layers will be converted to //Drawing layers//.
17
18 (% style="text-align: justify;" %)
19 [[image:https://wiki.fem-design.strusoft.com/xwiki/wiki/femdesignwiki/download/Manuals/User%20Manual/Model%20and%20Data%20Connections/WebHome/1584369646970-755.png?rev=1.1||alt="1584369646970-755.png"]]
20
21 ----
22
23 == Import ==
24
25
26 1. Load the DWG/DXF file with File > Open.
27 1. Set the import settings in the AutoCAD Import dialog
28 1. Hide the unnecessary drawing layers.
29 1. Create the structural model based on the referenced drawing.
30
31 === Import settings ===
32
33
34 * **Unit** **conversion  **|  Set the same drawing length unit with the unit-system saved in the file by the exporting application.
35 * **Color modes**|  Set one of the three predefined color modes, or define one color.
36 * **Show visible layers only**  |  Check this box in order to see only visible layers in the layer list.
37 * **Do not show empty layers** | Check this box, in order not to see empty layers in the layers list.
38 * **Resolve XRefs** |  Check this box
39
40 === Merge drawings ===
41
42
43 Only one DWG/DXF file can be opened at a time. But, you can merge more than one drawing (e.g. floor plans of different stories) into a project.
44
45 1. Import the first drawing as a new FEM-Design project.
46 1. Open the second/other drawing as a separate FEM-Design project (more than one copies of a FEM-Design module can run in the same time).
47 1. Click Edit > Copy for the required elements of the second/other drawing to send them to Clipboard.
48 1. Click Edit > Paste to merge the drawing elements (from the Clipboard) into the first project. Set the real position of the drawing insertion (point), so for example, place the 2^^nd^^ floor elements in the correct 2^^nd^^ level position.
49
50 === Tips ===
51
52
53 * Hide the unnecessary drawing layers to make clear the points and lines you would like to use for later model definition.
54 * With Modify > Change appearance you can query the host drawing layer of a selected element.
55 * Rotate the position of the drawing, if it is needed. For example set a section/elevation drawing to the Global XZ or YZ plane in 3D modules.
56 * In most cases the drawing elements of the merged DWG/DXF file are placed far from the origin of the global co-ordinate system, so click View > Zoom margin to show the entire drawing after opening it.
57
58 ----
59
60 == Export ==
61
62
63 There are two different ways to export a file to DWG/DXF-format.
64
65 * File > Save as...
66 * File export to DWG/DXF
67
68 === Save as ===
69
70
71 1. Click File > Save as, choose the proper DWG/DXF file type and enter a valid file name.
72 1. Set the export settings in the AutoCAD Export dialog.
73 1. Select the layers to be exported.
74
75 === Export to dwg / dxf ===
76
77
78 Using this method of exporting model to dwg/dfx, it is possible to select the objects that you want to export.
79
80 1. Click File > Export to DWG/DXF
81 1. Select the objects in the 3D window that you want to export.
82 1. In the Save as dialog, choose the proper DWG/DXF file type and enter a valid file name.
83 1. Set the export settings in the AutoCAD Export dialog.
84
85 === Export setting ===
86
87
88 * **Unit  | ** Set the drawing length unit of the exported elements to the type required by the other application which wants to open the DWG/DXF file.
89 * **Show visible layers only  | ** Check this box in order to see only visible layers in the layer list.
90 * **Do not show empty layers** | Check this box, in order not to see empty layers in the layers list.
91 * **AutoCAD version  | ** Select the version of AutoCAD  that should read the file.
92
93 ----
94
95 **Parent topic:** [[Import / Export>>doc:Manuals.User Manual.Import / Export Model.WebHome]]
Copyright 2020 StruSoft AB
FEM-Design Wiki