<
From version < 55.2 >
edited by Fredrik Lagerström
on 2020/03/18 09:38
To version < 55.3 >
edited by Fredrik Lagerström
on 2020/03/18 11:12
>
Change comment: (Autosaved)

Summary

Details

Page properties
Content
... ... @@ -131,3 +131,243 @@
131 131  The Default settings dialog is used to change the properties of new objects. It usually contains a General tab where many commands and identifiers are shown, some dialogs also contains tabs for cross sections, materials and boundary conditions/connections.
132 132  
133 133  [[image:dialog 001.png]]
134 +
135 += Program Settings =
136 +
137 +Clicking //Settings > All// opens a dialog with all available settings of the program and the current project.
138 +
139 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image002.png]]
140 +
141 +Figure: Project and program settings
142 +
143 +The settings are valid for the current project, but they can be extended for later projects by saving them as default settings. //OK// closes the dialog and validates the settings for the current project. //Save as default// set the “selected” project settings available for next projects and new files.
144 +
145 +**[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image003.wmz||alt="MCj04113200000%5b1%5d"]] **“Selected” means that //Save as default// works only for the branch belongs to the list/folder title selected by the cursor. For example, apply //Save as default// for “//Environment//” to save the //General//, the //Directories// and the //Cursor// settings as default, or select “//Settings//” and click //Save as default// to store all current settings as default values.
146 +
147 +The range of available settings depends on the currently opened[[ **Tabmenu**>>path:#_Tabmenus]]. For example, all setting are available at launched “//Structure//” tabmenu, but the settings are reduced with e.g. finite element (//Mesh//) settings in case of activated “//Analysis//” tabmenu.
148 +
149 +The program stores project and default settings in the //fem.ini// file can be found in the “//FEMData//” folder of the installed program.
150 +
151 +New program release can use the default settings of the previous release, if you keep them after the first running of the new release in a warning message dialog.
152 +
153 +==== Environment ====
154 +
155 +
156 +//General// settings enable the user to adjust the main program settings affect on startup, system, rendering and display style.
157 +
158 +* **Check for update at start**
159 +
160 +By default, the program informs the user if a new official release of the current FEM-Design version is available.
161 +
162 +* **Check for upgrade at start**
163 +
164 +It sends a message if a newer commercial FEM-Design version is released. In this case, the newer version can be downloaded, but it can be run only in demo mode till renewing the current license agreement (please contact your local distributor).
165 +
166 +* **Auto load last drawing**
167 +
168 +Checking this box opens the last project at program start-up.
169 +
170 +* **Language**
171 +
172 +By default, the user interface is displayed in the installation language. Ask your local distributor about the available languages in your country.
173 +
174 +* **Timesave [min]**
175 +
176 +It defines the time period in minute for automatic project saving. Read more at [[**Data safety**.>>path:#Data_safety]]
177 +
178 +* **Undo steps**
179 +
180 +The number of executable undo steps can be set in the field. But do not forget, that there are some complex calculation processes (analysis, mesh preparing etc.) //Undo// does not work on.
181 +
182 +* **Graphic engine**
183 +
184 +The suitable graphic engine can be set here by choosing “DirectX” or “OpenGL” according to the video card.
185 +
186 +The DirectX graphic engine is faster than OpenGL on most of the computers. We recommend the User to check which graphic engine performs better on his computer.
187 +
188 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image004.jpg]]
189 +
190 +**//[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image005.wmz||alt="MCj02990090000%5b1%5d"]] //**For more information about the graphic engine read the Remarks.
191 +
192 +**[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image003.wmz||alt="MCj04113200000%5b1%5d"]] **If you have any rendering problem with the default graphic engine, apply the other one. In case of further troubles, download the latest driver of your graphic card.
193 +
194 +“//Safe mode//” is developed to protect the program from possible video drive crashes. If no graphic problem is detected with the current driver, uncheck this box to take the full advantage of the new powerful graphic engine and to reach the maximum rendering speed.
195 +
196 +* **Enable Win8/Win7/Vista style**
197 +
198 +By default, the user interface is developed in the height of Microsoft Windows 8, 7 and Vista fashion. Unchecking the box a simpler interface will be available after restarting the program.
199 +
200 +* **Window background**
201 +
202 +The color of the drawing background (graphical windows) can be set here. The default and suggested color is white. Objects having the same color with the background are always displayed in inverse color.
203 +
204 +* **Display information pop-up**
205 +
206 +If there is no running command, moving the cursor over an element displays an //Information pop-up// with the element’s main properties. Depending on the currently used working mode (//Structure//, //Loads// etc.), pop-up is available for different elements (structural elements, loads etc.) only. For example, the pop-up displays the ID, the material, the thickness, the alignment and orthotropic features for //Plates// in //Structure// mode.
207 +
208 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image006.png||alt="info.png"]]
209 +
210 +Figure: Information pop-up examples
211 +
212 +//Directories// settings allow the user to specify the location of FEM-Design files.
213 +
214 +* **Temporary**
215 +
216 +The program stores temporary files during calculations and mesh generations in the given folder, which will be automatically removed, if the operations are done successfully. Remained temporary files can be erased from the //Temporary// folder after closing the currently opened project. The changes made in //Temporary// directory will affect after the program is restarted.
217 +
218 +* **Working**
219 +
220 +The default favorite folder can be set here for the open and save commands.
221 +
222 +The style of cross-hair cursor can be set in //Cursor// dialog. It can be full-sized in graphical windows or custom-sized (//Limited//) by the scroll tool.
223 +
224 +==== Drawing ====
225 +
226 +
227 +//Title// dialog allows the user to specify the content of drawing title block (//Draw > //[[**Title information table**>>path:#Title_info_table]]) and the header title of printing (//File > Print//). //Project//, //Description//, //Designer//, //Signature// and //Comments// attributes are autotexts. That means, modifying their content updates all titles used in the current project. These five title attributes can be used in documentation and reinforcement list templates with the help of [[**Field**>>path:#Field]]**// //**tool (//Draw// menu).
228 +
229 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image007.png||alt="Title information table.png"]] [[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image008.png||alt="titleinfotable.png"]]
230 +
231 +Figure: Title information table
232 +
233 +//Scale// has effect in displaying texts, line types and wall hatches in graphic windows. Of course, [[**printing scale**>>path:#_Printing]] can be set independently from drawing scale.
234 +
235 +//Param// settings allow the user to specify the default initial settings for drawing (//Draw// menu commands) in the current or later projects (//Save as default//). Line type, pen width and drawing color can be edited independently from the default values with the [[**Status bar**>>path:#_Status_Bar]] tools “//Current style//”, “//Current layer//” and “//Current color//”.
236 +
237 +//Text// settings enable the user to set the default font style and sizes for general text items.
238 +
239 +| |**Text setting effect**
240 +|Drawing Title block|yes
241 +|Structural element ID and label|yes
242 +|Design data label|yes
243 +|Load label|yes
244 +|Mass label|yes
245 +|Support ID and label|yes
246 +|Default settings of //Draw > Text//|yes
247 +|Default settings of numeric result values|yes
248 +|//Draw > Dimension//|no
249 +|Grid axis label (//Structure > Axis//)|no
250 +|Storey label (//Structure > Storey//)|no
251 +|(((
252 +Finite element and node ID
253 +
254 +(//Settings > Display > Mesh//)
255 +)))|no
256 +
257 +Table: List of elements on which Text setting has effect or not
258 +
259 +//Dimension//, //Axis// and //Storey// tools and the finite element display have individual text settings from the general //Text// settings.
260 +
261 +**[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image005.wmz||alt="MCj02990090000%5b1%5d"]] **//Script// solves the character problems of different languages. For example character “**ő**” appears as “**õ**” in “//Western//”, but as correct “**ő**” in “//Central European//” script.
262 +
263 + //Size// is defined in real values (mm), so text size varies on drawings by modifying its //Scale//.
264 +
265 + The //Width// factor 1.0 refers to the normal character width, so factor smaller/greater than 1.0 results a condensed/extended text.
266 +
267 + For “italic” style use //Slant// between 10 or 15 degrees.
268 +
269 +==== Calculation ====
270 +
271 +//Calculation// includes settings influence structural behavior, finite element mesh generation, analysis and result.
272 +
273 +//Code// displays the current and available design code for the current project. //Code// influences:
274 +
275 +* the range of available modeling materials,
276 +* automatic combination of load groups, and
277 +* the method and result of reinforcement, steel and timber design.
278 +
279 +Changing the current code erases the materials, the design parameters and the results in the project, so these properties have to be redefined to run valid calculations later.
280 +
281 +Read more details from other //Calculation// settings in the connected topics:
282 +
283 +* **“Rigid” values**
284 +
285 +The default value of “infinite rigidity” can be set for [[**supports**>>path:#_Supports]], [[**connections**>>path:#_Connection_Objects]] and [[**fictitious bars**>>path:#_Fictitious_Bar]]**// //**by types.
286 +
287 +* **Mesh**
288 +
289 +Mesh and peak smoothing settings of [[**automatic finite element mesh generation**.>>path:#_Mesh_Generation]]
290 +
291 +Perform gives additional features to [[**data safety**.>>path:#Data_safety]]
292 +
293 +* **Analysis**
294 +
295 +In //Analysis// you can decide the way of [[**//Automatic save//**>>path:#Rules_of_time_save]], in //Find identical copies before calculation for// you can// //set if the program should check the identical copies of structural elements and/or loads and in //Warnings //it can be checked if the program should warn about using non-linear elements in a linear calculation.
296 +
297 +
298 +* **Result**
299 +
300 +//Options// define the calculation sections of bars and affect on [[**detailed results**>>path:#_Detailed_Bar_Result]] of bars.
301 +
302 +
303 +==== Display ====
304 +
305 +
306 +The current and default display settings of the drawing elements, numbers, [[**structural objects**>>path:#_Structure_Definition]], [[**loads**>>path:#_Loads]] and [[**finite elements/mesh**>>path:#_Finite_Element_Mesh]] can be set here.
307 +
308 +Displaying structural and analytical element ID’s is separated in order to avoid duplicate labels on the screen. The required ID can be set by Bar and Shell elements in Display settings dialog.
309 +
310 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image009.jpg]]
311 +
312 +Figure: Display settings (Bar, Shell)
313 +
314 +==== Window ====
315 +
316 +
317 +//Co-ordinate systems// include the display settings of the //Global// and the //User-defined// (//UCS//) [[**co-ordinate system**>>path:#_Co-ordinate_Systems]] symbols. The symbols are shown in the defined size in working windows, but they can be hidden by unchecking the //Display co-ordinate systems// box.
318 +
319 +//Grid// defines the distribution settings of the visible [[**Construction grid**.>>path:#_Construction_grid]] The grid can be hidden by unchecking the //Display grid// box. The grid lines can be set to be parallel with the axis directions of the //Global// (//Ground//) or //UCS// system.
320 +
321 +All default settings of [[**Object Snap tools**>>path:#_Object_Snap_Tools]] are grouped in //Snap// dialog.
322 +
323 +In different windows different //scales// can be defined, which is especially useful in documentation module. By choosing an appropriate scale factor the displayed labels are easy to read. In another window the parameters can be decreased to highlight another result.
324 +
325 +//Units// setting offers various unit types for modeling (length, angle, force, mass and cross-sectional data) and for results. Stress and displacement units can be set independently of the length and force units.
326 +
327 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image010.jpg]]
328 +
329 +Figure: Available units
330 +
331 +=== Data Safety ===
332 +
333 +Time saving and protection system ensures more the data safety of working files.
334 +
335 +==== Time Save ====
336 +
337 +
338 +FEM-Design automatically saves copy of the working file by given time period.
339 +
340 +The saving time period can be set in minutes at //Settings > All > Environment > General > System > Timesave//.
341 +
342 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image011.png||alt="egerpad%20copy"]] Working on a project file called e.g. “steel construction.str” in the [[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image012.png||alt="icon_3DSTRU"]] //3D Structure// module with a 15-minute time save period, an extra file will be generated and updated by the time period (0, 15, 30min …) with special extension and in a hidden folder:
343 +
344 +**Rules of time save:**
345 +
346 +* In case of a program crash, the last saved copy opens automatically in the right module.
347 +* If you successfully exit from FEM-Design after saving the current project, its time save copy will be erased from the recovery folder.
348 +* The location of time save files cannot be modified for data safety.
349 +
350 +**[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image003.wmz||alt="MCj04113200000%5b1%5d"]] **Additional automatic savings can be set before and after calculations at //Settings > Calculation > Analysis > Automatic save…//, but automatic savings overwrite the original project file.
351 +
352 +==== Recovery files ====
353 +
354 +
355 +Recovery file command in File menu is for managing time-save files which are generated after some unexpected events. Its tool-window:
356 +
357 +[[image:file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image013.png]]
358 +
359 +Figure: Recovery file dialog
360 +
361 +You can open the desired version and delete the useless ones, and you can also set the sorting criterion, by clicking on File / Date / Size.
362 +
363 +==== Protected Work File ====
364 +
365 +
366 +All working files are locked not to be modified, overwritten by another user or process. Starting a project, a file having the project name with **//.lck//** extension is generated automatically, which guarantees the protection till closing the working file.
367 +
368 +Opening a protected file sends the warning message: “//The file is locked by another user or process.//” You are allowed to open and modify the content of a protected file, but changes can be saved only under a new name (//File > Save as//).
369 +
370 +=== Element Types ===
371 +
372 +
373 +Two main types
Copyright 2020 StruSoft AB
FEM-Design Wiki