<
From version < 29.1 >
edited by Fredrik Lagerström
on 2019/10/18 16:31
To version < 30.1 >
edited by Fredrik Lagerström
on 2019/10/18 16:33
>
Change comment: There is no comment for this version

Summary

Details

Page properties
Content
... ... @@ -10,14 +10,16 @@
10 10  
11 11  [[Menu bar>>doc:||anchor="HMenuBar"]]
12 12  
13 +Tab menus
14 +
13 13  Toolbars
14 14  
15 -Tabmenus
17 +Application window
16 16  
19 +Quick tools
20 +
17 17  Status bar
18 18  
19 -Application window
20 -
21 21  Tool palette
22 22  
23 23  Dialog
... ... @@ -39,6 +39,26 @@
39 39  Menu commands having icons next to their names can be organized in Toolbars around the Application window. Some commands can be executed by hotkey displayed behind the command name.
40 40  
41 41  (% style="text-align: justify;" %)
44 +== Tab menus ==
45 +
46 +Tab menus contain the main functionalities and their order displays the recommended structural design workflow.
47 +
48 +|(% style="background-color:#c0c0c0; width:240px" %)(% style="color:#ffffff" %)**Tab menu**|(% style="background-color:#c0c0c0; width:1238px" %)(% style="color:#ffffff" %)**Function**
49 +|(% style="width:240px" %)Structure|(% style="width:1238px" %)Tools to define axis and storey system, structural elements, supports and connections
50 +|(% style="width:240px" %)Loads|(% style="width:1238px" %)Tools to define load cases, loads, load combinations and load groups
51 +|(% style="width:240px" %)Finite elements|(% style="width:1238px" %)Tools to define finite elements and finite element mesh
52 +|(% style="width:240px" %)Analysis|(% style="width:1238px" %)Tools to run analysis for the current project and to display results
53 +|(% style="width:240px" %)(((
54 +Foundation design
55 +)))|(% style="width:1238px" %)Tools to run automatic and manual design for foundations and to display results
56 +|(% style="width:240px" %)RC design|(% style="width:1238px" %)Tools to run automatic and manual design for concrete elements and to display results
57 +|(% style="width:240px" %)Steel design|(% style="width:1238px" %)Tools to run automatic and manual design for steel bars and to display results
58 +|(% style="width:240px" %)Timber design|(% style="width:1238px" %)Tools to run automatic and manual design for timber elements and to display results
59 +|(% style="width:240px" %)Performance based design|(% style="width:1238px" %)
60 +
61 +By default, Tab menus have different Object layer settings to protect their elements from the others. That means, for example, structural elements (defined at Structure tab) are protected against load editing (Load tab) although they can selected for load definition. Of course, the available layers of tabs can be customized (Status bar > Current layer). The optional module Documentation can be launched from the Tab menus bar
62 +
63 +(% class="wikigeneratedid" style="text-align: justify;" %)
42 42  == Toolbars ==
43 43  
44 44  The Menu bar commands can be grouped in toolbars with their icons and placed next to Application window.
... ... @@ -50,13 +50,56 @@
50 50  Customize… allows you to edit the command content of the toolbar, on which the right-click is used. A toolbar can be moved into new position by dragging it with its “thick vertical line” start.
51 51  
52 52  (% style="text-align: justify;" %)
53 -== Tabmenus ==
75 +== Application window ==
54 54  
55 -Tabmenus contain the main functionalities and their order displays the recommended structural design workflow.
77 +Two main windows types are available in FEM-Design:
56 56  
79 +* Graphical window
80 +It works as a drawing board and displays the model defined in the current project.
81 +* Detailed result window
82 +Analysis and design results with detailed background calculation formulas (code references), figures and tables can be displayed by single elements or by design groups in separate windows. Quick navigation is powered with zooming details.
57 57  
84 +An arbitrary number of windows can be opened (Window menu) to show for example a model in different views at the same time. The list of the currently available windows is shown at the bottom of the windows (tabs) and in the Window menu. You can swap between the windows by clicking on their name tabs or by choosing the requested one in the Window menu. Applied windows can be arranged by Window > Arrange. Right-clicking on a window tab, the window’s name can be edited.
58 58  
86 +[[image:application window_FD19.00.001.png]]
59 59  
88 +== Quick tools ==
89 +
90 +x
91 +
92 +== Status bar ==
93 +
94 +The Status bar is situated under the Application window and separated into the following parts.
95 +
96 +[[image:status bar_FD19.00.001.png]]
97 +
98 +* Selection
99 +Number of the selected elements (bars, shells, supports, loads, etc.) can be seen in the lower part of design area.
100 +* Co-ordinate box
101 +It shows the exact coordinates of the crosshair cursor in the current co-ordinate system. Coordinates can be also given for point/direction definition in a dialog appears after clicking on the Co-ordinate box (see Entering Co-ordinates).
102 +* “Current layer” button
103 +Clicking the button opens a dialog contains the layer-system of the current project. All layer operations like defining new, renaming, color-assignment, showing/hiding and deleting are available in the layer-system dialog. The “//Current layer//” button displays the name of the current drawing layer.
104 +* “Current style” button
105 +This button shows the line type currently available for drawing lines, arc, circles, edges etc. (Draw menu). Clicking the button opens a dialog, where new line type can be defined or line types can be edited.
106 +* Point/Direction editor
107 +Editor tools provide reference points and lines by using existing lines and points during element definition, drawing and editing.
108 +* Object snap tools
109 +Here you can set the snapping distance and turn object snaps on and off.
110 +* “Current color” button
111 +Here you can set the drawing color independently from the color of the current drawing layer. This color is used for numeric values on result figures too.
112 +* “OK” and “Cancel” buttons
113 +These tools approve or reject the current operation.
114 +* Command line
115 +Here you can directly communicate with the program for example by typing coordinate values in it. In the command line coordinates can be defined in several ways (see Entering Coordinates). Command line also displays additional messages to show the steps of the current command.
116 +
117 +== Tool palette ==
118 +
119 +x
120 +
121 +== Dialog ==
122 +
123 +x
124 +
60 60  = {{id name="Settings"/}}Settings =
61 61  
62 62  
Copyright 2020 StruSoft AB
FEM-Design Wiki