User interface

Each module has a similar user interface and consists of the following parts:

Menu bar | Tab menus | Toolbars | Application window | Quick tools | Status bar | Tool palette | Dialog

Window-001c.gif
 

Menu Bar

The Menu bar contains file operations (File), editing commands (Edit), drawing (Draw), assistant tools (Tools), settings (Settings), views (View), window-system (Window) and user-guides, license info and about (Help).

Menu commands having icons next to their names can be organized in Toolbars around the Application window. Some commands can be executed by hotkey displayed behind the command name.

Tab menus

Tab menus contain the main functionalities and their order displays the recommended structural design workflow.

Tab menuFunction
1584520572121-451.pngTools to define axis and storey system, structural elements, supports and connections
1584520578867-196.pngTools to define load cases, loads, load combinations and load groups
1584520584481-921.pngTools to define finite elements and finite element mesh
1584520590723-456.pngTools to run analysis for the current project and to display results

Foundation design

Tools to run automatic and manual design for foundations and to display results
1584520597599-565.pngTools to run automatic and manual design for concrete elements and to display results
1584520604845-203.pngTools to run automatic and manual design for steel bars and to display results
1584520611557-473.pngTools to run automatic and manual design for timber elements and to display results
Performance based designOnly available for Turkish seismic analysis

By default, Tab menus have different Object layer settings to protect their elements from the others. That means, for example, structural elements (defined at Structure tab) are protected against load editing (Load tab) although they can selected for load definition. Of course, the available layers of tabs can be customized (Status bar > Current layer). The optional module Documentation can be launched from the Tab menus bar

Toolbars

The Menu bar commands can be grouped in toolbars with their icons and placed next to Application window.

By default, all five toolbars are displayed. If you right-click anywhere on the menu or on one of the displayed toolbars, a list appears, where toolbars can be set visible or hidden.

customize toolbar 001.png

Customize… allows you to edit the command content of the toolbar, on which the right-click is used. A toolbar can be moved into new position by dragging it with its “Top/Left thick horizontal/vertical line”.

Application window

Two main windows types are available in FEM-Design:

  • Graphical window
    It works as a drawing board and displays the model defined in the current project.
  • Detailed result window
    Analysis and design results with detailed background calculation formulas (code references), figures and tables can be displayed by single elements or by design groups in separate windows. Quick navigation is powered with zooming details.

An arbitrary number of windows can be opened (Window menu) to show for example a model in different views at the same time. The list of the currently available windows is shown at the bottom of the windows (tabs) and in the Window menu. You can swap between the windows by clicking on their name tabs or by choosing the requested one in the Window menu. Applied windows can be arranged by Window > Arrange. Right-clicking on a window tab, the window’s name can be edited.

application window_FD19.00.001.png

Quick tools

Quick tools is a tool window that contains the often used functions such Layers, Results and Filter.

Quick tools 001.png

Quick tools can be enabled in several ways:

  1. Settings > Environment > General > Quick tools
  2. Right click on the toolbars > Quick tools
  3. Window tab > Other windows > Quick tools

Quick tool window can be placed anywhere on the screen and it can be docked to the left and right side of the FEM-Design model view area. The docked Quick tool window can be also collapsed.

Quick tools 002.png

Status bar

The Status bar is situated under the Application window and separated into the following parts.

status bar_FD19.00.001.png

  • Command
    Field to enter coordinates and shortcut commands. Command line also displays additional messages to show the steps of the current command.
  • Selection
    Number of the selected elements (bars, shells, supports, loads, etc.) can be seen in the lower part of design area.
  • Co-ordinate box
    It shows the exact coordinates of the crosshair cursor in the current co-ordinate system. Coordinates can be also given for point/direction definition in a dialog appears after clicking on the Co-ordinate box (see Entering Co-ordinates).
  • Layer button
    Clicking the button opens the Quick tools-tab. All layer operations like defining new, renaming, color-assignment, showing/hiding and deleting are available in the layer-system dialog.
  • Point/Direction editor
    Editor tools provide reference points and lines by using existing lines and points during element definition, drawing and editing.
  • Object snap tools
    Here you can set the snapping distance and turn object snaps on and off.

Tool palette

In most cases, a command/tool has own palette (Tool palette) that contains its definition and setting tools.

toolbar 001.png

Figure: An example for tool palette (Beam command in 3D Structure module)

The parts of a tool palette are:

  • Toolbar - It gives the editing modes and their additional tools. The main editing modes are:
    • Define: creates new objects according to its current settings (“Default settings”).
    • Properties: asks and/or changes the properties of selected object(s).
  • Default settings - If this button has 3D shape, then you can set all default parameters for the new object. Otherwise, it only shows the symbol of the function.
  • Main settings - The frequently changed parameters of the new object (Define) can be set directly in tool palette.

You can usually use a dialog to modify the settings, the properties of a command; it contains text and number fields where you can set parameter values.
The main difference between dialogs and Tool palettes is that you can work beside an opened tool palette, but cannot at a dialog.
There are three main switch types at a dialog or a tool palette: check boxes, radio and chain buttons.

Chain button 001.png

Figure: Function of chain buttons

In case chain button exists and it is “Active” (pushed in), any changes made to the related edit box will be transferred to the next edit box automatically. It gives a quick definition of defining surface elements with constant thickness, loads with constant intensities etc.

Dialog

The Default settings dialog is used to change the properties of new objects. It usually contains a General tab where many commands and identifiers are shown, some dialogs also contains tabs for cross sections, materials and boundary conditions/connections.

dialog 001.png

Program Settings

Clicking Settings > All opens a dialog with all available settings of the program and the current project.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image002.png

Figure: Project and program settings

The settings are valid for the current project, but they can be extended for later projects by saving them as default settings. OK closes the dialog and validates the settings for the current project. Save as default set the “selected” project settings available for next projects and new files.

MCj04113200000%5b1%5d   “Selected” means that Save as default works only for the branch belongs to the list/folder title selected by the cursor. For example, apply Save as default for “Environment” to save the General, the Directories and the Cursor settings as default, or select “Settings” and click Save as default to store all current settings as default values.

The range of available settings depends on the currently opened Tabmenu. For example, all setting are available at launched “Structure” tabmenu, but the settings are reduced with e.g. finite element (Mesh) settings in case of activated “Analysis” tabmenu.

The program stores project and default settings in the fem.ini file can be found in the “FEMData” folder of the installed program.

New program release can use the default settings of the previous release, if you keep them after the first running of the new release in a warning message dialog.

Environment

General settings enable the user to adjust the main program settings affect on startup, system, rendering and display style.

  • Check for update at start

By default, the program informs the user if a new official release of the current FEM-Design version is available.

  • Check for upgrade at start

It sends a message if a newer commercial FEM-Design version is released. In this case, the newer version can be downloaded, but it can be run only in demo mode till renewing the current license agreement (please contact your local distributor).

  • Auto load last drawing

Checking this box opens the last project at program start-up.

  • Language

By default, the user interface is displayed in the installation language. Ask your local distributor about the available languages in your country.

  • Timesave [min]

It defines the time period in minute for automatic project saving. Read more at Data safety.

  • Undo steps

The number of executable undo steps can be set in the field. But do not forget, that there are some complex calculation processes (analysis, mesh preparing etc.) Undo does not work on.

  • Graphic engine

The suitable graphic engine can be set here by choosing “DirectX” or “OpenGL” according to the video card.

The DirectX graphic engine is faster than OpenGL on most of the computers. We recommend the User to check which graphic engine performs better on his computer.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image004.jpg

MCj02990090000%5b1%5d For more information about the graphic engine read the Remarks.

MCj04113200000%5b1%5d   If you have any rendering problem with the default graphic engine, apply the other one. In case of further troubles, download the latest driver of your graphic card.

Safe mode” is developed to protect the program from possible video drive crashes. If no graphic problem is detected with the current driver, uncheck this box to take the full advantage of the new powerful graphic engine and to reach the maximum rendering speed.

  • Enable Win8/Win7/Vista style

By default, the user interface is developed in the height of Microsoft Windows 8, 7 and Vista fashion. Unchecking the box a simpler interface will be available after restarting the program.

  • Window background

The color of the drawing background (graphical windows) can be set here. The default and suggested color is white. Objects having the same color with the background are always displayed in inverse color.

  • Display information pop-up

If there is no running command, moving the cursor over an element displays an Information pop-up with the element’s main properties. Depending on the currently used working mode (Structure, Loads etc.), pop-up is available for different elements (structural elements, loads etc.) only. For example, the pop-up displays the ID, the material, the thickness, the alignment and orthotropic features for Plates in Structure mode.

info.png

Figure: Information pop-up examples

Directories settings allow the user to specify the location of FEM-Design files.

  • Temporary

The program stores temporary files during calculations and mesh generations in the given folder, which will be automatically removed, if the operations are done successfully. Remained temporary files can be erased from the Temporary folder after closing the currently opened project. The changes made in Temporary directory will affect after the program is restarted.

  • Working

The default favorite folder can be set here for the open and save commands.

The style of cross-hair cursor can be set in Cursor dialog. It can be full-sized in graphical windows or custom-sized (Limited) by the scroll tool.

Drawing

Title dialog allows the user to specify the content of drawing title block (Draw > Title information table) and the header title of printing (File > Print). Project, Description, Designer, Signature and Comments attributes are autotexts. That means, modifying their content updates all titles used in the current project. These five title attributes can be used in documentation and reinforcement list templates with the help of Field tool (Draw menu).

Title information table.png titleinfotable.png

Figure: Title information table

Scale has effect in displaying texts, line types and wall hatches in graphic windows. Of course, printing scale can be set independently from drawing scale.

Param settings allow the user to specify the default initial settings for drawing (Draw menu commands) in the current or later projects (Save as default). Line type, pen width and drawing color can be edited independently from the default values with the Status bar tools “Current style”, “Current layer” and “Current color”.

Text settings enable the user to set the default font style and sizes for general text items.

 Text setting effect
Drawing Title blockyes
Structural element ID and labelyes
Design data labelyes
Load labelyes
Mass labelyes
Support ID and labelyes
Default settings of Draw > Textyes
Default settings of numeric result valuesyes
Draw > Dimensionno
Grid axis label (Structure > Axis)no
Storey label (Structure > Storey)no

Finite element and node ID

(Settings > Display > Mesh)

no

Table: List of elements on which Text setting has effect or not

Dimension, Axis and Storey tools and the finite element display have individual text settings from the general Text settings.

MCj02990090000%5b1%5d   Script solves the character problems of different languages. For example character “ő” appears as “õ” in “Western”, but as correct “ő” in “Central European” script.

            Size is defined in real values (mm), so text size varies on drawings by modifying its Scale.

            The Width factor 1.0 refers to the normal character width, so factor smaller/greater than 1.0 results a condensed/extended text.

            For “italic” style use Slant between 10 or 15 degrees.

Calculation

Calculation includes settings influence structural behavior, finite element mesh generation, analysis and result.

Code displays the current and available design code for the current project. Code influences:

  • the range of available modeling materials,
  • automatic combination of load groups, and
  • the method and result of reinforcement, steel and timber design.

Changing the current code erases the materials, the design parameters and the results in the project, so these properties have to be redefined to run valid calculations later.

Read more details from other Calculation settings in the connected topics:

  • “Rigid” values

The default value of “infinite rigidity” can be set for supports, connections and fictitious bars by types.

  • Mesh

Mesh and peak smoothing settings of automatic finite element mesh generation.

Perform gives additional features to data safety.

  • Analysis

In Analysis you can decide the way of Automatic save, in Find identical copies before calculation for you can set if the program should check the identical copies of structural elements and/or loads and in Warnings it can be checked if the program should warn about using non-linear elements in a linear calculation.

  • Result

Options define the calculation sections of bars and affect on detailed results of bars.

Display

The current and default display settings of the drawing elements, numbers, structural objects, loads and finite elements/mesh can be set here.

Displaying structural and analytical element ID’s is separated in order to avoid duplicate labels on the screen. The required ID can be set by Bar and Shell elements in Display settings dialog.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image009.jpg

Figure: Display settings (Bar, Shell)

Window

Co-ordinate systems include the display settings of the Global and the User-defined (UCS) co-ordinate system symbols. The symbols are shown in the defined size in working windows, but they can be hidden by unchecking the Display co-ordinate systems box.

Grid defines the distribution settings of the visible Construction grid. The grid can be hidden by unchecking the Display grid box. The grid lines can be set to be parallel with the axis directions of the Global (Ground) or UCS system.

All default settings of Object Snap tools are grouped in Snap dialog.

In different windows different scales can be defined, which is especially useful in documentation module. By choosing an appropriate scale factor the displayed labels are easy to read. In another window the parameters can be decreased to highlight another result.

Units setting offers various unit types for modeling (length, angle, force, mass and cross-sectional data) and for results. Stress and displacement units can be set independently of the length and force units.

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image010.jpg

Figure: Available units

Data Safety

Time saving and protection system ensures more the data safety of working files.

Time Save

FEM-Design automatically saves copy of the working file by given time period.

The saving time period can be set in minutes at Settings > All > Environment > General > System > Timesave.

egerpad%20copy   Working on a project file called e.g. “steel construction.str” in the icon_3DSTRU  3D Structure module with a 15-minute time save period, an extra file will be generated and updated by the time period (0, 15, 30min …) with special extension and in a hidden folder:

Rules of time save:

  • In case of a program crash, the last saved copy opens automatically in the right module.
  • If you successfully exit from FEM-Design after saving the current project, its time save copy will be erased from the recovery folder.
  • The location of time save files cannot be modified for data safety.

MCj04113200000%5b1%5d   Additional automatic savings can be set before and after calculations at Settings > Calculation > Analysis > Automatic save…, but automatic savings overwrite the original project file.

Recovery files

Recovery file command in File menu is for managing time-save files which are generated after some unexpected events. Its tool-window:

file:///C:/Users/Fredrik/AppData/Local/Temp/msohtmlclip1/01/clip_image013.png

Figure: Recovery file dialog

You can open the desired version and delete the useless ones, and you can also set the sorting criterion, by clicking on File / Date / Size.

Protected Work File

All working files are locked not to be modified, overwritten by another user or process. Starting a project, a file having the project name with .lck extension is generated automatically, which guarantees the protection till closing the working file.

Opening a protected file sends the warning message: “The file is locked by another user or process.” You are allowed to open and modify the content of a protected file, but changes can be saved only under a new name (File > Save as).

Element Types

Two main types

Tags: Manual
Copyright 2022 StruSoft AB
FEM-Design Wiki