0 Votes

Eszközök

Last modified by Hamid Richard Allili on 2023/04/04 16:55

Tartalomjegyzék


Megjegyzés eszköz

Egy vadonatúj eszköz került bevezetésre a szerkezettervező felek közötti kommunikáció egyszerűsítésére, a modell elemekhez és terhekhez fűzhető megjegyzések létrehozásának lehetőségével egy FEM-Design projekten belül. Egy Megjegyzés tetszőleges címmel, üzenettartalommal, kategóriával, színnel és betűstílussal rendelkezik, valamint ellátható felhasználó-idő-bélyeggel is. Mivel a Megjegyzések a modellben tárolódnak, azok mások számára is olvashatóak, módosíthatóak és bővíthetőek a projekt fájl megosztásával.

Megj1.png

Kategória

A Kategória bármire utalhat, ami az adott projekt szempontjából releváns: a megjegyzés jellegére, a probléma súlyosságára, a feladat típusára, a kérdésben érintett személyre, stb. Választhatunk néhány előre meghatározott kategória között (Beállítások >), de lehetőségünk van saját kategóriák létrehozására is, egyedi megjelenési stílussal felruházva (Beállítások > Mentés).

Megj2.png

Bélyegbeszúrás

Egy megjegyzést elláthatunk egy vagy több (pl. párbeszéd esetén) automatikus dátum/idő/felhasználónév bejegyzéssel a Bélyegbeszúrás funkcióra kattintva. A felhasználói nevet a Beállítások > Munkakörnyezet > Általános menüpontban adhatjuk meg.

Megjegyzés-pozíció

Egy megjegyzés lehet:

  • szerkezeti vagy teher-objektumhoz kötött, vagy
  • független, a modelltérben szabadon elhelyezett.

Megj3.png

Az "Objektumhoz kötött" megjegyzések együtt mozognak a gazdaobjektummal, és referenciapontjuk mindig az objektum közepén van. A Mozgatás paranccsal (Módosítás menü) külön mozgathatjuk a címke pozícióját a referenciaponthoz képest. A "Szabad" megjegyzések szabadon mozgathatóak referenciapontjukkal együtt a Mozgatás paranccsal.

Megjegyzések kezelése

Egy problémát kifejező megjegyzés érvényessége és fontossága a projekt élete során módosítható pl. Kategória váltással (a Tulajdonságok funkcióval), vagy egyszerűen törölhető a Megjegyzés eszköz Törlés parancsával, ha már nem releváns és nem akarjuk tovább tárolni. 

Note4.png

Az összes megjegyzés egy közös összefoglaló táblázatban együttesen is kezelhető, szerkeszthető. A táblázat a Megjegyzés eszköz Intéző funkciójával érhető el, ahol a megjegyzések

  • Kategória vagy Cím szerint rendezhetőek, illetve
  • többes kijelölésük egyszerre szerkeszthető vagy törölhető.

Megj4.png

Ha egy megjegyzés látható az aktuális ablakban (például "kötött" típus esetén a gazdaobjektuma nincs elrejtve), akkor a táblázatban kiválasztva a modelltérben is kiemelve jelenik meg. A lista szűkíthető csak a modelltérben aktuálisan látható megjegyzésekre is.

Megjegyzések elrejtése/megjelenítése

A megjegyzések megjelenítése egyszerűen és gyorsan ki-/bekapcsolható a modelltérben: Gyorsmenü > Megjelenítési beállítások > Részletes beállítások > Címke, Megjegyzés, Jelölő.

Megj5.png

Szűrés a megjegyzések között

A megjegyzések kereshetők és kiválaszthatók a modelltérben Kategóriájuk alapján a Gyorsmenü Szűrő eszközével.

Megj6.png


Naplózás eszköz

Az új Naplózás eszközzel (Eszközök menü) minden fél, aki egy közös FEM-Design modellen dolgozik, megjegyzéseket fűzhet a projekthez. A Naplózás eszköz csak egyszerű, formázatlan szöveget tesz lehetővé, de külső szöveges tartalom más programokból is beilleszthető (másolás/beillesztés funkcióval). Az Új bejegyzés  gombra kattintva beilleszthetjük a felhasználónevet, az aktuális dátumot és időt. A régi bejegyzések szükség szerint módosíthatók vagy törölhetőek. Az új megjegyzés, a napló bővítése vagy módosítása az OK gombra kattintva rögzíthető.

naplo-1.png

A felhasználónevet a Beállítások > Munkakörnyezet > Általános menüpontban adhatjuk meg. Itt aktiválhatjuk azt is, hogy a projekt minden mentésekor megnyíljon a Naplózás egy új bejegyzés megadása céljából.

naplo-2.png


Fájl-összehasonlítás eszköz

A vadonatúj Fájl-összehasonlítás eszköz (Szerkesztés menü) lehetővé teszi két FEM-Design fájl, azaz egy projekt két verziója közötti különbségek felfedezését és a változások lekövetését. Az eszköz összehasonlítja az éppen megnyitott modellt annak valamelyik kiválasztott verziójával (pl. egy újabbal), és listázza illetve a modelltérben vizuálisan megjeleníti az elfogadandó vagy elutasítandó különbségeket. Az eszköz igazán hasznos, amikor a tervezőcsapat tagjának ellenőriznie kell mások változtatásait, vagy össze kell hasonlítania egy projekt tervezési alternatíváit.

compare-01.png

Megjegyzések

  • Az összehasonlítás jelenleg a FEM-Design következő natív fájlformátumaira működik: .str és .StruXML.
  • Az összehasonlítás az objektumok globális egyedi azonosítóin alapul, amelyek objektumlétrehozáskor automatikusan az objektumokhoz vannak rendelve, és értékeik mindaddig változatlanok maradnak, amíg az objektumok léteznek.
  • Az összehasonlítás korlátozás nélkül ellenőrzi a szerkezetraszter (pl. Tengely), az alapozás, a rúd, a héj, a támasz és Support és modellezési eszköz (pl. kapcsolati elemek, fiktív rúd) objektumok változásait, valamint a megtámasztó szerkezetükre vonatkozó kisebb korlátozásokkal a Burkolat objektumok változásait.

Az összehasonlítás folyamata

Miközben a FEM-Design programban a vizsgálandó projekt egyik modellverziója meg van nyitva, indítsuk el a Fájl-összehasonlítás parancsot (Szerkesztés menü). A megjelenő Megnyitás párbeszédablakban válasszuk ki és nyissuk meg a projekt összehasonlítandó verzióját, és a program automatikusan összehasonlítja a két verzió tartalmát, és egy új, ún. "Összehasonlítás" üzemmódba lépve listázza illetve megjeleníti a különbségeket.

compare-02b.png

A Különbségek párbeszédpanel listázza az összehasonlítás eredményét, a megváltozott objektumokat. A gyors megértést és az áttekinthetőséget segítve (a modelltérbeli megjelenítéssel összhangban) különböző színek jelzik a változás típusát, ún. Státuszát: Új / Módosult / Törölt. A különbözőségben érintett objektumokat Azonosítójuk és típusuk (Objektum) képviselik a táblázatban.

A Módosult objektumok esetében a táblázat utolsó három oszlopa jelzi a különbség okát, azaz miben történt a változás:

  • Típusváltozás (Ti): pl. egy Oszlop Fal objektummá lett konvertálva;
  • Tulajdonságváltozás (Tu): pl. anyag, keresztmetszet, merevség, vagy más objektum tulajdonság megváltozása (lásd később);
  • Geometriaváltozás (Ge): pl. bármilyen méret- vagy pozícióváltozás.

A különbségek sorbarendezhetőek Objektum típus és Státusz szerint.

Összetett objektumok esetén, mint például a Falak Élkapcsolatokkal, az egyes részobjektumok változásait a különbség-bejegyzés kibontásával (fekete háromszögre kattintva) lehet megtekinteni. Az Összes kibontása gomb ezt automatikusan megteszi a listában szereplő összes bejegyzésre.

compare-03.png

"Összehasonlítás" üzemmódban is elérhetőek bizonyos FEM-Design eszközpaletta parancsok, melyek értelmezhetőek a megjelenített különbségekre, illetve azok érintett objektumaira. Ilyenek például a Mérés eszköz (pl. távolság, hosszváltozás mérésére), a Gyorsmenü megjelenítési eszközei (fóliák, feliratozás, stb.) és a Nézet menü eszközei (pl. Objektum elrejtés/mutatás, Átlátszóság, megjelenítési módok, szintenkénti megjelenítés). A megjelenítési eszközök mind azt segítik, hogy könnyen leszűrhessük és megtalálhassuk a valóban fontos különbségeket és érintett objektumaikat. Objektum elrejtés esetében a Különbségek listája szűkíthető csak a modelltérben látható objektumokra (Csak a látható különbségek listázása funkcióval).

Az objektumok gyorsan elrejthetők vagy megjeleníthetők a változás típusának megfelelően, a Megjelenítés jelölőnégyzeteit ki-/bekapcsolva.

compare-04.png

Tulajdonságok

Tulajdonságváltozás esetén a Lekérdezés > Tulajdonságok eszközzel ellenőrizhetjük, mely tulajdonság paraméterekben történt a változás. Lekérhetjük a tulajdonságait külön-külön a változáspár aktuális vagy új verziójú objektumának is, de a Mindkettő opcióval közvetlenül detektálhatjuk a megváltozott tulajdonságokat. A következő ábrán jól látható, hogy a kijelölt Tömör lemez objektumnak megváltozott a vastagsága (üresek a t1/t2/t3 vastagság mezők) és az anyaga (nincs kijelölt anyag).

compare-05c.png

A Tulajdonságok Aktuális vagy Új funkciójával egy geometriailag módosított objektumra állva kontúr-kiemelés segít az objektum aktuális és új állapota közötti megkülönböztetésben.

compare-06b.png

Az Új vagy Törölt Státuszú objektumok tulajdonságai is lekérdezhetőek a Lekérdezés > Tulajdonságok eszközzel.

Különbségek jóváhagyása illetve elvetése

A különbségeket (törléseket, új objektumok létrehozását és módosításokat) egyenként vagy többszörös kijelöléssel jóváhagyhatjuk vagy elvethetjük. Ezt megtehetjük a listatáblázatban (Jóváhagyás/Elvetés gombok) vagy a modelltérben (Megoldás eszközkészlet pipa és X funkciója) egyaránt. A következő ábra egy példát mutat arra, amikor az összes újonnan létrehozott (Új Státuszú) objektumot jóváhagytuk. A teljes különbségkezelést a Kilépés compare-09.png gombra (a főablak jobb felső sarkában) kattintva fejezhetjük be, és ​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​​az aktuális modell frissül a jóváhagyott módosításokkal.

compare-07.png

Megjegyzés

Ha úgy lépünk ki a különbségkezelésből, hogy maradtak olyan különbségek, melyeket nem zártunk le jóváhagyással vagy elvetéssel, akkor egy figyelmeztető üzenet értesít erről. Az Igen gomb megnyomására a rendszer elveti az összes le nem kezelt különbséget. A Nem gombbal visszatérhetünk a még megmaradó különbségekhez és folytathatjuk lezárásukat.

compare-08.png


A Jelölő megjelenítési opciói

A FEM-Design Jelölők hasznos információs elemek, melyeket a Modelljavítás és az Analitikus modell igazítás eszközök egyaránt használnak a geometriai módosítások javaslatainak illetve eredményeinek megjelölésére/megjelenítésére. Egy új Gyorsmenü opciónak köszönhetően, a Jelölők megjelenítése egyszerűen és gyorsan ki-/bekapcsolható a modelltérben (Megjelenítési beállítások > Részletes beállítások > Címke, Megjegyzés, Jelölő).

Jelolo.gif